You are not logged in.

#1 2021-06-11 02:01:57

verticalegg
Member
Registered: 2021-06-11
Posts: 2

[SOLVED] Locale problems with KDE Plasma

I've been trying to nail down this problem for a while - one application has been complaining about my locale being set to "EN_US.UTF-8" instead of "en_US.UTF-8". I believe the problem is from KDE Plasma, since even after running locale-gen multiple times the output of locale is still

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=EN_US.UTF-8
LC_CTYPE="EN_US.UTF-8"
LC_NUMERIC="EN_US.UTF-8"
LC_TIME="EN_US.UTF-8"
LC_COLLATE="EN_US.UTF-8"
LC_MONETARY="EN_US.UTF-8"
LC_MESSAGES="EN_US.UTF-8"
LC_PAPER="EN_US.UTF-8"
LC_NAME="EN_US.UTF-8"
LC_ADDRESS="EN_US.UTF-8"
LC_TELEPHONE="EN_US.UTF-8"
LC_MEASUREMENT="EN_US.UTF-8"
LC_IDENTIFICATION="EN_US.UTF-8"
LC_ALL=

Strangely, localectl shows

   System Locale: LANG=en_US.UTF-8
       VC Keymap: n/a
      X11 Layout: n/a

I'm not sure what my next steps should be here, since KDE doesn't allow setting the locale string directly. Any help is appreciated.

Last edited by verticalegg (2021-06-11 20:41:02)

Offline

#2 2021-06-11 08:13:34

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,994

Re: [SOLVED] Locale problems with KDE Plasma

What's the "Regional Settings" -> "Formats" in systemsettings set to? Make sure that properly reads one of the en_US variants.

That said logically speaking plasma writes that into ~/.config/plasma-localerc which you could either remove or fix the LANG= string if that happens to be wrong

Offline

#3 2021-06-11 20:39:30

verticalegg
Member
Registered: 2021-06-11
Posts: 2

Re: [SOLVED] Locale problems with KDE Plasma

Fixing the plasma-localerc worked and everything seems to be working now. Marking as solved.

Offline

Board footer

Powered by FluxBB