You are not logged in.

#1 2021-06-12 08:22:21

malacology
Member
Registered: 2021-04-24
Posts: 135

error while loading shared libraries: libncurses.so.5: cannot open sha

The first error report is after install aur/ncurses5-compat-libs and the second error report is after remove aur/ncurses5-compat-libs

░▒▓ ~/Dow/tnt64 ▓▒░ ./tnt                 ░▒▓ ✔  16:15:49 ▓▒░
./tnt: /usr/lib/libncurses.so.5: version `NCURSES_5.7.20081102' not found (required by ./tnt)
./tnt: /usr/lib/libncurses.so.5: version `NCURSES_5.0.19991023' not found (required by ./tnt)
░▒▓ ~/Dow/tnt64 ▓▒░ ./tnt               ░▒▓ 1 ✘  16:15:55 ▓▒░
./tnt: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

Don't speak to silly man. Keep Minimalism.

Offline

#2 2021-06-12 10:07:02

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,596

Re: error while loading shared libraries: libncurses.so.5: cannot open sha

$ ls -l /usr/lib/libncurses.so.5 
lrwxrwxrwx 1 root root 25 12 jun 11:53 /usr/lib/libncurses.so.5 -> /usr/lib/libncursesw.so.5
$ ls -l /usr/lib/libncursesw.so.5
lrwxrwxrwx 1 root root 18 12 jun 11:53 /usr/lib/libncursesw.so.5 -> libncursesw.so.5.9
$ $ ls -l /usr/lib/libncursesw.so.5.9 
-rwxr-xr-x 1 root root 412808 12 jun 11:53 /usr/lib/libncursesw.so.5.9
$

It looks like ./tnt wants and older version of ncurses .
I can't find a tnt pacakge in repos and aur page for ncurses5-compat-libs doesn't list doesn't it also .
Where does ./tnt come from ?


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2021-06-12 12:00:31

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,507
Website

Re: error while loading shared libraries: libncurses.so.5: cannot open sha

Mod note: Moving to AUR Issues.


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#4 2021-06-12 15:25:18

malacology
Member
Registered: 2021-04-24
Posts: 135

Re: error while loading shared libraries: libncurses.so.5: cannot open sha

Lone_Wolf wrote:
$ ls -l /usr/lib/libncurses.so.5 
lrwxrwxrwx 1 root root 25 12 jun 11:53 /usr/lib/libncurses.so.5 -> /usr/lib/libncursesw.so.5
$ ls -l /usr/lib/libncursesw.so.5
lrwxrwxrwx 1 root root 18 12 jun 11:53 /usr/lib/libncursesw.so.5 -> libncursesw.so.5.9
$ $ ls -l /usr/lib/libncursesw.so.5.9 
-rwxr-xr-x 1 root root 412808 12 jun 11:53 /usr/lib/libncursesw.so.5.9
$

It looks like ./tnt wants and older version of ncurses .
I can't find a tnt pacakge in repos and aur page for ncurses5-compat-libs doesn't list doesn't it also .
Where does ./tnt come from ?

TNT is from http://www.lillo.org.ar/phylogeny/tnt/


Don't speak to silly man. Keep Minimalism.

Offline

#5 2021-06-13 10:10:43

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,596

Re: error while loading shared libraries: libncurses.so.5: cannot open sha

$ strings /usr/lib/libncursesw.so.5.9 | grep NCURSES
NCURSES_TIC_5.0.19991023
NCURSES_TIC_5.1.20000708
NCURSES_TIC_5.5.20051010
NCURSES_TIC_5.7.20081102
NCURSES_TIC_5.9.20150530
NCURSES_TIC_6.1.20171230
NCURSES_TINFO_5.0.19991023
NCURSES_TINFO_5.1.20000708
NCURSES_TINFO_5.2.20001021
NCURSES_TINFO_5.3.20021019
NCURSES_TINFO_5.4.20040208
NCURSES_TINFO_5.5.20051010
NCURSES_TINFO_5.6.20061217
NCURSES_TINFO_5.7.20081102
NCURSES_TINFO_5.8.20110226
NCURSES_TINFO_5.9.20150530
NCURSES_TINFO_6.1.20171230
NCURSES_TINFO_6.2.20200212
NCURSESW_5.1.20000708
NCURSESW_5.3.20021019
NCURSESW_5.4.20040208
NCURSESW_5.5.20051010
NCURSESW_5.6.20061217
NCURSESW_5.7.20081102
NCURSESW_5.8.20110226
NCURSESW_5.9.20150530
NCURSESW_6.1.20171230
NCURSESW_6.2.20200212
NCURSES_ASSUMED_COLORS
NCURSES_NO_UTF8_ACS
NCURSES_NO_PADDING
$ 

Both versions tnt is looking for are supported, maybe some buildtime option needs to be added / removed .

Could you try running it on a few other distros like debian,  *buntu , fedora to see if this is an arch-specific issue ?
(no need to install them , just use live media)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#6 2021-06-13 13:29:24

a821
Member
Registered: 2012-10-31
Posts: 285

Re: error while loading shared libraries: libncurses.so.5: cannot open sha

Try rebuilding `ncurses5-compat-libs` without the configure option "--enable-widec".

diff --git a/PKGBUILD b/PKGBUILD
index 9f6d614..01e2011 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,7 +29,6 @@ build() {
     --with-normal \
     --without-debug \
     --without-ada \
-    --enable-widec \
     --disable-pc-files \
     --with-cxx-binding \
     --with-cxx-shared \
@@ -45,9 +44,6 @@ package() {
   rm -rf "$pkgdir/usr/include/" "$pkgdir/usr/lib/pkgconfig" \
     "$pkgdir"/usr/lib/*.so "$pkgdir"/usr/lib/*.a
 
-  for lib in ncurses ncurses++ form panel menu; do
-    ln -s /usr/lib/lib${lib}w.so.5 "$pkgdir/usr/lib/lib${lib}.so.5"
-  done
   ln -s /usr/lib/libncurses.so.5 "$pkgdir/usr/lib/libtinfo.so.5"
   ln -s /usr/lib/libncurses.so.5 "$pkgdir/usr/lib/libtic.so.5"
 }

Offline

#7 2021-06-18 12:18:57

invidian
Member
Registered: 2021-03-14
Posts: 2

Re: error while loading shared libraries: libncurses.so.5: cannot open sha

@a821 "ncurses5-compat-libs" maintainer here. Do you think I should remove "--enable-widec" from the PKGBUILD. I'm not familiar with what "--enable-widec" does, but it seems "ncurses" package use it. According to https://www.linuxfromscratch.org/lfs/vi … urses.html enabling it is correct.

I suppose tnt should be rebuilt with wide characters enabled and then it would be fine.

Offline

#8 2021-06-18 12:50:07

a821
Member
Registered: 2012-10-31
Posts: 285

Re: error while loading shared libraries: libncurses.so.5: cannot open sha

@invidian: I do not think you should remove wide characters support, as this will likely break a lot of reverse dependencies. Also, I didn't check whether this is an actual solution, just saw that `ldd tnt` didn't complain about missing libraries (which is why I asked to try this on #6). I would wait for feedback from OP (OP didn't say anything in the AUR comments).

Offline

#9 2021-11-14 01:58:04

malacology
Member
Registered: 2021-04-24
Posts: 135

Re: error while loading shared libraries: libncurses.so.5: cannot open sha

a821 wrote:

Try rebuilding `ncurses5-compat-libs` without the configure option "--enable-widec".

diff --git a/PKGBUILD b/PKGBUILD
index 9f6d614..01e2011 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,7 +29,6 @@ build() {
     --with-normal \
     --without-debug \
     --without-ada \
-    --enable-widec \
     --disable-pc-files \
     --with-cxx-binding \
     --with-cxx-shared \
@@ -45,9 +44,6 @@ package() {
   rm -rf "$pkgdir/usr/include/" "$pkgdir/usr/lib/pkgconfig" \
     "$pkgdir"/usr/lib/*.so "$pkgdir"/usr/lib/*.a
 
-  for lib in ncurses ncurses++ form panel menu; do
-    ln -s /usr/lib/lib${lib}w.so.5 "$pkgdir/usr/lib/lib${lib}.so.5"
-  done
   ln -s /usr/lib/libncurses.so.5 "$pkgdir/usr/lib/libtinfo.so.5"
   ln -s /usr/lib/libncurses.so.5 "$pkgdir/usr/lib/libtic.so.5"
 }

But I use this PKGBUILD works fine


Don't speak to silly man. Keep Minimalism.

Offline

Board footer

Powered by FluxBB