You are not logged in.

#1 2021-06-14 07:09:06

Flame
Member
Registered: 2021-06-14
Posts: 3

[SOLVED] Boot archiso in Legacy BIOS mode instead of UEFI mode

I want to boot archiso into BIOS mode instead of UEFI. I did as much research as I can and I ended up with no solution. Are there other ways that I can do?

I am using MBR/Legacy system, how can I flash archiso to USB flash drive into BIOS, boot it into BIOS, or force it to use BIOS?

I'm always ended with these choices of

Arch Linux install medium (x86_64, UEFI)
Arch Linux install medium (x86_64, UEFI) with speech
...

instead of

Arch Linux install medium (x86_64, BIOS)
Arch Linux install medium (x86_64, BIOS) with speech
...

I tried some flashing tools that I got through the internet, such as balenaEtcher, rufus, and ISO2Disc, and including dd, but it is still showing UEFI instead of BIOS. I tried changing the settings of flashing tools that I'm using too, but it is still showing UEFI instead of BIOS.

Any help to my issue will be appreciated. Thank you!

Last edited by Flame (2021-06-15 05:36:38)

Offline

#2 2021-06-14 10:01:07

hutiwephy
Member
Registered: 2021-06-12
Posts: 3

Re: [SOLVED] Boot archiso in Legacy BIOS mode instead of UEFI mode

Rufus will automatically make the usb work as "BIOS and UEFI", so if your computer supports UEFI it will only show UEFI options, since it will boot from the EFI Bootloader, however You can override this by, enabling BIOS mode on your PC BIOS:

- Disable FAST BOOT
- Disable Secure BOOT (don't worry that's a UEFI only feature that sometimes gets in the way)
- Enable CSM (That will allow you to boot via BIOS Mode)
- Save Changes and Reboot
- Override the original Boot device (either via BOOT Menu or BIOS)

Now Your USB will show up with 2 options, normally there will be:
- {USB_DEVICE_NAME}, Partition 1   - that's the UEFI Boot
- {USB_DEVICE_NAME}                     - that's the BIOS Boot


NOTE: if you want create an installation with BIOS Boot you don't necessarily need to Boot into BIOS Mode

Offline

#3 2021-06-14 16:43:06

Flame
Member
Registered: 2021-06-14
Posts: 3

Re: [SOLVED] Boot archiso in Legacy BIOS mode instead of UEFI mode

hutiwephy wrote:

Rufus will automatically make the usb work as "BIOS and UEFI", so if your computer supports UEFI it will only show UEFI options, since it will boot from the EFI Bootloader, however You can override this by, enabling BIOS mode on your PC BIOS:

- Disable FAST BOOT
- Disable Secure BOOT (don't worry that's a UEFI only feature that sometimes gets in the way)
- Enable CSM (That will allow you to boot via BIOS Mode)
- Save Changes and Reboot
- Override the original Boot device (either via BOOT Menu or BIOS)

Now Your USB will show up with 2 options, normally there will be:
- {USB_DEVICE_NAME}, Partition 1   - that's the UEFI Boot
- {USB_DEVICE_NAME}                     - that's the BIOS Boot


NOTE: if you want create an installation with BIOS Boot you don't necessarily need to Boot into BIOS Mode

My CSM is enabled by default. I have already tried this method before, but it is not working. Still, I appreciate your reply, thank you!

Offline

#4 2021-06-15 05:33:45

Flame
Member
Registered: 2021-06-14
Posts: 3

Re: [SOLVED] Boot archiso in Legacy BIOS mode instead of UEFI mode

I found a solution to my issue. I just did ESC until to get in legacy boot manager, and I selected the flash drive without the label, UEFI.

Offline

#5 2021-06-16 20:05:52

hutiwephy
Member
Registered: 2021-06-12
Posts: 3

Re: [SOLVED] Boot archiso in Legacy BIOS mode instead of UEFI mode

probably should have made myself more explicit, but thats what I meant with the "override the original boot device"

Offline

Board footer

Powered by FluxBB