You are not logged in.

#1 2021-06-16 17:41:35

Wild Penguin
Registered: 2015-03-19
Posts: 314

Plasma-wayland keyboard: layout [FIXED] and numpad [BUG] issues


Decided to try out plasma-wayland for a chance, but immediately run into roadblocks.

First, I noticed plasma-wayland does not differentiate between numpad-ANYTHING between the regular ANYTHING key (in plasma settings) for keyboard shortcuts. I.e. my old shortcuts to arrange windows via meta+KP_[1-9] (or the corresponding KP_X with numlock off) do not work anymore, and trying to re-set the shortcut keys reveals plasma thinks I've pressed meta+[1-9] (which has totally different functions assigned to them) - or, again, with numlock of, the corresponding regular (non-kp) key is detected. Curiously, xev still detects the keys correctly (KP_1-9, KP_Next, KP_Home etc..).

Moreover, many applications (such as Firefox, gimp) do not recognize my keyboard layout (Finnish), while some do (LibreOffice, Plasma native applications).

Both of these issues are absent on the Xorg (X11) side. Is it just my system or do these features work for others?

Either one of these just by alone would be a dealbreaker for me, and I'm a bit surprised I run into such input issues. I would have expected graphical issues with legacy applications and games, perhaps....


Last edited by Wild Penguin (2022-12-01 17:06:53)


#2 2021-06-17 02:11:32

Registered: 2012-06-16
Posts: 412

Re: Plasma-wayland keyboard: layout [FIXED] and numpad [BUG] issues

For the keyboard layout issue these linked issues may be relevant?

Though it *should* be fixed in >= 5.21.4 -- maybe try setting your Finish keyboard layout twice to see if it's the same thing?

"the wind-blown way, wanna win? don't play"


#3 2021-06-17 07:08:07

Forum Moderator
Registered: 2012-10-16
Posts: 21,136

Re: Plasma-wayland keyboard: layout [FIXED] and numpad [BUG] issues

That sounds more like the X11 keymap for xwayland is misconfigured (pretty sure both gimp and firefox will use xwayland by default) and I'm not sure whether that's supposed to be automatically handled. Maybe make sure you have a xorg configlet setting up finnish, probably easiest done with localectl set-x11-keymap


#4 2022-11-30 19:19:41

Wild Penguin
Registered: 2015-03-19
Posts: 314

Re: Plasma-wayland keyboard: layout [FIXED] and numpad [BUG] issues

Old thread, but it's started by me and I can confirm the issue is still exactly the same and as such relevant, as I came around to give another shot for Wayland just to see if it has improved.

For the more severe (in terms of my workflow) issue has a bug report here: . Though the fact that keyboard is broken in every non-QT application is quite severe, too.

As for the (presumably) xwayland issue, I'm not sure where I'm supposed to set the keyboard layout. My system locale is set to Finnish, the default keyboard layout is Finnish and localectl reports Finnish as the keyboard layout.

in /etc/X11/xorg.conf.d/00-keyboard.conf I have:

$ dog 00-keyboard.conf 
# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "fi"
        Option "XkbModel" "pc-105"

and localectl lists:

$ localectl
System Locale: LANG=fi_FI.UTF-8
    VC Keymap: fi
   X11 Layout: fi
    X11 Model: pc-105

As an additional problem, I've noticed Firefox does not recognize AltGr. I needed to copy-paste the [] from a Konsole window to be able to use code tags! So things are really in a very, very broken state here on Plasma in Wayland. (EDIT: Presumably is is just the US keyboard layout working correctly. And I've found the [] also...).

Last edited by Wild Penguin (2022-12-01 14:32:59)


#5 2022-12-01 14:58:09

Wild Penguin
Registered: 2015-03-19
Posts: 314

Re: Plasma-wayland keyboard: layout [FIXED] and numpad [BUG] issues

I did a bit more testing and it seems like KDE Plasma settings are sometimes causing the wrong layout to be applied to some (non-QT?) applications.

Originally, I had "set keyboard layouts" (or whatever it is called in English) set on, but only one keyboard layout - Finnish - in there (I occasionally need other keyboard layouts so I've set it this way; I can add keyboard layouts if I need them).

By adding an English keyboard layout here, suddenly Firefox (and Gimp as these are the two applications I've used as the test cases) can use a Finnish keyboard. Removing the other (English) layout, they didn't recognize the layout (again). Switching off "set keyboard layouts" altogether, Finnish keyboard layout now works again. But now I've reset the settings as I've had them originally, and Finnish keyboard again works everywhere! So it seems something in Plasma system settings is not always working as intended, but I can not reproduce it consistently. But it could be bug 433576 upstream linked previously by CarbonChauvinist, as chances are I've just overwritten my config files by fiddling (back and forth) with the Plasma system configuration.

So, my keyboard layout now works correctly, but the numpad shortcuts still don't work. That's sadly crucial for me since my workflow depends on shortcuts in the numpad (but not on the "regular" keys).

Last edited by Wild Penguin (2022-12-01 17:06:29)


Board footer

Powered by FluxBB