You are not logged in.

#1 2021-06-22 07:13:20

spongycrumb
Member
Registered: 2021-05-23
Posts: 4

[solved] cannot upgrade - could not satisfy lib32 dependencies

I haven't upgraded my arch computer for several weeks and trying today I cannot successfully run the usual pacman -Syu command without encountering errors. The output I get is shown below

 ~ sudo pacman -Syu
:: Synchronising package databases...
 core                                        134.3 KiB  1428 KiB/s 00:00 [########################################] 100%
 extra                                      1567.1 KiB  7.93 MiB/s 00:00 [########################################] 100%
 community                                     5.6 MiB  8.73 MiB/s 00:01 [########################################] 100%
 multilib                                    149.6 KiB  10.4 MiB/s 00:00 [########################################] 100%
:: Starting full system upgrade...
:: Replace libcanberra-pulse with extra/libcanberra? [Y/n] Y
:: Replace qca with extra/qca-qt5? [Y/n] Y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing lib32-libcanberra (0.30+2+gc0620e4-4) breaks dependency 'lib32-libcanberra=0.30+2+gc0620e4-3' required by lib32-libcanberra-gstreamer

I read some other threads on similar issues and thought maybe I had inadvertently disabled the multilib library in pacman but so far as I can see it is still enabled. Shown below is my pacman.conf file which has the multilib lines uncommented. I don't know if it is connected but I see pacman itself was upgraded earlier in June to version 6.0.0-3 as at 11/6/21 and I have the older pacman 5.2.2-4 version installed. I'm not sure how to proceed from here to continue by system upgrade. What should I try next?

 ~ cat /etc/pacman.conf
#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg=python-msgpack
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
Color
TotalDownload
CheckSpace
#VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

Last edited by spongycrumb (2021-06-22 07:43:32)

Offline

#2 2021-06-22 07:31:07

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,087

Re: [solved] cannot upgrade - could not satisfy lib32 dependencies

Remove lib32-libcanberra-gstreamer as it's not necessary/built anymore.  It doesn't offer a replacement as unlike the pulse variant the gstreamer build has been completely removed.

Last edited by V1del (2021-06-22 07:31:57)

Offline

#3 2021-06-22 07:43:10

spongycrumb
Member
Registered: 2021-05-23
Posts: 4

Re: [solved] cannot upgrade - could not satisfy lib32 dependencies

Thank you V1del. That fixed the problem.

Offline

Board footer

Powered by FluxBB