You are not logged in.

#1 2021-07-10 00:47:51

DiegoRSM
Member
Registered: 2021-06-26
Posts: 2

[SOLVED] Static noise on my microphone ( pulseaudio )

A few days ago i've installed arch again, for test how much i learned since a year ago.
The problem is, i setup all fine except pulseaudio. Before i reinstall arch, i solved this issue with this article:

Microphone distorted due to automatic adjustment

But now, i have the same issue and the previous article doesnt solve that.
So i tried also the next articles:
Static noise in microphone recording
Another possible cause

The only modification that improve the situation was the Noise cancellation, but the static noise still there.
I guess i miss some dependencies, but i'm not sure.

pulseaudio version:       14.2

What i installed:
* pulseaudio
* pavucontrol
* alsa-utils
* alsa-firmware

daemon.conf

default-sample-format = float32le
default-sample-rate = 48000
alternate-sample-rate = 44100

default-sample-channels = 2
;enable-lfe-remixing = no
remixing-produce-lfe = no
remixing-consume-lfe = yes

resample-method = soxr-vhq
avoid-resampling = yes

default.pa

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties

### Should be after module-*-restore but before module-*-detect
load-module module-switch-on-port-available

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail
load-module module-jackdbus-detect channels=2
.fail
.endif

### Automatically load driver modules for Bluetooth hardware
.ifexists module-bluetooth-policy.so
load-module module-bluetooth-policy
.endif

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif

### Load several protocols
load-module module-dbus-protocol
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
#load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP receiver module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
#load-module module-rtp-send source=rtp.monitor

### Load additional modules from GSettings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gsettings.so
.nofail
load-module module-gsettings
.fail
.endif

### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Honour intended role device property
load-module module-intended-roles

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
load-module module-console-kit
.endif
.ifexists module-systemd-login.so
load-module module-systemd-login
.endif

### Enable positioned event sounds
load-module module-position-event-sounds

### Cork music/video streams when a phone stream is active
load-module module-role-cork

### Modules to allow autoloading of filters (such as echo cancellation)
### on demand. module-filter-heuristics tries to determine what filters
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

### Make some devices default
#set-default-sink output
#set-default-source input


### My custom configs

### Remap microphone to mono
#load-module module-remap-source master=alsa_input.pci-0000_00_14.2.analog-stereo master_channel_map=front-left,front-right channels=2 channel_map=mono,mono

### Enable Echo/Noise-Cancellation
load-module module-echo-cancel use_master_format=1 aec_method=webrtc aec_args="analog_gain_control=0\ digital_gain_control=1" source_name=echoCancel_source sink_name=echoCancel_sink
set-default-source echoCancel_source
#set-default-sink echoCancel_sink

Last edited by DiegoRSM (2021-07-11 04:33:51)

Offline

#2 2021-07-10 17:41:57

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,272

Re: [SOLVED] Static noise on my microphone ( pulseaudio )

Potentially an issue with snd_hda_intel power saving that got enabled by default. Make a /etc/modprobe.d/disablePowerSave.conf

options snd_hda_intel power_save=0

and reboot to check that.

Otherwise during an affected recording session post the outputs of

pacmd list-cards
pacmd list-sources
pacmd list-source-outputs

Offline

#3 2021-07-11 04:26:55

DiegoRSM
Member
Registered: 2021-06-26
Posts: 2

Re: [SOLVED] Static noise on my microphone ( pulseaudio )

Thanks for the reply c:
I've read your same answer in other similar issues and i tried it but not works, i forgot to say it, my bad.
Fortunately, or sadly i was able to solve the problem reinstalling arch again.

I think the problem was pulseaudio-qt package, because this time (and the first time also) i installed pulseaudio (not qt package) and the solution that i mentioned before works (This solution)

Regards

Offline

Board footer

Powered by FluxBB