You are not logged in.

#1 2021-07-15 10:05:20

ITA84
Member
Registered: 2019-10-02
Posts: 19

[SOLVED] Baloo File Indexer not updating index automatically

In my KDE Plasma desktop I have enabled indexed search, and I can search files and their contents just fine in Dolphin. The problem is, the indexed files are only those from when I manually enabled the indexing (with balooctl enable), any newer files are not found. Running balooctl enable again starts the indexer and updates the index, but I don't think this is normal behaviour. It seems the indexer never starts again after a reboot.

The output of balooctl status (after a reboot) is

Baloo File Indexer is not running
Total files indexed: 194,067
Files waiting for content indexing: 0
Files failed to index: 0
Current size of index is 1.67 GiB

I also checked the journal, but found no particular error messages about Baloo; here's an excerpt

Jul 15 11:49:47 ryzen74 dbus-daemon[610]: [session uid=1000 pid=610] Activating via systemd: service name='org.kde.runners.baloo' unit='plasma-baloorunner.service' requested by ':1.29' (uid=1000 pid=952 comm="/usr/bin/krunner ")
Jul 15 11:49:47 ryzen74 systemd[593]: Starting KRunner provider for baloo file indexer...
Jul 15 11:49:47 ryzen74 dbus-daemon[610]: [session uid=1000 pid=610] Successfully activated service 'org.kde.runners.baloo'
Jul 15 11:49:47 ryzen74 systemd[593]: Started KRunner provider for baloo file indexer.

Last edited by ITA84 (2021-07-15 15:04:20)

Offline

#2 2021-07-15 10:40:40

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,805

Re: [SOLVED] Baloo File Indexer not updating index automatically

Is starting the indexer enabled to start in System Settings -> Search?

You'd have a line to the tune of

Jul 15 11:39:15 butler-arch plasma_session[1217]: org.kde.plasma.session: Starting autostart service  "/etc/xdg/autostart/baloo_file.desktop" ("/usr/lib/baloo_file")

if it was invoked via autostart, how are you starting plasma, what does your ~/.config/baloofilerc look like?

Offline

#3 2021-07-15 14:57:46

ITA84
Member
Registered: 2019-10-02
Posts: 19

Re: [SOLVED] Baloo File Indexer not updating index automatically

The Indexer seems enabled, as well as file contents search. Checking the stuff from your post out, though, I think the problem is that I've enabled Plasma systemd startup as described in https://wiki.archlinux.org/title/KDE#systemd_startup, and that does not seem to run any of the autostart services from /etc/xdg/autostart. I'll look around and see if there's a fix or workaround. Thanks for your help!

EDIT: more specifically, baloo_file autostart is currently explicitly disabled with systemd for a bug that should have been fixed, and in Plasma 5.23 there should be a definitive fix for this (ref. https://bugs.kde.org/show_bug.cgi?id=439346)

Last edited by ITA84 (2021-07-15 15:04:00)

Offline

Board footer

Powered by FluxBB