You are not logged in.

#1 2021-07-17 08:54:58

fakefred
Member
From: Shanghai
Registered: 2021-07-17
Posts: 4
Website

Wacom tablet express keys do not send X event

I own a Wacom Intuos Small CTH-490, connected to my ThinkPad E485 via USB. It has four express keys, two on the top-left and two on the top-right of the panel. Stylus and the righthand keys work fine. The lefthand buttons, however, do not. When pressed, they fail to send X events, as proven by

xev -event button

The buttons are not dead because the on-tablet LED flashes when I press them. I do not own another computer so I cannot test it anywhere else. The problem has been present for a minimum of 3 days, but no more than 8 days (they were functional on July 9th).

kde_wacom_tabletfinder also has a "Map Hardware Buttons" function, and the results are the same. Only righthand keys trigger a signal.

The weird thing is, despite their refusal to send X events, the two buttons send Ctrl+Z and Ctrl+Shift+Z to my computer. These two key combinations used to be two of the shortcuts I configured on the board with kcm_wacom_tablet. As they cannot be detected by X11 anymore, I cannot remap them.

I wish I could restore the keys to their functional state. Thanks for any help.

Kernel: 5.12.15-arch1-1
DE: Plasma 5.22.3
Wacom-related packages: kcm-wacomtablet 1:3.2.0-4, libwacom 1.11-1 (upgraded just today), xf86-input-wacom 0.40.0-1

Offline

#2 2021-07-17 11:07:49

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,229

Re: Wacom tablet express keys do not send X event

When pressed, they fail to send X events, as proven by

xev -event button

What is the actual output of the command?
Just checking the obvious. Do you get an x window? Have you tried putting the cursor there and triggering the buttons? And so what is the output of xev when you do so?
Have you tried xsetwacom to configure the button?

Offline

#3 2021-07-17 11:17:40

fakefred
Member
From: Shanghai
Registered: 2021-07-17
Posts: 4
Website

Re: Wacom tablet express keys do not send X event

What is the actual output of the command?

There is an X window, yes, and when I move my cursor there and press&release righthand express keys, the output is:

Outer window is 0x4e00001, inner window is 0x4e00002

ButtonPress event, serial 25, synthetic NO, window 0x4e00001,
    root 0x6ab, subw 0x0, time 1513862, (126,95), root:(126,156),
    state 0x0, button 9, same_screen YES

ButtonRelease event, serial 25, synthetic NO, window 0x4e00001,
    root 0x6ab, subw 0x0, time 1513954, (126,95), root:(126,156),
    state 0x0, button 9, same_screen YES

ButtonPress event, serial 25, synthetic NO, window 0x4e00001,
    root 0x6ab, subw 0x0, time 1515108, (126,95), root:(126,156),
    state 0x0, button 8, same_screen YES

ButtonRelease event, serial 25, synthetic NO, window 0x4e00001,
    root 0x6ab, subw 0x0, time 1515152, (126,95), root:(126,156),
    state 0x0, button 8, same_screen YES

ClientMessage event, serial 25, synthetic YES, window 0x4e00001,
    message_type 0x17b (WM_PROTOCOLS), format 32, message 0x17c (WM_DELETE_WINDOW)

No output is printed for the lefthand ones.

Have you tried xsetwacom to configure the button?

No, I didn't know it was possible without getting the keypresses to send an X event.

Offline

#4 2021-07-17 12:16:41

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,229

Re: Wacom tablet express keys do not send X event

No, I didn't know it was possible without getting the keypresses to send an X event.

Well I'm not sure if it's possible if the x event is not triggered. What would be good to know is to establish is why the button doesn't trigger the x event and if the fault lies in wacom or xorg.
You probably already seen this: https://wiki.archlinux.org/title/wacom_tablet

Offline

#5 2021-07-17 13:03:51

fakefred
Member
From: Shanghai
Registered: 2021-07-17
Posts: 4
Website

Re: Wacom tablet express keys do not send X event

Of course I have consulted the wiki, but inevitable got stuck when it brought up xev.

Also, when I execute

ls /dev/input/wacom*

no matches are found.

When comparing the contents in /dev/input before and after the tablet is plugged in, I found the tablet gives me these:

  • event9

  • event10

  • event20

  • js0

  • mouse2

  • mouse3

  • mouse4

... but no wacom.

Offline

#6 2021-07-17 14:35:46

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,229

Re: Wacom tablet express keys do not send X event

... but no wacom.

No 'wacom' doesn't show up in /dev files. If you want to see how wacom is connecting, run

udevadm monitor

in console then power on the device and udev should be able to recognize it and see the inputs and events tied to the device.

Offline

#7 2021-07-17 15:01:01

fakefred
Member
From: Shanghai
Registered: 2021-07-17
Posts: 4
Website

Re: Wacom tablet express keys do not send X event

USB connection seems normal, and a kcm_wacomtablet HUD pops up once I plug/unplug it.

Offline

#8 2021-07-17 16:18:27

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,229

Re: Wacom tablet express keys do not send X event

I have a feeling the buttons are gone. Best is to try the device on another machine even Windows if you can.

Offline

Board footer

Powered by FluxBB