You are not logged in.

#1 2021-07-19 15:11:11

ZenRen
Member
Registered: 2020-05-08
Posts: 3

Systemd-backlight@backlight:acpi_video0.service failed to start

I know many questions have been asked about this message before, but I am not having any issues as a result of it, my backlight works. I am actually just wondering if I should disable it.
I have a Thinkpad X395, I have tried adding acpi_backlight=vedor (no message, but backlight no longer works) and acpi_osi=linux (does nothing) to grub.

ls /sys/class/backlight/

only lists

adgpu_bl0

.

systemctl status systemd-backlight@backlight:amdgpu_bl0.service

shows that is the running service.

So how do I stop it from trying to start with acpi_video0? From what I understand running

systemctl disable systemd-backlight@backlight:acpi_video0.service

does not solve the issue because systemd-backlight@.service is actually what is being ran and its responsible for trying acpi_video0 and amdgpu_bl0. I guess I can mask it, but does that work? Would it theoretically speed up boot? It seemed a little faster when there was no wait for the message to show booting with acpi_backlight=vendor. I have never used mask so I am a little unfamiliar with it.

Offline

#2 2021-07-21 12:34:01

raindog1975
Member
From: Romania
Registered: 2017-04-04
Posts: 14

Re: Systemd-backlight@backlight:acpi_video0.service failed to start

Had the same issue on an Lenovo IdeaPad 3 with Ryzen 3500u, solved with acpi_backlight=vendor, ( from what I could figure out the systemd-backlight was trying to use acpi-video0 for backlight -whitch would be appropriate for older radeon gpus- and it should use amdgpu_bl0.)

Last edited by raindog1975 (2021-07-21 12:35:31)

Offline

Board footer

Powered by FluxBB