You are not logged in.

#1 2021-07-19 20:37:31

LouisDK
Member
Registered: 2013-10-06
Posts: 12

[SOLVED] Pacman does not tell me what I'll do prior to upgrading

I have this strange issue where packing just goes ahead and upgrades after it has refreshed the mirror list and told me that I'll be "Starting full system upgrade":

[louis@hostname ~]$ sudo pacman -Syyuu
:: Synchronizing package databases...
core                                    133.5 KiB   230 KiB/s 00:01 [######################################] 100%
extra                                  1567.0 KiB   705 KiB/s 00:02 [######################################] 100%
community                                 5.6 MiB  2.24 MiB/s 00:03 [######################################] 100%
multilib                                149.7 KiB  1559 KiB/s 00:00 [######################################] 100%
jk-aur                                    6.1 KiB  28.4 KiB/s 00:00 [######################################] 100%
:: Starting full system upgrade...
:: Replace kodi-common with community/kodi? [Y/n]
:: Replace kodi-x11 with community/kodi? [Y/n]
resolving dependencies...
looking for conflicting packages...
:: thunderbird and thunderbird-appmenu-bin are in conflict. Remove thunderbird-appmenu-bin? [y/N]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: thunderbird and thunderbird-appmenu-bin are in conflict
[louis@hostname ~]$

Normally it'll give me a list of packages to be updated and I'll be given an option to press eg. M for manually selecting packages but not this time?

As I have an outdated version of thunderbird-appmenu-bin it probably wants replace it with the official "thunderbird" due to it being a dependency by "thunderbird-i18n-da" and I'm given the option to deselect the upgrade of "thunderbird-i18n-da".

[louis@hostname ~]$ pacman -Ss thunderbird | grep '/thunderbird '
extra/thunderbird 78.12.0-1
[louis@hostname ~]$ pacman -Qs thunderbird                       
local/thunderbird-appmenu-bin 78.11.0-1
    Thunderbird-appmenu, binary version
local/thunderbird-i18n-da 78.11.0-1
    Danish language pack for Thunderbird
[louis@hostname ~]$

Pacman conf:

[louis@hostname ~]$ grep -Ev '^#|^$' /etc/pacman.conf
[options]
HoldPkg     = pacman glibc
Architecture = auto
CheckSpace
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
[core]
Include = /etc/pacman.d/mirrorlist
[extra]
Include = /etc/pacman.d/mirrorlist
[community]
Include = /etc/pacman.d/mirrorlist
[multilib]
Include = /etc/pacman.d/mirrorlist
[jk-aur]
Server = https://repo.vin.ovh/arch/$arch
[louis@hostname ~]$

[louis@hostname ~]$ grep -Ev '^#|^$' /etc/pacman.d/mirrorlist
Server = http://ftp.myrveln.se/pub/linux/archlin … o/os/$arch
[louis@hostname ~]$

Selecting other package mirrors does not help. Any ideas?

EDIT: Changing to a different mirror does not fix this issue.

Last edited by LouisDK (2021-07-19 21:40:41)

Offline

#2 2021-07-19 21:02:48

CarbonChauvinist
Member
Registered: 2012-06-16
Posts: 382
Website

Re: [SOLVED] Pacman does not tell me what I'll do prior to upgrading

In your output nothing has been upgraded. The default selection of N for removal of thunderbid-appmenu-bin causes the entire transaction to be cancelled. You need to explicitly select Y for the removal for it to proceed (or otherwise handle that prior to running the upgrade).

Also -Syyuu is not needed. A simply -Syu is all that is required moving forward.


"the wind-blown way, wanna win? don't play"

Offline

#3 2021-07-19 21:36:45

LouisDK
Member
Registered: 2013-10-06
Posts: 12

Re: [SOLVED] Pacman does not tell me what I'll do prior to upgrading

I put "IgnorePkg   = thunderbird-i18n-da" into /etc/pacman.conf to fix this.

Also need to remember that pacman does not act like my aur helper hence does not provide me with an option to select or deselect packages.

Last edited by LouisDK (2021-07-19 21:39:30)

Offline

Board footer

Powered by FluxBB