You are not logged in.

#1 2021-07-22 13:46:25

Registered: 2013-06-03
Posts: 10

1440p 144hz not working on HD Graphics 520

Hi there,

I have a Lenovo Thinkpad x260 with an Intel i5-6300u laptop, which has an Intel HD Graphics 520.
In theory, the laptop is able (according to the manufacturer and intel) to output up to 4096x2304@60Hz via display port, which is a bandwidth of 16.99 Gbps.
Such bandwidth should be enough to drive a monitor with resolution 2560x1440@144Hz (15.93 Gbps), but when I connect a monitor capable of that (tested with another system with an nVidia RTX 2070), all I get is a black screen.
If I set a resolution of 2560x1440@60Hz it works just fine, but if I try to bump the refresh even a little, like 100Hz, I get a black screen.
With a resolution of 1920x1080 I'm able to set the refresh rate to 75Hz, so it's not like it's capped at 60Hz.
I use gnome on wayland, but I also tried on X11 to see if that was the problem, but I've got the exact same results.
I've also tried to disable the laptop screen (use a single screen) just in case the bandwidth was shared, but even with a single display configuration, the results remain the same.

I'm lost at this point, does anybody know what could I test next?


Board footer

Powered by FluxBB