You are not logged in.

#1 2021-08-11 14:56:59

sgtnasty
Member
Registered: 2020-07-27
Posts: 8

upgrade error: ttf-ionicons: signature from ... is unknown trust

I have a work around, but here is the info.
Here is the output:

[$] sudo pacman -Syu                                                                                                                       [10:45:42]
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 sublime-text is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (82) alacritty-0.9.0-1  alsa-card-profiles-1:0.3.33-1  archlinux-keyring-20210802-1  automake-1.16.4-1  btrfs-progs-5.13.1-1  c-ares-1.17.2-1
              ca-certificates-mozilla-3.69-1  dav1d-0.9.1-1  dbus-glib-0.112-2  diffutils-3.8-1  e2fsprogs-1.46.3-3  electron-13.1.8-1
              electron12-12.0.16-1  element-desktop-1.7.34-1  element-web-1.7.34-1  firefox-91.0-1  firewalld-1.0.0-3  gtk3-1:3.24.30-2  gtkd-3.9.0-13
              iana-etc-20210728-1  imagemagick-7.1.0.4-2  jasper-2.0.33-1  kimageformats-5.84.0-3  kio-extras-21.04.3-2  kitty-0.22.2-1
              kitty-terminfo-0.22.2-1  krita-4.4.7-1  lib32-libxcrypt-4.4.24-1  libbsd-0.11.3-1  libinput-1.18.1-1  libjpeg-turbo-2.1.1-1
              liblphobos-2:1.27.0-1  libmbim-1.26.0-2  libmd-1.0.3-1  libmm-glib-1.16.10-1  libnm-1.32.8-1  libqmi-1.30.0-1  libreoffice-fresh-7.1.5-2
              libtg_owt-0.git6.91d836d-2  libxcrypt-4.4.24-1  libxfont2-2.0.5-1  libxft-2.3.4-1  linux-5.13.9.arch1-1  linux-headers-5.13.9.arch1-1
              llvm-libs-12.0.1-3  modemmanager-1.16.10-1  mpfr-4.1.0.p13-1  mtools-1:4.0.35-1  mutter6-3.36.9-1  networkmanager-1.32.8-1  nss-3.69-1
              openexr-3.1.1-1  pacman-mirrorlist-20210808-1  papirus-icon-theme-20210802-1  pipewire-1:0.3.33-1  plasma-workspace-5.22.4-3
              poppler-21.08.0-1  poppler-qt5-21.08.0-1  protobuf-3.17.3-1  python-dateutil-2.8.2-1  python-tomli-1.2.1-1  qt5-base-5.15.2+kde+r211-1
              re2-1:20210801-1  starship-0.56.0-2  systemd-249.3-1  systemd-libs-249.3-1  systemd-sysvcompat-249.3-1  telegram-desktop-2.9.0-4
              texinfo-6.8-2  ttf-font-awesome-5.15.4-1  ttf-ionicons-5.5.3-1  udisks2-2.9.3-1  util-linux-2.37.1-3  util-linux-libs-2.37.1-3
              vulkan-icd-loader-1.2.186-1  xorg-server-1.20.13-2  xorg-server-common-1.20.13-2  xorg-server-devel-1.20.13-2
              xorg-server-xephyr-1.20.13-2  xorg-server-xnest-1.20.13-2  xorg-server-xvfb-1.20.13-2  xorg-xwd-1.0.8-1

Total Download Size:      0.06 MiB
Total Installed Size:  2347.77 MiB
Net Upgrade Size:        49.72 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 ttf-ionicons-5.5.3-1-any                                        64.3 KiB   199 KiB/s 00:00 [#####################################################] 100%
(82/82) checking keys in keyring                                                            [#####################################################] 100%
(82/82) checking package integrity                                                          [#####################################################] 100%
error: ttf-ionicons: signature from "Brett Cornwall <brett@i--b.com>" is unknown trust
:: File /var/cache/pacman/pkg/ttf-ionicons-5.5.3-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

the key info being:

error: ttf-ionicons: signature from "Brett Cornwall <brett@i--b.com>" is unknown trust
:: File /var/cache/pacman/pkg/ttf-ionicons-5.5.3-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

I don't see any info in the Arch main page news or anything in the package web page.
I just did a

$] sudo pacman -Syu --ignore=ttf-ionicons

and it worked for now.

Offline

#2 2021-08-11 16:04:26

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,872

Re: upgrade error: ttf-ionicons: signature from ... is unknown trust

your problem was the outdated archlinux-keyring

Offline

#3 2021-08-11 23:26:04

sgtnasty
Member
Registered: 2020-07-27
Posts: 8

Re: upgrade error: ttf-ionicons: signature from ... is unknown trust

arojas wrote:

your problem was the outdated archlinux-keyring

So if I understand it correctly all I need to do is a full upgrade:

$ sudo pacman -Syyu

And that seems to fix it. Thanks for the help.

Offline

#4 2021-08-12 14:49:00

ipstone
Member
Registered: 2014-01-12
Posts: 2

Re: upgrade error: ttf-ionicons: signature from ... is unknown trust

Hi, I encounter the same issue, even with `sudo pacman -Syyu` , I still encounter the same error.
For now, I just use `sudo pacman -Syu --ignore=ttf-ionicons` to circumvent this, but it seems this issue does exist, perhaps not directly related to outdated key-rings.

Offline

#5 2021-08-12 16:14:31

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,872

Re: upgrade error: ttf-ionicons: signature from ... is unknown trust

ipstone wrote:

Hi, I encounter the same issue, even with `sudo pacman -Syyu` , I still encounter the same error.
For now, I just use `sudo pacman -Syu --ignore=ttf-ionicons` to circumvent this, but it seems this issue does exist, perhaps not directly related to outdated key-rings.

Yes, you will have the same issue even with 'sudo pacman -Syyu', until you update your archlinux-keyring package

Offline

Board footer

Powered by FluxBB