You are not logged in.

#1 2021-08-23 16:05:40

pfdint
Member
Registered: 2013-11-18
Posts: 37

qbittorrent versions: same dependency graph?

Should qbittorrent-nox really have the same dependency list as qbittorrent?
That means that qbittorrent-nox, a no-gui version of qbittorrent, requires you to install things like Xorg, wayland, libpng, libcups, vulkan-icd-loader, etc.

The list of dependencies installed to a minimal system for qbittorrent-nox is at least this long:

avahi-0.8+20+gd1e71b3-1
boost-libs-1.76.0-1
double-conversion-3.1.5-2
fontconfig-2:2.13.94-1
freetype2-2.10.4-1
graphite-1:1.3.14-1
harfbuzz-2.8.2-1
libcups-1:2.3.3op2-3
libdrm-2.4.107-1
libevdev-1.11.0-1
libglvnd-1.3.3-1
libgudev-236-1
libinput-1.18.1-1
libjpeg-turbo-2.1.1-1
libomxil-bellagio-0.9.3-3
libpciaccess-0.16-2
libpng-1.6.37-3
libproxy-0.4.17-2
libtiff-4.3.0-1
libtorrent-rasterbar-1:1.2.14-1
libunwind-1.5.0-1
libusb-1.0.24-2
libwacom-1.11-1
libxdamage-1.1.5-3
libxfixes-6.0.0-1
libxi-1.7.10-3
libxkbcommon-1.3.0-1
libxkbcommon-x11-1.3.0-1
libxrender-0.9.10-4
libxshmfence-1.3-2
libxxf86vm-1.1.4-4
llvm-libs-12.0.1-3
lm_sensors-1:3.6.0.r41.g31d1f125-1
md4c-0.4.8-1
mesa-21.1.6-1
mtdev-1.1.6-1
qt5-base-5.15.2+kde+r215-1
shared-mime-info-2.0+57+gc1d1c70-1
tslib-1.22-1
vulkan-icd-loader-1.2.186-1
wayland-1.19.0-1
xcb-util-0.4.0-3
xcb-util-image-0.4.0-3
xcb-util-keysyms-0.4.0-3
xcb-util-renderutil-0.3.9-3
xcb-util-wm-0.4.1-3
xdg-utils-1.1.3+19+g9816ebb-1
xkeyboard-config-2.33-1
xorg-xprop-1.2.5-1
xorg-xset-1.2.4-2
qbittorrent-nox-4.3.7-1

As a practical solution, currently there is a qt5-base-headless in the AUR which reduces the madness.

Offline

#2 2021-08-23 16:22:57

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,057

Re: qbittorrent versions: same dependency graph?

If the tool requires qt5-libs just the same then you are unlikely to get around this.

Offline

Board footer

Powered by FluxBB