You are not logged in.

#1 2021-09-02 12:10:23

tcn
Member
Registered: 2011-09-30
Posts: 40

[fixed] chromium: undefined symbol: FT_Get_Color_Glyph_Paint

Hi!

Well, is it just me but since the recent update to 93.0.4577.63-1 this is what I get:

# chromium
/usr/lib/chromium/chromium: symbol lookup error: /usr/lib/chromium/chromium: undefined symbol: FT_Get_Color_Glyph_Paint

thx
tcn

Last edited by tcn (2021-09-02 13:30:20)

Offline

#2 2021-09-02 12:51:31

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,477

Re: [fixed] chromium: undefined symbol: FT_Get_Color_Glyph_Paint

Likely partial upgrades. Did you downgrade freetype to fix steam? Don't do that update your system and use steam-native-runtime or switch to steam's beta channel.

Online

#3 2021-09-02 13:19:46

tcn
Member
Registered: 2011-09-30
Posts: 40

Re: [fixed] chromium: undefined symbol: FT_Get_Color_Glyph_Paint

Nope. Can't remember to have ever downgraded freetype.

[2020-10-25T11:39:09+0100] [ALPM] upgraded freetype2 (2.10.3-1 -> 2.10.4-1)

Offline

#4 2021-09-02 13:24:05

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,477

Re: [fixed] chromium: undefined symbol: FT_Get_Color_Glyph_Paint

Then you have funky mirrors. You should have a variant of freetype 2.11 ( 2.11.0-3 to be exact). Recheck your mirror list and make sure the top mirror(s) are actively syncing with a low delay time: https://archlinux.org/mirrors/status/#successful

And to reiterate, if you've acquired the new version of chromium without an -Syu operation you are conducting partial upgrades which you mustn't do.

Last edited by V1del (2021-09-02 13:27:21)

Online

#5 2021-09-02 13:30:32

tcn
Member
Registered: 2011-09-30
Posts: 40

Re: [fixed] chromium: undefined symbol: FT_Get_Color_Glyph_Paint

Fixed. Thanks!

Offline

#6 2021-09-03 13:49:13

Lord Hobborg
Member
Registered: 2021-09-03
Posts: 1

Re: [fixed] chromium: undefined symbol: FT_Get_Color_Glyph_Paint

Same issue here; don't think there was a partial upgrade, nor funky mirrors for that matter.

I had package freetype2-cleartype (2.10.2-1) installed: replaced it for freetype2 (2.11.0-3) and problem solved.

Offline

#7 2021-09-03 13:57:00

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,873

Re: [fixed] chromium: undefined symbol: FT_Get_Color_Glyph_Paint

Lord Hobborg wrote:

Same issue here; don't think there was a partial upgrade, nor funky mirrors for that matter.

I had package freetype2-cleartype (2.10.2-1) installed: replaced it for freetype2 (2.11.0-3) and problem solved.

Replacing an official package with an unofficial variant and failing to keep up with updates is a partial upgrade for all practical purposes.

Offline

Board footer

Powered by FluxBB