You are not logged in.

#1 2021-09-13 12:29:07

YorYi
Member
Registered: 2021-09-13
Posts: 3

How to not listen my microphone.

Hi, I'm new to the forum and on Arch Linux.

I'm using a Corsair Void Pro Rgb Wireless Gaming Headset and I have installed pulseaudio and pavucontrol. The sound works perfectly but the problem is that when I use the microphone of the headphones, I listen to myself all the time. I would like to disable this.

If you need the output of any command, tell me.

Thank you.

Offline

#2 2021-09-13 13:18:37

Kinrar
Member
Registered: 2021-09-12
Posts: 13

Re: How to not listen my microphone.

You might be using the "phone call" profile of the headset. Do you notice a drop in audio quality when you start using the microphone?
When in a call, try opening pavucontrol => Configuration => your headset and check it's using High Fidelty Playback (A2DP) and not Headseat Head Unit.

Offline

#3 2021-09-13 13:31:10

YorYi
Member
Registered: 2021-09-13
Posts: 3

Re: How to not listen my microphone.

No, I don't notice a drop in audio quality. Secondly, in pavucontrol I don't have the High Fidelty Playback profile.

Offline

#4 2021-09-13 14:04:27

Kinrar
Member
Registered: 2021-09-12
Posts: 13

Re: How to not listen my microphone.

What profiles do you have?

Have you tried this headset on any other OS? I mean, are you sure this is not by design?

Last edited by Kinrar (2021-09-13 14:05:14)

Offline

#5 2021-09-13 14:26:39

YorYi
Member
Registered: 2021-09-13
Posts: 3

Re: How to not listen my microphone.

I have the 0S in Spanish, so the profiles are:

  • Stereo analogical output + mono input.

  • Stereo analogical output.

  • Mono input.

Yes, I have tried this headset on other OS and works perfectly.

Offline

#6 2021-09-13 15:39:54

Kinrar
Member
Registered: 2021-09-12
Posts: 13

Re: How to not listen my microphone.

Oh I thought it was a Bluetooth headset, my bad. I don't really know how to help you then, sorry. I'm not aware of any default setting of pulseaudio that would send you back audio automatically.

If there is no delay at all between when you speak and when you hear yourself back, it would indicate that the playback is on the hardware side, not software.

Offline

#7 2021-09-17 10:06:56

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,058

Re: How to not listen my microphone.

What's your

aplay -l
amixer -c0 #Replace the 0 with the correct index from the above command
pacmd list-sources
pacmd list-source-outputs

output during reproduction of the issue? Post these in code tags

Online

Board footer

Powered by FluxBB