You are not logged in.

#1 2021-09-13 17:26:09

simonhiggs
Member
Registered: 2015-02-16
Posts: 7

Warnings building logitechmediaserver-git

I've installed Arch on an old Mac Mini to run Logitech Media Server. When I build the package, I have some warnings...

==> WARNING: Package contains reference to $srcdir
opt/logitechmediaserver-git/CPAN/auto/DBD/SQLite/SQLite.so
opt/logitechmediaserver-git/CPAN/auto/Media/Scan/Scan.so

Is it safe to ignore these warnings?

There is a section in the wiki: WARNING:_Package_contains_reference_to_$srcdir

$ grep -R "$PWD/src" pkg/
grep: pkg/logitechmediaserver-git/usr/share/licenses/logitechmediaserver-git/LICENSE: No such file or directory
grep: pkg/logitechmediaserver-git/opt/logitechmediaserver-git/CPAN/auto/DBD/SQLite/SQLite.so: binary file matches
grep: pkg/logitechmediaserver-git/opt/logitechmediaserver-git/CPAN/auto/Media/Scan/Scan.so: binary file matches

SImon.

Last edited by simonhiggs (2021-09-13 17:35:34)

Offline

#2 2021-09-13 17:27:46

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,455
Website

Re: Warnings building logitechmediaserver-git

Mod note: moving to AUR Issues.


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2021-09-13 17:51:46

simonhiggs
Member
Registered: 2015-02-16
Posts: 7

Re: Warnings building logitechmediaserver-git

WorMzy wrote:

Mod note: moving to AUR Issues.

Thanks WorMzy. Originally posted in Newbie Corner - Please be gentle!
Simon.

Offline

#4 2021-09-13 19:46:46

loqs
Member
Registered: 2014-03-06
Posts: 13,871

Re: Warnings building logitechmediaserver-git

See https://bbs.archlinux.org/viewtopic.php … 7#p1992727 in respect to $srcdir references
I would suggest using the none git version logitechmediaserver instead of logitechmediaserver-git unless you have a particular need for the git version.
If you wanted to improve the PKGBUILD I would suggest starting by removing the install file and replacing its functionality by sysusers.d and tempfiles.d configs.  PKGBUILDS should never delete users or groups as there may be files using the UID / GID.
Then see if the bundled dependencies can be replaced by system provided versions which might solve the initial issue.
After that adjust the build script to use Arch's build flags.

Offline

#5 2021-09-14 20:07:23

simonhiggs
Member
Registered: 2015-02-16
Posts: 7

Re: Warnings building logitechmediaserver-git

Thanks loqs,

Although I was using logitechmediaserver-git, I was trying to install the stable 8.2.1 release, rather than the older 8.1 version from logitechmediaserver.

#source=("git+https://github.com/Logitech/slimserver.git"
#       "git+https://github.com/Logitech/slimserver-vendor.git"
#        'service')

source=("git+https://github.com/Logitech/slimserver.git#branch=public/8.2"
        "git+https://github.com/Logitech/slimserver-vendor.git#branch=public/8.2"
        'service')

I'll read up about sysusers.d and tempfiles.d

Simon.

Offline

#6 2021-09-14 21:20:35

loqs
Member
Registered: 2014-03-06
Posts: 13,871

Re: Warnings building logitechmediaserver-git

You can update logitechmediaserver as well:

git diff
diff --git a/PKGBUILD b/PKGBUILD
index 0f95ed2..c83c3da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
 # Maintainer: Stefan Sielaff <aur AT stefan-sielaff DOT de>
 pkgname=logitechmediaserver
-pkgver=8.1.1
+pkgver=8.2.0
 pkgrel=1
 pkgdesc='Slimserver for Logitech Squeezebox players. This server is also called Logitech Media Server. (Release-Version, if you prefer bleeding edge consider using logitechmediaserver-git instead)'
 arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -10,16 +10,19 @@ provides=('logitechmediaserver')
 depends=('perl>=5.26' 'perl-io-socket-ssl')
 makedepends=('git' 'yasm' 'rsync' 'gd' 'zlib')
 optdepends_x86_64=('lib32-glibc: transcoding on 64-bit systems' 'lib32-gcc-libs: transcoding on 64-bit systems')
-install=install
 
-_gitver=8.1.1
-_gitvendorver=8.0
-source=("slimserver.tar.gz::https://github.com/Logitech/slimserver/archive/${_gitver}.tar.gz"
-        "slimserver-vendor-public.tar.gz::https://github.com/Logitech/slimserver-vendor/archive/public/${_gitvendorver}.tar.gz"
-        'service')
-sha256sums=('cfab3acda2cfb60b106bdfd80f943e3f4d466ec4cc6f00973d796c7c68640f53'
-            'e13f0e3529234693953e32382776ea965b87a758d1bc75cf453819fb0d76d502'
-            '07208896fed78eb9cb0086360c02f3226ecf1be9a061d55a6f95b9a60b6d6735')
+_gitver=8.2.0
+_gitvendorver=8.2
+source=("slimserver-$_gitver.tar.gz::https://github.com/Logitech/slimserver/archive/${_gitver}.tar.gz"
+        "slimserver-vendor-public-$_gitvendorver.tar.gz::https://github.com/Logitech/slimserver-vendor/archive/public/${_gitvendorver}.tar.gz"
+        'service'
+        'logitechmediaserver.sysusers'
+        'logitechmediaserver.tmpfiles')
+sha256sums=('845f11b276d3fa987d942427e10c6dece296f1e167385b19f99a2567741e7957'
+            '949429ff43be01e9ac42204d444410f6c9130354c90707a4a79dd15c345c4242'
+            '07208896fed78eb9cb0086360c02f3226ecf1be9a061d55a6f95b9a60b6d6735'
+            'ea532fab20cee21ce9a82df0102324464b42614baaa1d14ad7289be458e46b6d'
+            '4240fb031c3c0ca0335dd857c4adc600c57c3b81f975156b2df088891a2e4b24')
 
 prepare() {
        cd "${srcdir}/slimserver-${_gitver}/Bin"
@@ -44,6 +47,8 @@ build() {
 package() {
         cd "${srcdir}"
         install -Dm644 service "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+        install -Dm644 logitechmediaserver.sysusers "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
+        install -Dm644 logitechmediaserver.tmpfiles "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
         cd "${srcdir}/slimserver-${_gitver}"
         install -d "${pkgdir}"/{opt,usr/share/licenses}/"${pkgname}" && ln -s "/opt/${pkgname}/License.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
         cp -a * "${pkgdir}/opt/${pkgname}"

I could not find an 8.2.1 tag so the above uses 8.2.0.  It adds the version to the downloads name so each release produce a unique download.
You could also flag the package as out of date.
Edit:
Added sysusers.d and tmpfiles.d
logitechmediaserver.sysusers

u     logitechms    -    'Logitech Media Server'    /opt/logitechmediaserver

logitechmediaserver.tmpfiles

d    /opt/logitechmediaserver/cache
d    /opt/logitechmediaserver/Logs
d    /opt/logitechmediaserver/prefs
d    /opt/logitechmediaserver/prefs/plugin
d    /opt/logitechmediaserver/Plugins
f    /opt/logitechmediaserver/Logs/slimserver.log
Z    /opt/logitechmediaserver    -    logitechms    logitechms

I suspect the directory creation entries could be moved to the PKGBUILD package() function leaving only the file creation and mode change in tmpfiles.

Last edited by loqs (2021-09-14 21:47:26)

Offline

#7 2021-09-15 20:30:52

simonhiggs
Member
Registered: 2015-02-16
Posts: 7

Re: Warnings building logitechmediaserver-git

loqs, Thank-you! That's really helpful.

Where did you find the checksums for the downloaded files? Does updpkgsums do this?

Simon.

Offline

#8 2021-09-15 20:53:35

loqs
Member
Registered: 2014-03-06
Posts: 13,871

Re: Warnings building logitechmediaserver-git

simonhiggs wrote:

Where did you find the checksums for the downloaded files? Does updpkgsums do this?

Yes updpkgsums.

Last edited by loqs (2021-09-15 20:53:49)

Offline

Board footer

Powered by FluxBB