You are not logged in.

#1 2021-09-14 20:45:00

sosed
Member
Registered: 2021-09-14
Posts: 2

Weechat can't login to freenode with ssl

this is the messages that i get when try to log on to freenode:

irc: connecting to server chat.freenode.net/6697 (SSL)...
gnutls: connected using 2048-bit Diffie-Hellman shared secret exchange
gnutls: receiving 3 certificates
- certificate[1] info:
   - subject `CN=myeongjong.joseon.kr', issuer `CN=R3,O=Let's Encrypt,C=US', serial
0x04267902bac04b3c2ec6df65130c17c4c9b6, RSA key 2048 bits, signed using RSA-SHA256, activated `2021-08-11
04:46:57 UTC', expires `2021-11-09 04:46:55 UTC', pin-sha256="H804efsdkfXzf4S+PH6V79JHERVCaN3A//ZaGQhMaYQ="
- certificate[2] info:
   - subject `CN=R3,O=Let's Encrypt,C=US', issuer `CN=ISRG Root X1,O=Internet Security Research Group,C=US',
serial 0x00912b084acf0c18a753f6d62e25a75f5a, RSA key 2048 bits, signed using RSA-SHA256, activated `2020-09-04
00:00:00 UTC', expires `2025-09-15 16:00:00 UTC', pin-sha256="jQJTbIh0grw0/1TkHSumWb+Fs0Ggogr621gT3PvPKG0="
- certificate[3] info:
   - subject `CN=ISRG Root X1,O=Internet Security Research Group,C=US', issuer `CN=DST Root CA X3,O=Digital
Signature Trust Co.', serial 0x4001772137d4e942b8ee76aa3c640ab7, RSA key 4096 bits, signed using RSA-SHA256,
activated `2021-01-20 19:14:03 UTC', expires `2024-09-30 18:14:03 UTC',
pin-sha256="C5+lpZ7tcVwmwQIMcRtPbsQtWLABXhQzejna0wHFr8M="
gnutls: peer's certificate is trusted
irc: connected to chat.freenode.net/6697 (139.162.201.178)
*.joseon.kr: *** Looking up your ident...
*.joseon.kr: *** Looking up your hostname...
*.joseon.kr: *** You must use TLS/SSL and authenticate via SASL to connect to freenode please visit
https://irc.com/login/sso in order to create an account. SASL Configuration: https://freenode.net/kb/answer/sasl
- Webchat: https://webchat.freenode.net/
*.joseon.kr: *** Could not resolve your hostname: Domain not found; using your IP address (141.226.61.61)
instead.
irc: client capability, server supports: inspircd.org/standard-replies extended-join server-time message-tags
echo-message labeled-response invite-notify setname account-tag multi-prefix inspircd.org/poison batch
account-notify userhost-in-names chghost sasl=EXTERNAL,PLAIN cap-notify away-notify draft/relaymsg=/
irc: client capability, requesting: sasl
irc: client capability, enabled: sasl
You are now logged in as extern
* :SASL authentication successful
irc: connection timeout (message 001 not received)
irc: disconnected from server
irc: reconnecting to server in 20 seconds

i might missing some packages as i just installed arch linux yesterday but i dont know which ones ( if that's the case )

Offline

#2 2021-10-07 17:55:18

m3nda
Member
Registered: 2021-10-07
Posts: 1

Re: Weechat can't login to freenode with ssl

Same for me.

I didn't change anything of the weechat client for ages. Simply started to not work suddently.
Reconfiguring SASL and all the config did not help.

The domain joseon.kr is no longer working, and I don't understand why there's nothing that rotates that SASL server in the freenode login mechanism if that server is no longer alive.

I have no idea about changing or blocking that server in the login process.

Offline

#3 2021-10-07 19:08:27

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,748
Website

Re: Weechat can't login to freenode with ssl


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB