You are not logged in.

#1 2021-09-16 02:21:14

Krygen
Banned
Registered: 2021-09-10
Posts: 39

Can not update the system due to vim

I am trying to update my system but I keep getting this error.

yay -Syu                                              
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing vim-runtime (8.2.3441-1) breaks dependency 'vim-runtime=8.2.3412-1' required by vim-clipboard
error installing repo packages

Any suggestions ?

Offline

#2 2021-09-16 02:22:28

Ammako
Member
Registered: 2021-07-16
Posts: 197

Re: Can not update the system due to vim

Fix your aur stuff

The error is very clear as to what you should be doing

Last edited by Ammako (2021-09-16 02:22:53)

Offline

#3 2021-09-16 02:26:53

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,929

Re: Can not update the system due to vim

Moving to AUR issues


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#4 2021-09-16 13:45:42

Krygen
Banned
Registered: 2021-09-10
Posts: 39

Re: Can not update the system due to vim

I would not be posting this If that was so clear to me smile)

Offline

#5 2021-09-16 13:50:40

seth
Member
Registered: 2012-09-03
Posts: 23,994

Re: Can not update the system due to vim

installing vim-runtime (8.2.3441-1) breaks dependency 'vim-runtime=8.2.3412-1' required by vim-clipboard

You do know how numbers work and what "=" means?

Offline

#6 2021-09-16 20:40:53

Ammako
Member
Registered: 2021-07-16
Posts: 197

Re: Can not update the system due to vim

vim-clipboard is out of date. update the PKGBUILD, rebuild and install new version, then update system.

Never use AUR helpers unless you actually understand how the AUR works. Given that the maintainer has now updated the package, you should be able to update as normal, but, please, learn how to actually use the AUR for the future.

Offline

#7 2021-09-17 23:23:53

Krygen
Banned
Registered: 2021-09-10
Posts: 39

Re: Can not update the system due to vim

As far as i know, aur works with PKGBUILD, I do not know the technical side of pkgbuild but I know how it works. People creating packages with PKGBUILD and we are building it from there. aur helpers doing it automatically without needing me to clone the repo to my local and run makepkg -si. What do you think I need to learn. I did uninstall the vim-clipboard, updated the system than re installed vim-clipboard. Is it the right way ?

Offline

#8 2021-09-17 23:41:25

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,682
Website

Re: Can not update the system due to vim

It's only in the case of a version dependency that you'll need to uninstall. Generally, rebuilding against the new libraries in the official repos will be sufficient.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#9 2021-09-17 23:47:37

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 25,744
Website

Re: Can not update the system due to vim

Krygen wrote:

Is it the right way ?

Yes.  There might be other approaches as well, but that is a simple and appropriate way to deal with this sort of error.

I think you caught a lot of crap in this thread that had a harsher tone than was called for: most of us get pretty cranky when new users have been roped into using overbearing AUR helpers long before they should - but it's not your fault.

Just the same though, the harsh reactions here are the result of users with a lot of knowledge and experience knowing that yay is currently doing you a disservice.  It'd be helpful if you can set aside the tone and accept the content that using yay is probably not a good idea for you at this point.

Get some experience building with makepkg.  Not to practice typing that sequence of key presses, but to get used to addressing the little issues that will periodically arise with AUR packages.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#10 2021-09-18 00:23:49

Ammako
Member
Registered: 2021-07-16
Posts: 197

Re: Can not update the system due to vim

Krygen wrote:

What do you think I need to learn.

In this particular case, the error was quite clear in telling you that vim-clipboard was the root cause of the problem. From there you would check the AUR page for vim-clipboard and see what's going on with the package, why is it asking for a mismatched dependency? From there you'll notice that the package hasn't been updated to the new latest version, and so it's still looking for the previous version of the runtime. What can I do to fix this? so you check the PKGBUILD and what it's doing, and it turns out you can just bump up the version number in the PKBUILD and then makepkg.

Let's say you weren't even aware that vim-clipboard was an AUR package. Your package manager is telling you that vim-clipboard is causing issues. So, what's vim-clipboard, is that from the official repositories or from the AUR? So you check AUR and Arch Packages, and figure out it's from the AUR. From there you'll notice it's being pretty strict on requirements and blocking your update. What can I do to fix that? so you check the PKGBUILD and see if there's anything you might be able to do to fix it. Ah, all I have to do is update the version number and makepkg to build the new one.

Stuff like that, you know? Problem-solving skills. You're not always going to be able to fix a PKGBUILD by yourself like that, depending on how complicated the package is, but that's okay, you know? Because then you at least know what the problem is (this package is outdated and needs to be fixed), so you can either ask the maintainer about the error and hopefully they'll update the package so you can move on, or you'll be able to ask the community in case anyone knows how to fix the PKGBUILD.

Even if it was a simple package to update like this one that you needed to ask for help on fixing, you're already *miles* ahead just because you'll have done the research to figure out the root cause. It'll show that you at least understand how the system works and that you've put effort into trying to fix it yourself first. That is something others will greatly appreciate.

Last edited by Ammako (2021-09-18 00:34:58)

Offline

#11 2021-09-25 07:36:12

Krygen
Banned
Registered: 2021-09-10
Posts: 39

Re: Can not update the system due to vim

Thank you very much for your wonderfull explanation, it really helped and now I understand why that happened. Furthermore, you said I can manually update the version number with my hand. I could not quite understand that part.What I need to update, vim runtime manually or vim-clipboard ? And where are those PKGBUILD files, because I am not always cloning repos to my local and doing "makepkg" think, %70 of the time I am using an aur helper.

Offline

#12 2021-09-25 08:55:03

flyingscorpio
Member
Registered: 2020-06-04
Posts: 29

Re: Can not update the system due to vim

Krygen wrote:

And where are those PKGBUILD files, because I am not always cloning repos to my local and doing "makepkg" think, %70 of the time I am using an aur helper.

Exactly why we say AUR helpers are hiding it away. The normal process is to clone from the aur repo, so you have to know where the PKGBUILD is because you just cloned it.

Offline

#13 2021-09-25 11:58:04

Ammako
Member
Registered: 2021-07-16
Posts: 197

Re: Can not update the system due to vim

You don't even need to clone, "View PKGBUILD" is right there on every package in the AUR.

Offline

Board footer

Powered by FluxBB