You are not logged in.

#1 2021-09-19 21:51:50

slowjoe
Member
Registered: 2021-09-19
Posts: 4

How do I install all the members in archlinux package base-devel

I wish to install all the options in the archlinux package base-devel.

When I issue the command "sudo pacman -S --needed base-devel" I get:

[vagrant@archlinux ~]$ sudo pacman -S --needed base-devel
warning: file-5.40-5 is up to date -- skipping
warning: findutils-4.8.0-1 is up to date -- skipping
warning: gawk-5.1.0-1 is up to date -- skipping
warning: gettext-0.21-1 is up to date -- skipping
warning: grep-3.6-1 is up to date -- skipping
warning: gzip-1.11-1 is up to date -- skipping
warning: pacman-6.0.1-1 is up to date -- skipping
warning: sed-4.8-1 is up to date -- skipping
warning: sudo-1.9.7.p2-1 is up to date -- skipping
:: There are 15 members in group base-devel:
:: Repository core
   1) autoconf  2) automake  3) binutils  4) bison  5) fakeroot  6) flex  7) gcc
   8) groff  9) libtool  10) m4  11) make  12) patch  13) pkgconf  14) texinfo
   15) which

Enter a selection (default=all): 

How can I avoid getting the interactive prompt to select which package to install.

Last edited by slowjoe (2021-09-19 22:05:30)

Offline

#2 2021-09-19 21:55:14

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,686
Website

Re: How do I install all the members in archlinux package base-devel

Please use code tags when pasting to the boards: https://wiki.archlinux.org/index.php/Co … s_and_code

As the prompt says, the default (ie., Enter) installs all of the necessary packages.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2021-09-19 21:57:08

dreamycrane
Member
Registered: 2019-03-18
Posts: 18

Re: How do I install all the members in archlinux package base-devel

Maybe try

sudo pacman -S --needed --noconfirm base-devel

Offline

Board footer

Powered by FluxBB