You are not logged in.

#1 2021-10-03 12:29:02

InFerYes
Member
Registered: 2012-11-13
Posts: 30

Unable to update polkit (signature is unknown trust)

Hi, I'm getting the following issue:

$ sudo pacman -S polkit
resolving dependencies...
looking for conflicting packages...

Packages (1) polkit-0.119-1

Total Installed Size:  1,85 MiB
Net Upgrade Size:      0,01 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                                                                                                                                  [##################################################################################################] 100%
(1/1) checking package integrity                                                                                                                                [##################################################################################################] 100%
error: polkit: signature from "Jonas Witschel <diabonas@gmx.de>" is unknown trust
:: File /var/cache/pacman/pkg/polkit-0.119-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

Deleting the package y or n doesn't change the outcome.

How can I proceed?

edit: Sorry, this seems to be a duplicate from https://bbs.archlinux.org/viewtopic.php?id=269928

Last edited by InFerYes (2021-10-03 12:34:13)

Offline

Board footer

Powered by FluxBB