You are not logged in.

#1 2021-10-04 22:48:31

Registered: 2021-10-04
Posts: 1

ERROR: device 'UUID=...' not found. Skipping fsck.

I've tried installing Arch almost 10 times now following the official guide alone and following other guides. I've had arch users from the discord walk me through the process, and I've even used the built-in arch installer script twice, once with grub and the other with systemd. Yet every time when I'm finished and boot into Arch Linux, I get the following error.
```Starting version 249.4-2-arch
ERROR: device 'UUID=4e94b936-fbc3-4b58-b1da-5d70e776c7e8' not found. Skipping fsck.
mount: /new_root: can't find UUID=UUID=4e94b936-fbc3-4b58-b1da-5d70e776c7e8.
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off.
I've double checked that these UUIDs are the same in my fstab, and that the EFI partition is mounted to /mnt/boot and the root partition is mounted to /.

I will post the sequence of commands I run during the install to make sure that I am not missing anything.

`timedatectl set-ntp true`
`fdisk /dev/nvme0n1` - GPT label, 2 partitions, first is EFI type with +512M last sector. Second is Linux file system for root.

`mkfs.ext4 /dev/nvme0n1p2`
`mkfs.fat -F32 /dev/nvme0n1p1`

`mount /dev/nvme0n1p2 /mnt`
`mkdir /mnt/boot`
`/mount /dev/nvme0n1p1 /mnt/boot`

`pacstrap /mnt base linux linux-firmware`
`genfstab -U /mnt >> /mnt/etc/fstab`
`arch-chroot /mnt`

(locale/network/hostname/users configruation steps omitted)

`pacman -S grub efibootmgr`
`grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=GRUB --removable`
`grub-mkconfig -o /boot/grub/grub.cfg`
`umount -R /mnt`

One google search about this problem suggests that my NVME drive is not configured correctly. "Check whether the NVME drive is configured for RAID mode in your UEFI/BIOS and switch that to AHCI."
But for some reason my BIOS does not have a PCH storage configuration option in advanced to change it. The closest option I can find is:
Intel(R) Rapid Storage Technology > PCIe 0.0 > where it then shows the physical disk info:
Size: 953.8GB
Status: Non-RAID
Controller Type: NVMe
Controller Interface: PCIe

The machine is an Asus Zephyrus M16 GU603.

Last edited by michaelmoreno (2021-10-04 22:49:15)


#2 2021-10-04 23:08:14

Registered: 2012-09-01
Posts: 8,695

Re: ERROR: device 'UUID=...' not found. Skipping fsck.


Board footer

Powered by FluxBB