You are not logged in.

#1 2021-10-09 19:08:47

Morta
Member
Registered: 2019-07-07
Posts: 113

yay - Can't install wordpress in specific folder

[morta@5erver webapps]$ yay -Sr wordpress-git  /usr/share/webapps/blog/
unable to CreateHandle: could not find or read directory

Why doesn't work?

I did mkdir /usr/share/webapps/blog but no effect...

Last edited by Morta (2021-10-09 19:10:35)

Online

#2 2021-10-09 19:22:10

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 4,651

Re: yay - Can't install wordpress in specific folder

Because that's not how the AUR works.

Also -r isn't a valid switch, what did you expect it to do?


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#3 2021-10-09 19:52:35

Morta
Member
Registered: 2019-07-07
Posts: 113

Re: yay - Can't install wordpress in specific folder

Slithery wrote:

Because that's not how the AUR works.

Also -r isn't a valid switch, what did you expect it to do?

Install the package in this folder insted of the original.

I read that should work with pacman so i thinked with yay too. I‘m wrong obviously.

Online

#4 2021-10-09 20:00:10

Alad
Wiki Admin/IRC Op
From: Bagelstan
Registered: 2014-05-04
Posts: 2,221
Website

Re: yay - Can't install wordpress in specific folder

pacman -r doesn't set the installation path, it sets the installation root. So you'd have paths like:

/usr/share/webapps/blog/usr/share/webapps/wordpress/index.php

Modify the PKGBUILD instead and use makepkg.

Last edited by Alad (2021-10-09 20:01:11)


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby

Offline

#5 2021-10-09 20:17:14

Morta
Member
Registered: 2019-07-07
Posts: 113

Re: yay - Can't install wordpress in specific folder

Alad wrote:

pacman -r doesn't set the installation path, it sets the installation root. So you'd have paths like:

/usr/share/webapps/blog/usr/share/webapps/wordpress/index.php

Modify the PKGBUILD instead and use makepkg.


Ok thanks. That would be a nice feature for the package managers.

Last edited by Morta (2021-10-09 20:32:28)

Online

#6 2021-10-09 20:46:47

loqs
Member
Registered: 2014-03-06
Posts: 13,975

Re: yay - Can't install wordpress in specific folder

Morta wrote:

Ok thanks. That would be a nice feature for the package managers.

Even after the files are moved at least systemd services,  tmpfils.d,  sysusers.d,  .install files,  pacman hooks,  /etc files would all be broken.
That is why it needs to be manually performed on a per package basis

Last edited by loqs (2021-10-09 20:47:10)

Offline

#7 2021-10-10 06:58:58

mpan
Member
Registered: 2012-08-01
Posts: 720
Website

Re: yay - Can't install wordpress in specific folder

Morta wrote:

Ok thanks. That would be a nice feature for the package managers.

You may be still misunderstanding what the `--root` (`-r`) option does. It is not a switch to set package path that just has some weird semantics. The `--root` option is used to tell pacman where is the entire system, which pacman manages, installed. That’s needed for situations in which pacman operates on a system other the currently running one (in “/”), not to affect specific packages.

You can’t set just a single package to be in a different root and expect things to work. It will not. And it’s not a feature to have. Not only that’s not how package managers for entire operating systems are expected to operate, but also impossible to implement without you yourself having to build every package, often manually patching it and debugging issues. Which you can do right now, which is the point of Alad’s suggestion.

I’m also smelling a possible XY problem here. Normally⁽¹⁾ there should be no reason for you to install it in a different directory. Why do you need to do that?
____
⁽¹⁾ There are specific cases, which I am aware of, in which that may be desirable. And some exceptional cases with the piece of software being broken, though that should be addressed upstream.

Last edited by mpan (2021-10-10 07:02:49)


Sometimes I seem a bit harsh — don’t get offended too easily! PGP: 7C848198AE93D3BB

Offline

Board footer

Powered by FluxBB