You are not logged in.

#1 2021-10-11 04:49:09

galdor
Member
From: France
Registered: 2007-10-24
Posts: 22
Website

[SOLVED] Missing old package version on mirrors

Hi,

I'm trying to update my system after a couple weeks, mirrors seem to be missing multiple files such as linux-headers-5.14.9 (current version is 5.14.10 which is present).
Running

pacman -Syyu

does *not* fix the problem, pacman still requires 5.14.9, and I get the same result after trying more than a dozen mirrors (also multiple mirrors cause SSL errors or return HTTP errors…).

Is there something specific to do in that kind of situation ?

:: Retrieving packages...
 linux-headers-5.14.9.arch2-1-x86_64 downloading...
debug: linux-headers-5.14.9.arch2-1-x86_64.pkg.tar.zst: url is http://archlinux.mirrors.ovh.net/archlinux/core/os/x86_64/linux-headers-5.14.9.arch2-1-x86_64.pkg.tar.zst
debug: linux-headers-5.14.9.arch2-1-x86_64.pkg.tar.zst: maxsize 25039866
debug: linux-headers-5.14.9.arch2-1-x86_64.pkg.tar.zst: opened tempfile for download: /var/cache/pacman/pkg/linux-headers-5.14.9.arch2-1-x86_64.pkg.tar.zst.part (wb)
debug: linux-headers-5.14.9.arch2-1-x86_64.pkg.tar.zst: curl returned result 0 from transfer
debug: linux-headers-5.14.9.arch2-1-x86_64.pkg.tar.zst: response code 404
error: failed retrieving file 'linux-headers-5.14.9.arch2-1-x86_64.pkg.tar.zst' from archlinux.mirrors.ovh.net : The requested URL returned error: 404
debug: linux-headers-5.14.9.arch2-1-x86_64.pkg.tar.zst: no more servers to retry
debug: curl_download_internal return code is -1
warning: failed to retrieve some files
error: failed to commit transaction (failed to retrieve some files)
Errors occurred, no packages were upgraded.

Last edited by galdor (2021-10-11 05:43:54)

Offline

#2 2021-10-11 04:58:57

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,686
Website

Re: [SOLVED] Missing old package version on mirrors

┌─[Centurion ~]
└─╼ pkgsearch linux-headers
linux-headers 5.14.10.arch1-1 core
linux-headers 5.14.11.arch1-1 testing

Fix your mirror list.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2021-10-11 05:00:42

galdor
Member
From: France
Registered: 2007-10-24
Posts: 22
Website

Re: [SOLVED] Missing old package version on mirrors

I would love to, but /etc/pacman.d/mirrorlist is owned by pacman-mirrorlist, and according to pacman itself, it is up-to-date (pacman-mirrorlist-20210822-1).
Is there an official procedure to force an update of the mirror list for somewhere else ?

Offline

#4 2021-10-11 05:15:38

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,686
Website

Re: [SOLVED] Missing old package version on mirrors

It's just a text file. Use the mirror status page on the wiki to identify some known good mirrors, and uncomment/add them.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#5 2021-10-11 05:43:03

galdor
Member
From: France
Registered: 2007-10-24
Posts: 22
Website

Re: [SOLVED] Missing old package version on mirrors

And now the kernel.org mirror gives me the right package list, so it seems I was stuck between mirror updates. The multiple SSL and HTTP errors on various mirrors are scary, but as long as it works for at least one mirror, I'm fine.
Thank you !

Offline

Board footer

Powered by FluxBB