You are not logged in.

#1 2021-10-12 04:54:16

YagokoroEirin
Member
Registered: 2020-10-28
Posts: 4

Laptop boot into black screen and cannot show dm.

I  managered intel and nvidia gpu driver with optimus manager qt for several months.

I accidentally ran the “nvidia-modprobe” today .

  nvidia-modprobe 

Then I noticed that used [optimus manager qt] to switch "integrated " would cause black screen.
Then I type

  optimus-manager --switch integrated  

,
the result was still black screen . Unexpected I cannot boot into GUI  with optimus manager (integrated, nvidia, hybrid,)

Then I try to remove optimus manager and optimus manager-qt the result was still black screen.

then I try to edit xorg.conf.d file:delete 10-optimus-manager.conf and try (https://wiki.archlinux.org/title/Xorg#M … figuration)

 /etc/X11/xorg.conf.d/10-headless.conf
Section "Monitor"
        Identifier "dummy_monitor"
        HorizSync 28.0-80.0
        VertRefresh 48.0-75.0
        Modeline "1920x1080" 172.80 1920 2040 2248 2576 1080 1081 1084 1118
EndSection

Section "Device"
        Identifier "dummy_card"
        VideoRam 256000
        Driver "dummy"
EndSection

Section "Screen"
        Identifier "dummy_screen"
        Device "dummy_card"
        Monitor "dummy_monitor"
        SubSection "Display"
        EndSubSection
EndSection 

didnot matter.

now my X11 folder:

 X11
├── xinit
│   └── xinitrc.d
│       ├── 40-libcanberra-gtk-module.sh
│       └── 50-systemd-user.sh
├
├── xorg.conf.d
└── Xsession.d
    └── 72sogoupinyin

some information:

 > xrandr
Can't open display  
 > sudo systemctl status sddm.service
[sudo] password for chippy: 
● sddm.service - Simple Desktop Display Manager
     Loaded: loaded (/usr/lib/systemd/system/sddm.service; enabled; vendor preset: disabled)
     Active: active (running) since Tue 2021-10-12 12:45:51 CST; 6min ago
       Docs: man:sddm(1)
             man:sddm.conf(5)
   Main PID: 1970 (sddm)
      Tasks: 2 (limit: 18981)
     Memory: 23.1M
        CPU: 205ms
     CGroup: /system.slice/sddm.service
             └─1970 /usr/bin/sddm

Oct 12 12:45:54 Archlinux sddm[1970]: Failed to read display number from pipe
Oct 12 12:45:54 Archlinux sddm[1970]: Display server stopping...
Oct 12 12:45:54 Archlinux sddm[1970]: Attempt 2 starting the Display server on vt 1 failed
Oct 12 12:45:56 Archlinux sddm[1970]: Display server starting...
Oct 12 12:45:56 Archlinux sddm[1970]: Adding cookie to "/var/run/sddm/{3383cf33-62b4-4cfa-8e19-cafeebe14ee6}"
Oct 12 12:45:56 Archlinux sddm[1970]: Running: /usr/bin/X -nolisten tcp -background none -seat seat0 vt1 -au>
Oct 12 12:45:56 Archlinux sddm[1970]: Failed to read display number from pipe

I am a newbie and cannot know more.
How should I solve this problem?

Offline

#2 2021-10-12 06:49:58

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,112

Re: Laptop boot into black screen and cannot show dm.

Post your /var/log/Xorg.0.log and

sudo journalctl -b
systemctl status optimus-manager

And remove that xorg conf beforehand, you don't want and don't have a headless configuration.

Last edited by V1del (2021-10-12 06:51:15)

Online

#3 2021-10-12 08:40:42

YagokoroEirin
Member
Registered: 2020-10-28
Posts: 4

Re: Laptop boot into black screen and cannot show dm.

this is /var/log/Xorg.0.log

> cat /var/log/Xorg.0.log
[    11.039] (--) Log file renamed from "/var/log/Xorg.pid-2099.log" to "/var/log/Xorg.0.log"
[    11.040] 
X.Org X Server 1.20.13
X Protocol Version 11, Revision 0
[    11.040] Build Operating System: Linux Archlinux
[    11.040] Current Operating System: Linux Archlinux 5.14.11-arch1-1 #1 SMP PREEMPT Sun, 10 Oct 2021 00:48:26 +0000 x86_64
[    11.040] Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=/dev/mapper/linux--root-lvroot rw loglevel=3 quiet
[    11.040] Build Date: 04 August 2021  08:13:54AM
[    11.040]  
[    11.040] Current version of pixman: 0.40.0
[    11.040]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    11.040] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    11.040] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Oct 12 12:58:54 2021
[    11.040] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    11.040] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    11.040] (==) ServerLayout "layout"
[    11.040] (**) |-->Screen "integrated" (0)
[    11.040] (**) |   |-->Monitor "<default monitor>"
[    11.040] (**) |   |-->Device "integrated"
[    11.040] (**) |   |-->GPUDevice "integrated"
[    11.040] (**) |   |-->GPUDevice "nvidia"
[    11.040] (==) No monitor specified for screen "integrated".
        Using a default monitor configuration.
[    11.040] (**) |-->Inactive Device "nvidia"
[    11.040] (**) Option "IgnoreABI" "1"
[    11.040] (**) Ignoring ABI Version
[    11.040] (==) Automatically adding devices
[    11.040] (==) Automatically enabling devices
[    11.040] (==) Automatically adding GPU devices
[    11.040] (==) Automatically binding GPU devices
[    11.040] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    11.040] (WW) The directory "/usr/share/fonts/misc" does not exist.
[    11.040]    Entry deleted from font path.
[    11.040] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    11.040]    Entry deleted from font path.
[    11.040] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    11.040]    Entry deleted from font path.
[    11.040] (==) FontPath set to:
        /usr/share/fonts/TTF,
        /usr/share/fonts/100dpi,
        /usr/share/fonts/75dpi
[    11.040] (**) ModulePath set to "/usr/lib/nvidia,/usr/lib32/nvidia,/usr/lib32/nvidia/xorg/modules,/usr/lib32/xorg/modules,/usr/lib64/nvidia/xorg/modules,/usr/lib64/nvidia/xorg,/usr/lib64/xorg/modules"
[    11.040] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    11.040] (II) Module ABI versions:
[    11.040]    X.Org ANSI C Emulation: 0.4
[    11.040]    X.Org Video Driver: 24.1
[    11.040]    X.Org XInput driver : 24.1
[    11.040]    X.Org Server Extension : 10.0
[    11.041] (++) using VT number 1

[    11.041] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    11.041] (II) xfree86: Adding drm device (/dev/dri/card1)
[    11.060] (II) xfree86: Adding drm device (/dev/dri/card0)
[    11.067] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/nvidia,/usr/lib32/nvidia,/usr/lib32/nvidia/xorg/modules,/usr/lib32/xorg/modules,/usr/lib64/nvidia/xorg/modules,/usr/lib64/nvidia/xorg,/usr/lib64/xorg/modules"
[    11.070] (--) PCI:*(0@0:2:0) 8086:3e9b:8086:2086 rev 0, Mem @ 0xab000000/16777216, 0x40000000/268435456, I/O @ 0x00007000/64, BIOS @ 0x????????/131072
[    11.070] (--) PCI: (1@0:0:0) 10de:2191:8086:2086 rev 161, Mem @ 0xac000000/16777216, 0x80000000/268435456, 0x90000000/33554432, I/O @ 0x00006000/128, BIOS @ 0x????????/524288
[    11.070] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    11.070] (II) LoadModule: "glx"
[    11.070] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    11.072] (II) Module glx: vendor="X.Org Foundation"
[    11.072]    compiled for 1.20.13, module version = 1.0.0
[    11.072]    ABI class: X.Org Server Extension, version 10.0
[    11.072] (II) LoadModule: "intel"
[    11.072] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    11.072] (EE) Failed to load /usr/lib/xorg/modules/drivers/intel_drv.so: /usr/lib/xorg/modules/drivers/intel_drv.so: file too short
[    11.072] (EE) Failed to load module "intel" (loader failed, 0)
[    11.072] (II) LoadModule: "nvidia"
[    11.072] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    11.072] (II) Module nvidia: vendor="NVIDIA Corporation"
[    11.072]    compiled for 1.6.99.901, module version = 1.0.0
[    11.072]    Module class: X.Org Video Driver
[    11.072] (II) NVIDIA dlloader X Driver  470.74  Mon Sep 13 23:05:04 UTC 2021
[    11.072] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    11.082] (II) Loading sub module "fb"
[    11.082] (II) LoadModule: "fb"
[    11.082] (II) Loading /usr/lib/xorg/modules/libfb.so
[    11.082] (II) Module fb: vendor="X.Org Foundation"
[    11.082]    compiled for 1.20.13, module version = 1.0.0
[    11.082]    ABI class: X.Org ANSI C Emulation, version 0.4
[    11.082] (II) Loading sub module "wfb"
[    11.082] (II) LoadModule: "wfb"
[    11.082] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    11.082] (II) Module wfb: vendor="X.Org Foundation"
[    11.082]    compiled for 1.20.13, module version = 1.0.0
[    11.082]    ABI class: X.Org ANSI C Emulation, version 0.4
[    11.082] (II) Loading sub module "ramdac"
[    11.082] (II) LoadModule: "ramdac"
[    11.082] (II) Module "ramdac" already built-in
[    11.083] (EE) No devices detected.
[    11.083] (EE) 
Fatal server error:
[    11.083] (EE) no screens found(EE) 
[    11.083] (EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
[    11.083] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    11.083] (EE) 
[    11.109] (EE) Server terminated with error (1). Closing log file.

this is optimus-manager status

> systemctl status optimus-manager

● optimus-manager.service - Optimus Manager Commands Daemon
     Loaded: loaded (/usr/lib/systemd/system/optimus-manager.service; enabled; vendor preset: disabled)
     Active: active (running) since Tue 2021-10-12 12:58:50 CST; 3h 39min ago
    Process: 460 ExecStartPre=/usr/bin/python3 -u -m optimus_manager.hooks.pre_daemon_start (code=exited, status=0/SUCCESS)
    Process: 515 ExecStartPre=/usr/bin/python3 -u -m optimus_manager.hooks.pre_xorg_start (code=exited, status=0/SUCCESS)
   Main PID: 1999 (python3)
      Tasks: 1 (limit: 18981)
     Memory: 34.3M
        CPU: 3.809s
     CGroup: /system.slice/optimus-manager.service
             └─1999 /usr/bin/python3 -u -m optimus_manager.daemon

Oct 12 12:58:50 Archlinux python3[515]: [3932] INFO: Writing to /etc/X11/xorg.conf.d/10-optimus-manager.conf
Oct 12 12:58:50 Archlinux python3[515]: [3932] INFO: Writing state {'type': 'pending_post_xorg_start', 'switch_id': '20211012T125846', 'requested_mode': 'hybrid'}
Oct 12 12:58:50 Archlinux python3[515]: [3933] INFO: Xorg pre-start hook completed successfully.
Oct 12 12:58:50 Archlinux systemd[1]: Started Optimus Manager Commands Daemon.
Oct 12 12:58:50 Archlinux python3[1999]: [1] INFO: # Commands daemon
Oct 12 12:58:50 Archlinux python3[1999]: [1] INFO: Opening UNIX socket
Oct 12 12:58:50 Archlinux python3[1999]: [1] INFO: Awaiting commands
Oct 12 16:27:35 Archlinux python3[1999]: [12525111] INFO: Received command : {"type": "switch", "args": {"mode": "hybrid"}}
Oct 12 16:27:35 Archlinux python3[1999]: [12525111] INFO: Writing requested GPU mode hybrid
Oct 12 16:27:35 Archlinux python3[1999]: [12525112] INFO: Writing state {'type': 'pending_pre_xorg_start', 'requested_mode': 'hybrid', 'current_mode': 'hybrid'}

Offline

#4 2021-10-12 10:01:50

YagokoroEirin
Member
Registered: 2020-10-28
Posts: 4

Re: Laptop boot into black screen and cannot show dm.

well,after tries I can boot into GUI with optimus manager disable.
but when I enable the optimus,it go to black screen again.
the x11 log is:

> cat /var/log/Xorg.0.log
[    11.129] (--) Log file renamed from "/var/log/Xorg.pid-2106.log" to "/var/log/Xorg.0.log"
[    11.130] 
X.Org X Server 1.20.13
X Protocol Version 11, Revision 0
[    11.130] Build Operating System: Linux Archlinux
[    11.130] Current Operating System: Linux Archlinux 5.14.11-arch1-1 #1 SMP PREEMPT Sun, 10 Oct 2021 00:48:26 +0000 x86_64
[    11.130] Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=/dev/mapper/linux--root-lvroot rw loglevel=3 quiet
[    11.130] Build Date: 04 August 2021  08:13:54AM
[    11.130]  
[    11.130] Current version of pixman: 0.40.0
[    11.130]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    11.130] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    11.130] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Oct 12 17:45:04 2021
[    11.130] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    11.130] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    11.130] (==) ServerLayout "layout"
[    11.130] (**) |-->Screen "integrated" (0)
[    11.130] (**) |   |-->Monitor "<default monitor>"
[    11.130] (**) |   |-->Device "integrated"
[    11.130] (**) |   |-->GPUDevice "nvidia"
[    11.130] (==) No monitor specified for screen "integrated".
        Using a default monitor configuration.
[    11.130] (**) |-->Inactive Device "nvidia"
[    11.130] (**) Option "IgnoreABI" "1"
[    11.130] (**) Ignoring ABI Version
[    11.130] (==) Automatically adding devices
[    11.130] (==) Automatically enabling devices
[    11.130] (==) Automatically adding GPU devices
[    11.130] (==) Automatically binding GPU devices
[    11.130] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    11.130] (WW) The directory "/usr/share/fonts/misc" does not exist.
[    11.130]    Entry deleted from font path.
[    11.130] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    11.130]    Entry deleted from font path.
[    11.130] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    11.130]    Entry deleted from font path.
[    11.130] (==) FontPath set to:
        /usr/share/fonts/TTF,
        /usr/share/fonts/100dpi,
        /usr/share/fonts/75dpi
[    11.130] (**) ModulePath set to "/usr/lib/nvidia,/usr/lib32/nvidia,/usr/lib32/nvidia/xorg/modules,/usr/lib32/xorg/modules,/usr/lib64/nvidia/xorg/modules,/usr/lib64/nvidia/xorg,/usr/lib64/xorg/modules"
[    11.130] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    11.130] (II) Module ABI versions:
[    11.130]    X.Org ANSI C Emulation: 0.4
[    11.130]    X.Org Video Driver: 24.1
[    11.130]    X.Org XInput driver : 24.1
[    11.130]    X.Org Server Extension : 10.0
[    11.130] (++) using VT number 1

[    11.131] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    11.131] (II) xfree86: Adding drm device (/dev/dri/card1)
[    11.152] (II) xfree86: Adding drm device (/dev/dri/card0)
[    11.155] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/nvidia,/usr/lib32/nvidia,/usr/lib32/nvidia/xorg/modules,/usr/lib32/xorg/modules,/usr/lib64/nvidia/xorg/modules,/usr/lib64/nvidia/xorg,/usr/lib64/xorg/modules"
[    11.156] (--) PCI:*(0@0:2:0) 8086:3e9b:8086:2086 rev 0, Mem @ 0xab000000/16777216, 0x40000000/268435456, I/O @ 0x00007000/64, BIOS @ 0x????????/131072
[    11.156] (--) PCI: (1@0:0:0) 10de:2191:8086:2086 rev 161, Mem @ 0xac000000/16777216, 0x80000000/268435456, 0x90000000/33554432, I/O @ 0x00006000/128, BIOS @ 0x????????/524288
[    11.156] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    11.157] (II) LoadModule: "glx"
[    11.157] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    11.157] (II) Module glx: vendor="X.Org Foundation"
[    11.157]    compiled for 1.20.13, module version = 1.0.0
[    11.157]    ABI class: X.Org Server Extension, version 10.0
[    11.157] (II) LoadModule: "intel"
[    11.157] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    11.157] (EE) Failed to load /usr/lib/xorg/modules/drivers/intel_drv.so: /usr/lib/xorg/modules/drivers/intel_drv.so: file too short
[    11.157] (EE) Failed to load module "intel" (loader failed, 0)
[    11.157] (II) LoadModule: "nvidia"
[    11.157] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    11.158] (II) Module nvidia: vendor="NVIDIA Corporation"
[    11.158]    compiled for 1.6.99.901, module version = 1.0.0
[    11.158]    Module class: X.Org Video Driver
[    11.158] (II) NVIDIA dlloader X Driver  470.74  Mon Sep 13 23:05:04 UTC 2021
[    11.158] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    11.158] (II) Loading sub module "fb"
[    11.158] (II) LoadModule: "fb"
[    11.158] (II) Loading /usr/lib/xorg/modules/libfb.so
[    11.158] (II) Module fb: vendor="X.Org Foundation"
[    11.158]    compiled for 1.20.13, module version = 1.0.0
[    11.158]    ABI class: X.Org ANSI C Emulation, version 0.4
[    11.158] (II) Loading sub module "wfb"
[    11.158] (II) LoadModule: "wfb"
[    11.158] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    11.158] (II) Module wfb: vendor="X.Org Foundation"
[    11.158]    compiled for 1.20.13, module version = 1.0.0
[    11.158]    ABI class: X.Org ANSI C Emulation, version 0.4
[    11.158] (II) Loading sub module "ramdac"
[    11.158] (II) LoadModule: "ramdac"
[    11.158] (II) Module "ramdac" already built-in
[    11.158] (EE) No devices detected.
[    11.158] (EE) 
Fatal server error:
[    11.158] (EE) no screens found(EE) 
[    11.158] (EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
[    11.158] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    11.158] (EE) 
[    11.158] (EE) Server terminated with error (1). Closing log file.
 ~                                      

the error is

[    11.157] (EE) Failed to load /usr/lib/xorg/modules/drivers/intel_drv.so: /usr/lib/xorg/modules/drivers/intel_drv.so: file too short
[    11.157] (EE) Failed to load module "intel" (loader failed, 0)

How to make optimus work again?

Offline

#5 2021-10-12 11:40:41

seth
Member
Registered: 2012-09-03
Posts: 24,102

Re: Laptop boot into black screen and cannot show dm.

[    11.157] (EE) Failed to load /usr/lib/xorg/modules/drivers/intel_drv.so: /usr/lib/xorg/modules/drivers/intel_drv.so: file too short
pacman -Qikk xf86-video-intel

and consider just removing the package.

Offline

Board footer

Powered by FluxBB