You are not logged in.

#1 2021-10-29 20:18:26

5h5egrtsetetg
Member
Registered: 2021-10-29
Posts: 3

ERROR: device '/dev/mapper/crypt' not found. Skipping fsck.

I've made encrypted installations of arch before but now I was facing issues. When reboot  it appears.

ERROR: device '/dev/mapper/crypt/' not found. Skipping fsck.
mount /new_root: no filesystem type specified.
You are now being dropped into an emergency shell.
sh: can't access tty; job control turned off
[rootfs ]#

Here's my HOOKS on /etc/mkinitcpio.conf:

HOOKS=(base udev autodetect keyboard keymap modconf block encrypt  filesystems fsck)

And /etc/default/grub:

GRUB_DEFAULT=0
GRUB_TIMEOUT=1
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet"
GRUB_CMDLINE_LINUX="cryptdevice=UUID=ae53f7ef-739d-4748-99ce-5529980355ad:crypt root=/dev/mapper/crypt"

It is not a lvm on luks or viceversa (I said this because there are similar posts but using lvm) . It contains a /boot/efi partition and the root which is encrypted.

Offline

#2 2021-10-29 23:04:37

loqs
Member
Registered: 2014-03-06
Posts: 14,258

Re: ERROR: device '/dev/mapper/crypt' not found. Skipping fsck.

From the rescue prompt does /dev/disk/by-uuid/ae53f7ef-739d-4748-99ce-5529980355ad exist if not does the device node for the root storage device exist in /dev?

Offline

#3 2021-10-30 18:55:00

5h5egrtsetetg
Member
Registered: 2021-10-29
Posts: 3

Re: ERROR: device '/dev/mapper/crypt' not found. Skipping fsck.

Yes. I typed blkid and It showed the uuid of /dev/sda2 (/dev/mapper/crypt) and because of curiosity I put  /dev/disk/by-uuid/ae53f7ef-739d-4748-99ce-5529980355ad and the output was sh: /dev/disk/by-uuid/ae53f7ef-739d-4748-99ce-5529980355ad: Permission denied,

Last edited by 5h5egrtsetetg (2021-10-30 18:58:54)

Offline

#4 2021-10-30 20:19:15

loqs
Member
Registered: 2014-03-06
Posts: 14,258

Re: ERROR: device '/dev/mapper/crypt' not found. Skipping fsck.

What if you try mounting /dev/mapper/crypt from the rescue shell?

mount /dev/mapper/crypt /new_root

Offline

#5 2021-10-31 12:13:19

5h5egrtsetetg
Member
Registered: 2021-10-29
Posts: 3

Re: ERROR: device '/dev/mapper/crypt' not found. Skipping fsck.

It worked but solved half of the problem. I did open /dev/mapper/crypt using cryptsetup then I used the command that you gave me and then exit.

After that I could login with my password and enter to the base install, now the thing is each time I reboot it shows the same issue so Is there a way to save the config or something like that?

Offline

#6 2021-10-31 13:14:56

Piri
Member
Registered: 2018-06-02
Posts: 69

Re: ERROR: device '/dev/mapper/crypt' not found. Skipping fsck.

I have a hunch that the initramfs you are booting from is missing the encrypt hook. Double check that your boot partition is mounted correctly and then rebuild the initramfs

 # mkinitcpio -p linux 

If that doesn't solve the issue then post the output of the above command plus

$ lsblk -o NAME,MOUNTPOINTS,UUID

and the contents of  /boot/grub/grub.cfg (or wherever your grub config is)

Last edited by Piri (2021-10-31 13:15:20)

Offline

Board footer

Powered by FluxBB