You are not logged in.

#1 2021-11-07 19:15:54

Niky04
Member
Registered: 2021-11-07
Posts: 4

Conky module cairo missing(Installing a conky configuration)

Hello guys, im new in LInux(especially in Arch), setting my desktop environment(xfce4), i got this problem installing a Conky widget configuration.

conky: llua_load: ...y/Conky_Revisited_2/Conky_Square_Horizontal/settings.lua:73: module 'cairo' not found:
no field package.preload['cairo']
no file '/usr/share/lua/5.4/cairo.lua'
no file '/usr/share/lua/5.4/cairo/init.lua'
no file '/usr/lib/lua/5.4/cairo.lua'
no file '/usr/lib/lua/5.4/cairo/init.lua'
no file './cairo.lua'
no file './cairo/init.lua'
no file '/usr/lib/conky/libcairo.so'
no file '/usr/lib/lua/5.4/cairo.so'
no file '/usr/lib/lua/5.4/loadall.so'
no file './cairo.so'

Can someone help me?

Last edited by Niky04 (2021-11-07 19:19:39)

Offline

#2 2021-11-07 19:43:01

dakota
Member
Registered: 2016-05-20
Posts: 161

Re: Conky module cairo missing(Installing a conky configuration)

What command are you using to install the "Conky widget configuration"?

Offline

#3 2021-11-07 19:46:29

Niky04
Member
Registered: 2021-11-07
Posts: 4

Re: Conky module cairo missing(Installing a conky configuration)

i did ls in cocky folder, with the configuration, and then ./start_conky_sh

Offline

#4 2021-11-07 20:26:01

dakota
Member
Registered: 2016-05-20
Posts: 161

Re: Conky module cairo missing(Installing a conky configuration)

I'm still not clear on what you're trying to do? Install conky? Startup conky? Install a configuration manager for conky? Start the configuration manager?

I'm not familiar with the script. What do you expect it to do?

While I don't think "conky" depends on cairo, I do think that "conky-manager" does.

It might help to post the contents of "start_conky_sh" [in BBCode brackets]

Cheers,

Offline

#5 2021-11-08 12:52:29

robson75
Member
From: Poland
Registered: 2020-06-28
Posts: 73

Re: Conky module cairo missing(Installing a conky configuration)

Conky-manager has long been useless since conky switched to 1.10 syntax.
https://github.com/brndnmtthws/conky/wi … igs-to-110


Arch Linux Xfce+compiz - 64Bit Linux User #621110

Offline

Board footer

Powered by FluxBB