You are not logged in.

#1 2021-11-08 12:03:50

Zod
Member
From: Hoosiertucky
Registered: 2019-03-10
Posts: 495

[solved] upgraded some xorg stuff, now the mouse cursor is slow

I don't know how to explain it, the mouse cursor is slow and sloppy.

It doesn't start moving when I start and it doesn't stop when I stop

I'm going to revert the changes after I drink some coffee, Until then I'll leave it like it is, in case anyone is interested

Linux carlos 5.15.1-zen1-1-zen #1 ZEN SMP PREEMPT Sat, 06 Nov 2021 23:40:12 +0000 x86_64 GNU/Linux

Testing and community testing are enabled



This is what got upgraded..

2021-11-08T06:06:57-0500] [ALPM] transaction started
[2021-11-08T06:06:57-0500] [ALPM] upgraded libseccomp (2.5.2-1 -> 2.5.3-1)
[2021-11-08T06:06:57-0500] [PACKAGEKIT] upgraded libseccomp (2.5.2-1 -> 2.5.3-1)
[2021-11-08T06:06:57-0500] [ALPM] upgraded xf86-input-libinput (1.2.0-1 -> 1.2.0-2)
[2021-11-08T06:06:57-0500] [PACKAGEKIT] upgraded xf86-input-libinput (1.2.0-1 -> 1.2.0-2)
[2021-11-08T06:06:57-0500] [ALPM] upgraded xf86-video-vesa (2.5.0-1 -> 2.5.0-2)
[2021-11-08T06:06:57-0500] [PACKAGEKIT] upgraded xf86-video-vesa (2.5.0-1 -> 2.5.0-2)
[2021-11-08T06:06:57-0500] [ALPM] upgraded xorg-server-common (1.20.13-3 -> 21.1.1-2)
[2021-11-08T06:06:57-0500] [PACKAGEKIT] upgraded xorg-server-common (1.20.13-3 -> 21.1.1-2)
[2021-11-08T06:06:57-0500] [ALPM] upgraded xorg-server (1.20.13-3 -> 21.1.1-2)
[2021-11-08T06:06:57-0500] [PACKAGEKIT] upgraded xorg-server (1.20.13-3 -> 21.1.1-2)
[2021-11-08T06:06:57-0500] [ALPM] upgraded xorg-server-devel (1.20.13-3 -> 21.1.1-2)
[2021-11-08T06:06:57-0500] [PACKAGEKIT] upgraded xorg-server-devel (1.20.13-3 -> 21.1.1-2)
[2021-11-08T06:06:57-0500] [ALPM] upgraded xorg-server-xephyr (1.20.13-3 -> 21.1.1-2)
[2021-11-08T06:06:57-0500] [PACKAGEKIT] upgraded xorg-server-xephyr (1.20.13-3 -> 21.1.1-2)
[2021-11-08T06:06:57-0500] [ALPM] upgraded xorg-server-xnest (1.20.13-3 -> 21.1.1-2)
[2021-11-08T06:06:57-0500] [PACKAGEKIT] upgraded xorg-server-xnest (1.20.13-3 -> 21.1.1-2)
[2021-11-08T06:06:57-0500] [ALPM] upgraded xorg-server-xvfb (1.20.13-3 -> 21.1.1-2)
[2021-11-08T06:06:57-0500] [PACKAGEKIT] upgraded xorg-server-xvfb (1.20.13-3 -> 21.1.1-2)
[2021-11-08T06:06:57-0500] [ALPM] transaction completed
[2021-11-08T06:06:57-0500] [ALPM] running '30-systemd-update.hook'...
[2021-11-08T06:06:57-0500] [ALPM] running '90-packagekit-refresh.hook'...

Nvidia 390xx.dkms (390xx duh)

lsmod | grep nvidia

nvidia_drm             53248  1
nvidia_uvm           1904640  0
nvidia_modeset       1060864  1 nvidia_drm
nvidia              15904768  17 nvidia_uvm,nvidia_modeset
ipmi_msghandler        81920  2 ipmi_devintf,nvidia

sudo journalctl -b --no-pager

http://sprunge.us/2g5C7H

Ok, everything is reverted and it's good as new.

Edit:
Cut over to nouveau, perhaps the 390xx drivers will get patched someday.

Edit:
Turns out it didn't need a patch, just a section for xorg.conf. See nvidia-390xx-dkms, in the comments, for more information.

Last edited by Zod (2021-11-10 18:04:10)

Offline

Board footer

Powered by FluxBB