You are not logged in.

#1 2021-11-09 03:49:29

gavinL
Member
Registered: 2021-11-09
Posts: 1

using Citrix gateway cleint issue under auchlinux

Recently, I have to use citrix gateway to access our servers, I downloaded the *.deb package from Citrix website.

Then I did debtap to install the package, but when I tried to lunch the nsgclient, the error occurred as below:

==>   /opt/Citrix/NSGClient/bin/NSGClient: error while loading shared libraries: libnm-glib.so.4: cannot open shared object file: No such file or directory

Then I downloaded the libnm-glib*.deb package and tried to install it, eror came out as below:

==>  error: failed to prepare transaction (package architecture is not valid)

I tried to find any existing solutions for this issue by google, unfortunately, there seems no solutions.

Is there anybody can help me out or any suggestions on this?

Offline

#2 2021-11-10 10:43:34

philo
Member
Registered: 2015-01-26
Posts: 167

Re: using Citrix gateway cleint issue under auchlinux

libnm-glib.so.4  is a 32 bit NetworkManager lib?


Maybe this would help:

https://bbs.archlinux.org/viewtopic.php?id=269011

Please use code tags.

Also note that debtap does not work for all debian packages, especially because of dependency conflicts.

EDIT-
You probably know there is an Arch wiki for  citrix.

Last edited by philo (2021-11-12 08:39:36)

Offline

#3 2021-11-12 01:21:42

zoqaeski
Member
From: /earth/australia/.
Registered: 2009-09-30
Posts: 132

Re: using Citrix gateway cleint issue under auchlinux

Don't install the *.deb package from the Citrix website. Use the package in the AUR instead. If you're running GNOME on Wayland, also enable these settings, or certain keyboard shortcuts (like Alt-Tab) won't work in the remote session.

gsettings set org.gnome.mutter.wayland xwayland-grab-access-rules "['Wfica']"
gsettings set org.gnome.mutter.wayland xwayland-allow-grabs true

Offline

Board footer

Powered by FluxBB