You are not logged in.

#1 2021-11-10 21:29:56

lpr1
Member
Registered: 2017-10-08
Posts: 57

[Solved] GDM always starts wayland session

Since 41.1 upgrade, GDM always starts wayland session even thought x11 is selected in GDM menu. Precisely, if x11 is "auto selected" as "last session", once I re-select it, it logins to X11 session as it should, next reboot = problem is back.

To clarify:
1. I always login via GDM by simply pressing enter, typing my password and pressing enter again. Using this method it will always result in wayland session even if x11 is selected.
2. If I press enter, type my password, then select x11 from the GDM (regardless if it's already selected or not), it will log in to x11 session as expected.

The only way to prevent this is by uncommenting "#WaylandEnable=false", I didn't find any other way.

Does anyone have this issue as well?

Last edited by lpr1 (2021-11-14 05:57:44)

Offline

#2 2021-11-11 00:54:30

javaman67
Member
Registered: 2021-11-11
Posts: 1

Re: [Solved] GDM always starts wayland session

I'm having the same issue here too.

The only way to keep it in X11 was to edit /etc/gdm/custom.conf  and  uncommenting "#WaylandEnable=false",

Last edited by javaman67 (2021-11-11 10:01:32)

Offline

#3 2021-11-11 05:29:58

lpr1
Member
Registered: 2017-10-08
Posts: 57

Re: [Solved] GDM always starts wayland session

javaman67 wrote:

I'm having the same issue here too.

Ok, so it's not just me, and it seems to be a bug, thanks. Will see if it's reported by now.

Offline

#4 2021-11-11 12:50:34

ossaffilate
Member
Registered: 2021-11-11
Posts: 1

Re: [Solved] GDM always starts wayland session

I cam here to say the same, always rebooting on wayland but when i logout/login it comes back to Xorg

Offline

#5 2021-11-11 18:14:59

aloisP
Member
Registered: 2021-10-07
Posts: 1

Re: [Solved] GDM always starts wayland session

javaman67 wrote:

I'm having the same issue here too.

The only way to keep it in X11 was to edit /etc/gdm/custom.conf  and  uncommenting "#WaylandEnable=false",

Thank you so much, this was the solution for me as well!

Offline

#6 2021-11-11 21:26:42

kabouzeid
Member
Registered: 2021-11-11
Posts: 3

Re: [Solved] GDM always starts wayland session

Worked for me too, thank you so much!

Offline

#7 2021-11-11 21:46:04

Starwalker
Member
Registered: 2021-08-21
Posts: 1

Re: [Solved] GDM always starts wayland session

You don't need to disable Wayland. Just do the following - on the GDM login screen click on the session icon (lower right corner) and select 'GNOME', then select 'GNOME on Xorg'. Now login. You should be logged in X11.
The issue is that every time you log in you need to select something else and then re-select GNOME on Xorg. It's inconvenient, but at least you still have a choice to go to Wayland if you need it.

Offline

#8 2021-11-13 20:04:48

flyingpig
Member
Registered: 2021-05-30
Posts: 2
Website

Re: [Solved] GDM always starts wayland session

This should be resolved in the next Arch Linux release of gdm. A fix upstream was already merged into the main branch, but it wasn't included with the 41.0 release.

Last edited by flyingpig (2021-11-13 20:14:51)

Offline

#9 2021-11-13 22:33:29

lpr1
Member
Registered: 2017-10-08
Posts: 57

Re: [Solved] GDM always starts wayland session

flyingpig wrote:

This should be resolved in the next Arch Linux release of gdm. A fix upstream was already merged into the main branch, but it wasn't included with the 41.0 release.

Good thanks. will mark as solved once fix lands.

Offline

#10 2021-11-13 23:29:02

flyingpig
Member
Registered: 2021-05-30
Posts: 2
Website

Re: [Solved] GDM always starts wayland session

flyingpig wrote:

This should be resolved in the next Arch Linux release of gdm. …

Resolved with gdm 41.0+r15+g23ebe617-1.

Offline

#11 2021-11-14 05:57:07

lpr1
Member
Registered: 2017-10-08
Posts: 57

Re: [Solved] GDM always starts wayland session

Yup, it's fixed now with gdm 41.0+r15+g23ebe617-1, marked as solved.

Offline

#12 2021-11-14 11:07:43

kabouzeid
Member
Registered: 2021-11-11
Posts: 3

Re: [Solved] GDM always starts wayland session

can confirm

Offline

Board footer

Powered by FluxBB