You are not logged in.

#1 2021-11-11 14:57:31

From: Hungary
Registered: 2021-11-11
Posts: 1

[SOLVED] BIOS does not load any bootloader in UEFI mode

I post this issue only to help others if they face the same problem.
I installed archlinux on root zfs, created a fat32 EFI partition, a zfs boot partition and a third one for zfs root. When I set up my BIOS settings to allow UEFI boot only the system every time boots directly into the BIOS menu. No error message.
When I copied the grubx64.efi file to the root of the EFI partition and set up the boot option directly from my BIOS menu to use this file it still boots into the BIOS directly.
If I rename this file to shellx64.efi then choose the option from the BIOS menu to "Launch EFI shell" then it loads the grub menu. So I thought what the hell is happening. I went through all the troubleshooting that is documented on the archwiki but nothing helped.

I saw in my BIOS that I have UEFI shell version 2.0. So I've downloaded the next UEFI shell: Precompiled UEFI Shell v2 binary with bcfg modified to work with UEFI pre-2.3 firmware and moved to my EFI partition in the root directory as shellx64.efi. On the next boot I've chosen from the BIOS menu the "Launch UEFI shell" option (remove any USB storage device before boot) then the UEFI shell loaded. I selected my EFI partition


and tried to

cd EFI

and an error message came up that the target is not a directory but when I listed the content


it showed EFI is there and it is a directory. I've made a google search and found this solution that helped: FreeBSD 10.3 UEFI, cannot boot with Intel Server Board.
I copy a quote and the code from this link to have it here too for sure.

The attribute of the "EFI" directory is wrong after installation.
The attribute should be "D" but not "A".
So, correct the attribute to "D", then the Internal UEFI shell can change into the "EFI" boot directory and boot it up.

fs0:\> attrib
attrib: A    fs0:\EFI

fs0:\> attrib -a efi
attrib:      fs0:\EFI

fs0:\> ls
Directory of: fs0:\

  01/08/16  01:49p                  0 EFI
  01/08/16  01:49p <DIR>            0 EFI
          1 File(s)          0 bytes
          1 Dir(s)

fs0:\> rm efi
removing fs0:\EFI
- [ok]

fs0:\> ls
Directory of: fs0:\

  01/08/16  01:49p <DIR>            0 EFI
          0 File(s)          0 bytes
          1 Dir(s)

fs0:\> attrib
attrib:D     fs0:\EFI

fs0:\> cd efi

fs0:\EFI> ls
Directory of: fs0:\EFI

  01/08/16  01:49p <DIR>            0 .
  01/08/16  01:49p <DIR>            0 ..
  01/08/16  01:49p <DIR>            0 BOOT
          0 File(s)          0 bytes
          3 Dir(s)


Last edited by kal-web-dev (2021-11-11 16:35:48)


Board footer

Powered by FluxBB