You are not logged in.

#1 2021-11-12 12:41:29

Registered: 2021-02-10
Posts: 10

[SOLVED] Unable to launch steam.


When I enter steam in the terminal this happens:

Running Steam on arch rolling 64-bit
STEAM_RUNTIME is enabled automatically
Steam runtime environment up-to-date!
Can't find 'steam-runtime-check-requirements', continuing anyway
WARNING: Using default/fallback debugger launch

I have installed it through multilib. nvidia, nvidia-utils, lib32-nvidia-utils are all installed.

When I try and launch it from the taskbar, nothing happenes.

Kind regards.

Last edited by Klintyfye (2021-11-13 10:37:48)


#2 2021-11-12 22:23:31

Registered: 2021-07-16
Posts: 266

Re: [SOLVED] Unable to launch steam.

Do you happen to have a lingering steam process running in the background?

Failing that, try … _correctly and see if it helps.


#3 2021-11-12 23:10:59

Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,507

Re: [SOLVED] Unable to launch steam.

Install both extra/mesa-demos and multilib/lib32-mesa-demos and post the output of


Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.


#4 2021-11-13 03:24:15

Registered: 2021-03-26
Posts: 2

Re: [SOLVED] Unable to launch steam.

I had the same problem after pacman -Syu today. I'm using mesa-git from Laurent Carlier.

What fixed my issue was resetting steam and downgrading all mesagit packages.

Reset steam via (you will lose  your custom proton installs):

steam-runtime --reset

Downgrade all mesagit packages (using downgrade program from AUR :

sudo downgrade $(pacman -Qg mesagit | awk '{print $2}')

With a reboot, Steam now works.

Edit: doing the --reset will remove all Steam settings, but will NOT delete your games. However, upon starting Steam, you must enable Proton in Steam settings, install a custom proton (if you had it installed before) and then select a proton version in a game's settings for the game to appear "installed".

Last edited by crazybit (2021-11-13 05:23:44)


#5 2021-11-13 09:00:36

Registered: 2021-02-10
Posts: 10

Re: [SOLVED] Unable to launch steam.

Ammako wrote:

Do you happen to have a lingering steam process running in the background?

After booting my machine up again today it just works. I'm guessing this is what it was but I have no way to back that statement up.

Just out of curiosity. How could I have checked if this was the case? Is there a "task manager" like in windows?


#6 2021-11-13 11:35:11

Forum Moderator
Registered: 2012-10-16
Posts: 14,477

Re: [SOLVED] Unable to launch steam.

There are a few on console, e.g. top or ps you can grep through. Otherwise most desktop environments will ship with one, e.g. KDE has one on Ctrl+Esc (... granted ksysguard is installed) most others will have something similar though I wouldn't know their keybinds


Board footer

Powered by FluxBB