You are not logged in.

#1 2021-11-23 12:31:57

Registered: 2021-11-23
Posts: 2

[SOLVED] Macbook 9,2 xorg/nouveau/vgaswitcheroo issues

Hi forum.

After running "pacman -Syu" I found that I was unable to "startx" successfully. I've since restored a backup so that I can get back to work, but I assume that updating my system again will lead to the same issue. Since I will probably have to upgrade my system eventually, I would like to try to solve the issue. I would appreciate any advice you can offer, such as what information is most likely relevant...

Obviously I won't be able to provide specific information about the error messages I'm seeing immediately, since I've restored a backup. But while I was troubleshooting, before giving up and reverting to a known-good state, I noticed the following:

Observed behavior:

- the secondary graphics card on my device (identified as "NVIDIA Corporation GK107M [GeForce GT 650M Mac Edition]" by lspci) was not being picked up by the driver ("lshw -c display" showed UNCLAIMED next to the device), whereas on the known-good configuration it shows nouveau under the configuration section
- /sys/kernel/debug/vgaswitcheroo/switch was not being created by the operating system, presumably because nouveau was not picking up the secondary graphics card
- I was able to get X to start in such a way that it seemed it was working perfectly except for not showing anything on screen (the session started and I was able to quit it with the hotkey that normally closes my window manager).

Known good config is running kernel 5.15.2-arch1-1. After update is 5.15.4. The device is a macbook pro 9,2.

It seems to me that when I was setting up this device way back when that the discrete graphics card was used by default, and to avoid this and use the integrated graphics I had to

echo IGD >> /sys/kernel/debug/vgaswitcheroo/switch

to turn off the discrete card. So my current theory is thus:

Current theory:

- after the update nouveau is not picking up my discrete graphics for some unknown reason
- X is able to start, but is unable to display to the screen since the discrete graphics are used by default
- because the discrete graphics aren't set up by any driver, vgaswitcheroo is also missing, so there is no way to switch the display to the integrated graphics

Can anyone suggest a workaround? Is there a way to force vgaswitcheroo to show up? Any idea why my discrete card is apparently not being set up properly? Am I barking up the wrong tree entirely? Any specific information that would be helpful to you helpful people?

Thanks for any advice, and for volunteering your time and attention by reading this far. It is immensely appreciated.

Last edited by docsunset (2021-12-22 12:52:10)


#2 2021-12-22 12:49:58

Registered: 2021-11-23
Posts: 2

Re: [SOLVED] Macbook 9,2 xorg/nouveau/vgaswitcheroo issues

After trying to upgrade again today, hoping that the latest kernel etc. would not have the same issue, I encountered the same behavior. Having been giving it some thought for a while, I tried just loading noueau:

sudo modprobe nouveau

That seemed to do the trick, and I am happily back to normal and up to date.


Board footer

Powered by FluxBB