You are not logged in.

#1 2021-11-30 06:42:35

littlefoot.longfoot
Member
Registered: 2021-11-30
Posts: 2

[Solved]ERROR: '/dev/disk/by-label/ARCH_202111' device did not show up

I'm trying to create a Bhyve virtual machine on FreeBSD. Here's what I see:

[    3.371742] Initramfs unpacking failed: write error
:: running early hook [udev]
Warning: /lib/modules/5.14.15-arch1-1/modules.devname not found - ignoring
systemd-tmpfiles: error while loading shared libraries: libsystemd-shared-249.so: cannot open shared object file: No such file or directory
/init: line 6: /usr/lib/systemd/systemd-udevd: not found
:: running early hook [archiso_pxe_nbd]
:: running hook [udev]
:: Triggering uevents...
udevadm: error while loading shared libraries: libsystemd-shared-249.so: cannot open shared object file: No such file or directory
udevadm: error while loading shared libraries: libsystemd-shared-249.so: cannot open shared object file: No such file or directory
udevadm: error while loading shared libraries: libsystemd-shared-249.so: cannot open shared object file: No such file or directory
:: running hook [memdisk]
:: running hook [archiso]
:: running hook [archiso_loop_mnt]
:: running hook [archiso_pxe_common]
:: running hook [archiso_pxe_nbd]
:: running hook [archiso_pxe_http]
:: running hook [archiso_pxe_nfs]
:: Mounting '/dev/disk/by-label/ARCH_202111' to '/run/archiso/bootmnt'
Waiting 30 seconds for device /dev/disk/by-label/ARCH_202111 ...
ERROR: '/dev/disk/by-label/ARCH_202111' device did not show up after 30 seconds...
   Falling back to interactive prompt
   You can try to fix the problem manually, log out when you are finished
sh: can't access tty; job control turned off
[rootfs ]# cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: BHYVE    Model: BHYVE DVD-ROM    Rev: 001 
  Type:   CD-ROM                           ANSI  SCSI revision: 05
[rootfs dev]# ls -d [^t]*
autofs           hpet             ptmx             vcsa
bsg              input            random           vcsa1
console          kmsg             rtc0             vcsu
cpu              lightnvm         snapshot         vcsu1
cpu_dma_latency  mem              udmabuf          vga_arbiter
dma_heap         null             urandom          zero
fb0              nvram            vcs
full             port             vcs1

The installation image:

file -sL /media/archlinux-2021.11.01-x86_64.iso 
/media/archlinux-2021.11.01-x86_64.iso: ISO 9660 CD-ROM filesystem data (DOS/MBR boot sector) 'ARCH_202111' (bootable)

And the launch command:

bhyve -m 512M -w -H \
        -s 0,hostbridge \
        -s 3,ahci-cd,/media/archlinux-2021.11.01-x86_64.iso \
        -s 4,virtio-blk,/dev/zvol/zroot/bhyve_vms/archvm \
        -s 5,virtio-net,tap0 \
        -s 29,fbuf,tcp=0.0.0.0:5914,w=800,h=600,wait \
        -s 30,xhci,tablet \
        -s 31,lpc \
        -l com1,stdio \
        -l bootrom,/usr/local/share/uefi-firmware/BHYVE_UEFI.fd archvm

Notably, /dev/disk/ doesn't exist.

What's wrong with it?

Last edited by littlefoot.longfoot (2021-12-03 23:07:26)

Offline

#2 2021-12-03 23:09:27

littlefoot.longfoot
Member
Registered: 2021-11-30
Posts: 2

Re: [Solved]ERROR: '/dev/disk/by-label/ARCH_202111' device did not show up

Solved. My admiration for FreeBSD grows yet again. It's the OS which most closely adheres to the original ethos of Unix.

Offline

#3 2022-11-22 15:24:22

vf
Member
Registered: 2020-04-07
Posts: 70

Re: [Solved]ERROR: '/dev/disk/by-label/ARCH_202111' device did not show up

"Solved" seems like a nice guideline to solve that kind of problem, thanks

Offline

Board footer

Powered by FluxBB