You are not logged in.

#1 2021-12-05 09:56:38

llesudb
Member
Registered: 2019-08-11
Posts: 19

[SOLVED] Upgrade breaks X

A recent system upgrade (which I have reverted) appears to have broken X on my system -- the GUI never starts up after booting (logs below). I'm using KDE with the proprietary nvidia drivers. My GPU model is NVIDIA Corporation TU116M [GeForce GTX 1660 Ti Mobile] (rev a1).

At first I thought my problem was the same as in this thread, but the fix there was to use older nvidia drivers from AUR, whereas my GPU is newer and should work with the current drivers.

This is the driver I need according to NVIDIA's website:

LINUX-AARCH64 (ARM64) DISPLAY DRIVER

Version:    470.86
Release Date:    2021.11.10
Operating System:    Linux aarch64
Language:    English (US)
File Size:    175.06 MB

lspci:

00:02.0 VGA compatible controller: Intel Corporation CoffeeLake-H GT2 [UHD Graphics 630]
	DeviceName: Onboard - Video
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device 1274
--
01:00.0 VGA compatible controller: NVIDIA Corporation TU116M [GeForce GTX 1660 Ti Mobile] (rev a1)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device 1274
	Kernel driver in use: nvidia

Logs:
journal
pacman (includes both the upgrade and the subsequent downgrade to revert it)
Xorg log after the upgrade
Xorg log after the downgrade (when X works)

Thanks for looking!

Last edited by llesudb (2022-01-03 03:04:08)

Offline

#2 2021-12-05 11:11:00

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 15,039

Re: [SOLVED] Upgrade breaks X

Post your /etc/X11/xorg.conf and if it was generated "just because" remove it and retry with an updated system again.

Side note, you are looking at the ARM drivers which are not what you want, but also irrelevant as long as you stick to the repos.

Offline

#3 2021-12-05 19:44:00

llesudb
Member
Registered: 2019-08-11
Posts: 19

Re: [SOLVED] Upgrade breaks X

Here is my xorg.conf. I'm not sure what you mean by "generated just because", but a couple of sections are customized to enable modesetting and force the full composition pipeline to prevent screen tearing.

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 430.14


Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Module"
    Load           "modesetting"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Ancor Communications Inc ASUS PA238QR"
    HorizSync       24.0 - 83.0
    VertRefresh     50.0 - 75.0
EndSection

#Section "Monitor"
#    # Laptop screen
#    Identifier   "eDP-1-1"
#    DisplaySize  650 365 # mm
#EndSection

#Section "Monitor"
#    # External ThinkVision monitor
#    Identifier   "DP-1-2"
#    DisplaySize  1516 487 # mm
#EndSection

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1660 Ti"
    Option         "AllowEmptyInitialConfiguration"
    BusID          "1:0:0"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1660 Ti"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "nvidia"
    Monitor        "Monitor0"
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +1920+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "nvidia-auto-select +1920+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection

    # See https://wiki.archlinux.org/index.php/xorg#Display_size_and_DPI
    #Option         "UseEdidDpi" "FALSE"
    #Option         "DPI" "96 x 96"
EndSection

Offline

#4 2021-12-05 20:39:33

loqs
Member
Registered: 2014-03-06
Posts: 14,439

Re: [SOLVED] Upgrade breaks X

What if you add the BusID to the used device section

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1660 Ti"
    BusID          "1:0:0"
EndSection

I would also suggest you comment out or remove unused and ignored sections

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1660 Ti"
    Option         "AllowEmptyInitialConfiguration"
    BusID          "1:0:0"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "nvidia"
    Monitor        "Monitor0"
EndSection

Offline

#5 2021-12-05 20:39:34

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 15,039

Re: [SOLVED] Upgrade breaks X

If "working mode" log is any indication your nvidia card is not actually attached to any screen and this configuration irrelevant for the intended purpose. As such I suggest you remove it entirely, and rather see https://wiki.archlinux.org/title/PRIME# … er_offload for the more modern way of making use of the nvidia gpu on demand while leaving general detection to xorgs auto detection instead of making static configurations. If you really want the nvidia card to be the driving force all the time you might want to look at: https://wiki.archlinux.org/title/NVIDIA … phics_only instead. I doubt the composition pipeline can be usefully used on such a situation, since the "displaying" portion has to be handled by the intel card/the modesetting driver anyway which doesn't take these arguments in the first place. And the working log does contain

     4.558] (WW) NVIDIA(0): No valid modes for
[     4.558] (WW) NVIDIA(0):     "nvidia-auto-select+1920+0{ForceCompositionPipeline=On,ForceFullCompositionPipeline=On}";
[     4.558] (WW) NVIDIA(0):     removing.
[     4.558] (WW) NVIDIA(0): 

so this is not actually applied, but this does make sense in my understanding of how the interaction between the intel card and nvidia works.

Last edited by V1del (2021-12-05 20:46:25)

Offline

#6 2021-12-05 20:46:15

seth
Member
Registered: 2012-09-03
Posts: 26,447

Re: [SOLVED] Upgrade breaks X

"to enable modesetting" is not a thing and "force the full composition pipeline" can and should be achieved by a confilet like
/etc/X11/xorg.conf.d/20-nvidia.conf

Section "Device"
    Identifier ""GeForce GTX 1660 Ti"
    Driver	"nvidia"
    Option	"TripleBuffer"			"True" # you probably want that too
    Option "ForceFullCompositionPipeline" "True"
EndSection

However, in your case that's complete nonsense because the working xorg log shows that the output is connected to the intel chip.
If you want to keep running on the nvidia chip, see https://wiki.archlinux.org/title/NVIDIA … phics_only

In any event, remove the existing config file and don't use nvidia-settings to generate one - it cannot reasonably deal w/ optimus systems and otherwise mostly only produces dated cruft.

Edit: shit.

Last edited by seth (2021-12-05 20:46:37)

Offline

#7 2022-01-03 03:03:28

llesudb
Member
Registered: 2019-08-11
Posts: 19

Re: [SOLVED] Upgrade breaks X

Thank you for your replies. Simply removing my /etc/X11/xorg.conf file and allowing xorg to do its auto-detection work solved the problem.

Offline

Board footer

Powered by FluxBB