You are not logged in.

#1 2021-12-13 02:28:50

tendouser
Member
Registered: 2021-08-30
Posts: 35

mode DORMANT

alguien sabe porque wlp3s0 sigue teniendo 'mode DORMANT' despues de usar i'p link set'?

no tengo problemas con mi wifi pero sigue mostrando lo mismo cada vez que inicio el sistema

saludos

Offline

#2 2021-12-13 05:26:47

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,796
Website

Re: mode DORMANT

Que utilizas para configurar tu red? (netctl, NetworkManager,  otra cosa?)
Quando dices "después de usar ip link set", que has hecho exactamente ? No tenia nunca "mode DORMANT" antes ?

Es una opción de alimentación, pues quizás cambió con una actualización del firmware? Apareció después de una actualización del sistema? Qué tarjeta de red tienes?


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

#3 2021-12-13 14:01:19

tendouser
Member
Registered: 2021-08-30
Posts: 35

Re: mode DORMANT

Que utilizas para configurar tu red? (netctl, NetworkManager,  otra cosa?)

NM

~]$ systemctl status NetworkManager
● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
             └─NetworkManager-ovs.conf
     Active: active (running) since Mon 2021-12-13 08:29:30 EST; 6min ago
       Docs: man:NetworkManager(8)
   Main PID: 339 (NetworkManager)
      Tasks: 3 (limit: 4571)
     Memory: 17.4M
        CPU: 2.150s
     CGroup: /system.slice/NetworkManager.service
             └─339 /usr/bin/NetworkManager --no-daemon

Dec 13 08:29:36 x540sa NetworkManager[339]: <info>  [1639402176.8997] device (wlp3s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
Dec 13 08:29:36 x540sa NetworkManager[339]: <info>  [1639402176.9467] device (wlp3s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
Dec 13 08:29:36 x540sa NetworkManager[339]: <info>  [1639402176.9472] device (wlp3s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
Dec 13 08:29:36 x540sa NetworkManager[339]: <info>  [1639402176.9482] manager: NetworkManager state is now CONNECTED_LOCAL
Dec 13 08:29:36 x540sa NetworkManager[339]: <info>  [1639402176.9495] manager: NetworkManager state is now CONNECTED_SITE
Dec 13 08:29:36 x540sa NetworkManager[339]: <info>  [1639402176.9497] policy: set 'CWC-0006101' (wlp3s0) as default for IPv4 routing and DNS
Dec 13 08:29:37 x540sa NetworkManager[339]: <info>  [1639402177.0649] device (wlp3s0): Activation: successful, device activated.
Dec 13 08:29:37 x540sa NetworkManager[339]: <warn>  [1639402177.0666] dns-sd-resolved[31b551f09d15083e]: send-updates SetLinkDomains@3 failed: GDBus.Error:org.freedesktop.resolve1.LinkBusy:>
Dec 13 08:29:37 x540sa NetworkManager[339]: <info>  [1639402177.6810] manager: NetworkManager state is now CONNECTED_GLOBAL
Dec 13 08:29:37 x540sa NetworkManager[339]: <info>  [1639402177.7912] manager: startup complete

~]$ systemctl status systemd-networkd
● systemd-networkd.service - Network Configuration
     Loaded: loaded (/usr/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: enabled)
     Active: active (running) since Mon 2021-12-13 08:29:22 EST; 7min ago
TriggeredBy: ● systemd-networkd.socket
       Docs: man:systemd-networkd.service(8)
   Main PID: 227 (systemd-network)
     Status: "Processing requests..."
      Tasks: 1 (limit: 4571)
     Memory: 3.0M
        CPU: 789ms
     CGroup: /system.slice/systemd-networkd.service
             └─227 /usr/lib/systemd/systemd-networkd

Dec 13 08:29:24 x540sa systemd-networkd[227]: wlan0: Interface name change detected, renamed to wlp3s0.
Dec 13 08:29:25 x540sa systemd-networkd[227]: wlp3s0: Link UP
Dec 13 08:29:32 x540sa systemd-networkd[227]: wlp3s0: Link DOWN
Dec 13 08:29:32 x540sa systemd-networkd[227]: wlp3s0: Link UP
Dec 13 08:29:34 x540sa systemd-networkd[227]: wlp3s0: Link DOWN
Dec 13 08:29:35 x540sa systemd-networkd[227]: wlp3s0: Link UP

~]$ systemctl status systemd-resolved
● systemd-resolved.service - Network Name Resolution
     Loaded: loaded (/usr/lib/systemd/system/systemd-resolved.service; enabled; vendor preset: enabled)
     Active: active (running) since Mon 2021-12-13 08:29:29 EST; 7min ago
       Docs: man:systemd-resolved.service(8)
             man:org.freedesktop.resolve1(5)
             https://www.freedesktop.org/wiki/Software/systemd/writing-network-configuration-managers
             https://www.freedesktop.org/wiki/Software/systemd/writing-resolver-clients
   Main PID: 336 (systemd-resolve)
     Status: "Processing requests..."
      Tasks: 1 (limit: 4571)
     Memory: 5.6M
        CPU: 465ms
     CGroup: /system.slice/systemd-resolved.service
             └─336 /usr/lib/systemd/systemd-resolved

Dec 13 08:29:28 x540sa systemd[1]: Starting Network Name Resolution...
Dec 13 08:29:28 x540sa systemd-resolved[336]: Positive Trust Anchors:
Dec 13 08:29:28 x540sa systemd-resolved[336]: . IN DS 20326 8 2 e06d44b80b8f1d39a95c0b0d7c65d08458e880409bbc683457104237c7f8ec8d
Dec 13 08:29:28 x540sa systemd-resolved[336]: Negative trust anchors: home.arpa 10.in-addr.arpa 16.172.in-addr.arpa 17.172.in-addr.arpa 18.172.in-addr.arpa 19.172.in-addr.arpa 20.172.in-add>
Dec 13 08:29:29 x540sa systemd-resolved[336]: Using system hostname 'x540sa'.
Dec 13 08:29:29 x540sa systemd[1]: Started Network Name Resolution.
Dec 13 08:29:31 x540sa systemd-resolved[336]: Switching to fallback DNS server 1.1.1.1#cloudflare-dns.com.
Dec 13 08:30:53 x540sa systemd-resolved[336]: Failed to send address reply: Transport endpoint is not connected
Dec 13 08:32:59 x540sa systemd-resolved[336]: Clock change detected. Flushing caches.

Cuando dices "después de usar ip link set", que has hecho exactamente ? No tenia nunca "mode DORMANT" antes ?

siempre estaba en DEFAULT..... si es que el motivo fue una actualización, no estoy seguro o no puedo precisar cuando ocurrió

~]$ ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
    link/ether 9c:5c:8e:d5:5a:98 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
    link/ether c8:ff:28:af:38:cd brd ff:ff:ff:ff:ff:ff

utilizo 'sudo ip link set' ahora porque requiere permisos.... antes no me pedia usar 'sudo'.... recién ayer lo utilicé sin sudo y actualicé el sistema completo con pacman.... cuando reinicio el sistema regresa a 'DORMANT'

Es una opción de alimentación, pues quizás cambió con una actualización del firmware? Apareció después de una actualización del sistema? Qué tarjeta de red tienes?

~]$ lspci
00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register (rev 21)
00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller (rev 21)
00:0b.0 Signal processing controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller (rev 21)
00:13.0 SATA controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SATA Controller (rev 21)
00:14.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller (rev 21)
00:1a.0 Encryption controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine (rev 21)
00:1b.0 Audio device: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller (rev 21)
00:1c.0 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #1 (rev 21)
00:1c.2 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #3 (rev 21)
00:1c.3 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #4 (rev 21)
00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU (rev 21)
00:1f.3 SMBus: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx SMBus Controller (rev 21)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

la verdad solo configuré NetworkManager y modprobe con algunos archivos  '.network' y '.conf' siguiendo la wiki y bbs de arch

Offline

#4 2021-12-13 21:14:55

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,796
Website

Re: mode DORMANT

Bueno, no se lo que ha cambiado pero si tu wifi funciona todavía sin poner la tarjeta en modo DEFAULT entonces no es importante. No me había dado cuenta antes pero la mía es en modo DORMANT también sin problema.

Si es realmente necesario ponerla en modo DEFAULT, supongo que podrías configurar NM ou systemd-networkd à cambiar el modo directamente o ejecutar un comando à cada vez que inicia el red. No estoy seguro pues habrías à consultar la documentación.. Si no es possible, podrías crear un "unit" et un "timer" systemd para ejecutar "ip link set..." à cada vez que reinicias el sistema y, si necesario, à intervalos regulares después, por ejemplo.


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

#5 2021-12-14 17:33:30

tendouser
Member
Registered: 2021-08-30
Posts: 35

Re: mode DORMANT

gracias por la respuesta....

solo tengo la intriga, pues el wifi sigue funcionando sin problemas!


saludos

Offline

Board footer

Powered by FluxBB