You are not logged in.

#1 2021-12-22 18:06:34

Registered: 2021-12-20
Posts: 1

Dell XPS 15 9575 2-in-1 (i915 [drm] *ERROR* CPU pipe A FIFO underrun)

This is my experience of installing Arch Linux on Dell XPS 15 9575.

The Good News: believe it or not, but everything works out of the box. At least, everything that is important: audio, video, 4K graphics, even the touchpad. I haven't tried the camera yet.
The Bad News: you have to downgrade the kernel to 5.13.13. Everything 5.14.1+ does not work: after a few brief kernel messages, the screen begins to flicker, some strange lines are drawn across it, but eventually it all just goes dark. The system at that point is unusable. There is no login prompt, nothing.

Investigating the issue, it turns out that starting with 5.14.1, the the only way I could get to login was to turn the Intel driver modesetting off by adding the following to the kernel command line:


Otherwise, the following well-known error can be seen in the kernel log:

i915 [drm] *ERROR* CPU pipe A FIFO underrun

First I thought, OK, I'll just turn the Intel card off, the AMD card will kick in and everything's going to be tip-top. Turns out, not so fast. I don't know how to properly describe it, but both cards need each other. I think, one of them is offloading work onto the other or something like that. I'm not a Linux guru, I don't understand such complicated things, but I can observe, record and attempt to patternize the behavior. So, if the Intel card is somehow disabled -- and i915.modeset=0 essentially disables the card -- then during startx, the AMD card starts puking things like

AMDGPU(0}: No modes found

OK, maybe I didn't get the message 100% correct, but it complained about not having modes. I haven't tried specifying a mode via an xorg.conf file, but I don't feel that I have to. My desktop box that just got migrated from Gentoo did not need any additional configuration -- Arch just worked out of the box. In fact, Arch recognized my Gentoo XFCE4 settings like a motherscratching NINJA and it was glorious, and I beheld it, and now I'm in love with Arch.


#2 2021-12-26 02:29:01

Registered: 2021-12-26
Posts: 1

Re: Dell XPS 15 9575 2-in-1 (i915 [drm] *ERROR* CPU pipe A FIFO underrun)

I also have the same problem as you with black flickering screen. There are several people that encountered it: and adding `i915.fastboot=0` fixes the problem. I wish someone could submit a bug report to i915 maintainers.

Another problem I encountered is that both cards are fully active (while laptop is connected to a charger):

(AMD Polaris 22 XL)
cat /sys/bus/pci/devices/0000:01:00.0/power_state

(Intel HD Graphics 630)
cat /sys/bus/pci/devices/0000:00:02.0/power_state


#3 2022-01-02 21:44:46

From: Texas, United States
Registered: 2015-04-01
Posts: 74

Re: Dell XPS 15 9575 2-in-1 (i915 [drm] *ERROR* CPU pipe A FIFO underrun)

My experience has been vastly different in that everything has worked...

Camera should work btw smile I wrote a large chunk of the ArchWiki article about the laptop and am typing this from said laptop.

think, one of them is offloading work onto the other or something like that.

You can use DRI_PRIME environment variable to offload.

DRI_PRIME=1 glxgears # will run on AMD chip
DRI_PRIME=0 glxgears # will run on Intel (it's zero by default)

I don't have any of the issues that others have mentioned on either X/Wayland (using Wayfire but used to use Sway (Wayland) and Awesome (X11) in the past). I don't use the AMD card much so it tends to stay powered down unless I really need the power else I just use the integrated graphics.





My module settings for i915/intel are the following. Mainly for power-saving stuff.


options i915 enable_guc=-1
options i915 disable_power_well=0
options i915 fastboot=1

I'm curious about what your boot process looks like to get a better idea. Currently, I boot through REFInd -> greetd (Wayland GUI Greeter)

Just trying to figure things out in this world


Board footer

Powered by FluxBB