You are not logged in.

#1 2021-12-30 21:15:33

surpriselizard
Member
Registered: 2021-12-30
Posts: 1

System freezes after suspend

Hello I recently installed arch on my laptop and whenever I close the lid or use the command 'systemctl suspend', after I wake up the computer again, the screen freezes, I can't move the mouse, and nothing responds to keyboard input (as far as I know).

Here is the 'journalctl -b-1' output:
https://pastebin.com/FtMt3a4u

Whenever I suspend the computer when I have X started, I can't do anything except restart with the power button. If I suspend and wake back up in tty before starting X, then I can't type anything but I can switch between ttys. Though each other tty than the tty I had open while suspending, is just a single solid underscore in the top left of the screen.

It happens consistently everytime I try and suspend the computer and it happened before I installed TLP. I tried removing my network driver module via 'modprobe -r mt7921e' and then tried suspending but that didn't fix the problem.

Any help is greatly appreciated. Thanks in advance.

edit1: I am using an Asus Vivobook 15 Model K513E

Last edited by surpriselizard (2021-12-30 21:16:43)

Offline

#2 2022-01-03 18:06:49

anarki@buttereblume
Member
Registered: 2015-12-29
Posts: 26

Re: System freezes after suspend

Your device seems to have an integrated Intel GPU and a dedicated nVidia GPU. Try disabling the latter by blacklisting its modules.

Offline

Board footer

Powered by FluxBB