You are not logged in.

#1 2022-01-10 10:43:10

flyinghelix
Member
Registered: 2022-01-10
Posts: 6

[SOLVED] gnome-keyring no keychain for Login, DBus-issue, sway, ly

Hello,

I have some problems with the gnome-keyring, specifically the secret-service portion. I am not sure if i can recollect what i already tried, as i went through the whole sway, ly, vscode and gnome-keyring forum posts, github pages etc...
I am using VSCode with settings sync, that is why i need the gnome-keyring.
My Setup uses Sway, no X11 but xWayland, ly as the display manager, gnome-keyring, i3status-rust as swaybar, ulauncher and visual-studio-code-bin, systemd services, arch installation as in the Wiki Install guide, but with snapper, grub and btrfs setup.
I set up gnome-keyring as mentioned in the ArchWiki, with the PAM step and in my sway.config i have

 include /etc/sway/config.d/*
exec /usr/bin/dunst
exec /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1
exec gnome-keyring-daemon --start
exec export SSH_AUTH_SOCK

i also tried it with exec eval $(gnome-keyring-daemon --start).
I tried it with both dbus and dbus-broker, tried the sway-systemd.

i also tried it with dbus-run-session sway and dbus-launch sway, with the exit-session command.
If i do not run it with dbus-run-session i get the error Error in block 'notify' Failed to establish D-Bus connection in my i3status-rust, ulauncher does not start, vscode throws an error Writing login information to the keychain failed with error 'Unknown or unsupported transport “disabled” for address “disabled:”'. With it vscode still throws No such interface "org.freedesktop.Secret.Collection" on object at path /org/freedesktop/secrets/collection/login.
I also tried this thread.
I was able to start sway with ulauncher and i3status-rust some days ago even without the dbus-run-session sway, but appearently i messed something up along the troubleshooting way regarding that, so this thread does not work for me either, but it didnt work without the dbus-run-session back then either.

my /etc/environment , if that helps, is

QT_QPA_PLATFORM=wayland
QT_QPA_PLATFORMTHEME=qt5ct
MOZ_ENABLE_WAYLAND=1
MOZ_WEBRENDER=1
XDG_SESSION_TYPE=wayland
XDG_SESSION_DESKTOP=sway
XDG_CURRENT_DESKTOP=sway
CLUTTER_BACKEND=wayland
SDL_VIDEODRIVER=wayland

testing the secret server with secret-tool provides the error secret-tool: Error calling StartServiceByName for org.freedesktop.secrets: Timeout was reached

I tried nearly everything i found on reddit, the forum and such, but i just can not get it to work..

I am relatively new to Arch, so apologies in advance if I make some mistakes regarding posting.

Last edited by flyinghelix (2022-01-10 11:26:26)

Offline

#2 2022-01-10 11:25:08

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 18,187

Re: [SOLVED] gnome-keyring no keychain for Login, DBus-issue, sway, ly

Stop using ly it's buggy. From a plain terminal logging in and running sway, do you get the same issue?

Offline

#3 2022-01-10 11:30:11

flyinghelix
Member
Registered: 2022-01-10
Posts: 6

Re: [SOLVED] gnome-keyring no keychain for Login, DBus-issue, sway, ly

i just installed dbus-broker again, removed sway-systemd, removed the dbus-run-session from the sway.session file, used exec eval $(gnome-keyring-daemon --start) and it works now. I do not know exactly why it now works, as i am pretty sure i had this combination already
ly works great for me. I do not want to use gdm because of all the dependencies, and a greeter login seems to involved for me. Other login managers have problems with wayland.

Offline

Board footer

Powered by FluxBB