You are not logged in.

#1 2022-01-11 14:49:28

Kritiqual
Member
Registered: 2021-09-10
Posts: 12

Cannot set keyboard rate in xorg.conf

I want to set this command

xset r rate 175 60

in xorg.conf, but when I write this:

Section "InputClass"
	Identifier "keyboard"
	Driver "kbd"
	Option "XkbOptions" "caps:escape_shifted_capslock"
	Option "AutoRepeat" "175 60"
EndSection

only the first number is accpeted, checked via this

xset q:
auto repeat delay:  175    repeat rate:  16

Did I do something wrong?

Offline

#2 2022-01-11 14:56:03

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,217

Re: Cannot set keyboard rate in xorg.conf

Which desktop environment (or window manager) are you using? The configuration file might be over-ridden by the desktop.

If you're just using a window manager then check the X.Org log to see if it's actually reading the configuration file.

Where have you put it anyway? A list of valid locations is given in xorg.conf(5).

EDIT: perhaps try separating the two options, like this:

   Option "AutoRepeat" "175" "60"

I don't have X installed so I can't test, sorry.

Last edited by Head_on_a_Stick (2022-01-11 15:01:03)

Offline

#3 2022-01-11 15:01:43

Kritiqual
Member
Registered: 2021-09-10
Posts: 12

Re: Cannot set keyboard rate in xorg.conf

I'm using awesomewm, and I have this file in /etc/X11/xorg.conf, also in the log, I found this

[    10.082] (II) LoadModule: "kbd"
[    10.082] (WW) Warning, couldn't open module kbd
[    10.082] (EE) Failed to load module "kbd" (module does not exist, 0)
[    10.082] (EE) No input driver matching `kbd'
[    10.082] (II) Falling back to input driver `libinput'

Offline

#4 2022-01-11 15:08:17

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,217

Re: Cannot set keyboard rate in xorg.conf

So does it work if you copy the keyboard stanza from /usr/share/X11/xorg.conf.d/40-libinput.conf to /etc/X11/xorg.conf and add your options there?

EDIT: I wish I could type...

Last edited by Head_on_a_Stick (2022-01-11 15:12:18)

Offline

#5 2022-01-11 15:16:35

seth
Member
Registered: 2012-09-03
Posts: 26,521

Re: Cannot set keyboard rate in xorg.conf

The kbd driver is dead since ages and so was the autorepeat option until very recently, https://www.phoronix.com/scan.php?page= … AutoRepeat
The linked https://cgit.freedesktop.org/xorg/xserv … 907ffee66b has a config pattern

Offline

#6 2022-01-11 15:18:59

Kritiqual
Member
Registered: 2021-09-10
Posts: 12

Re: Cannot set keyboard rate in xorg.conf

So, after a bit of testing, I found that set it in the xorg.conf file will only allow the second number less than 31. So, I have to use my wm autostart function

Offline

#7 2022-01-11 15:21:40

seth
Member
Registered: 2012-09-03
Posts: 26,521

Re: Cannot set keyboard rate in xorg.conf

I don't think so. Your syntax is off and the section and driver are wrong. It's more likely that your desktop session sets the value.

Please see the links I posted and then share your present xorg.conf

Offline

#8 2022-01-12 08:59:53

Kritiqual
Member
Registered: 2021-09-10
Posts: 12

Re: Cannot set keyboard rate in xorg.conf

This is my xorg.conf, but still, if I set any number in the second position higher than 31, it will change to the decreased the value

Section "InputClass"
	Identifier "keyboard"
	MatchIsKeyboard "on"
	Option "XkbOptions" "caps:escape_shifted_capslock"
	Option "AutoRepeat" "175 60"
EndSection

Offline

#9 2022-01-12 12:19:40

seth
Member
Registered: 2012-09-03
Posts: 26,521

Re: Cannot set keyboard rate in xorg.conf

Can you please post the xorg log for that configlet?

Offline

Board footer

Powered by FluxBB