You are not logged in.

#1 2022-01-12 00:47:02

AFatNut21
Member
Registered: 2021-09-06
Posts: 25

Gnome display flickering at random intervals[Solved]

I can't figure out why gdm keeps flickering at random intervals. My system works just fine with lightdm. I followed this post right here:
https://bbs.archlinux.org/viewtopic.php?id=256896


I added this to it:
    [Service]
    Type=idle
    ExecStartPre=/bin/sleep 1



Which I was able to log in... However, it is still missed up for some reason:

Here is the logs http://ix.io/3LW2



I have my modules already inside the mkinitcpio.conf. I have amdgpu radeon i915. I added i915 for my iGPU. Basically the cpu graphics.
My modules are the same when I had lightdm. Which again, everything worked fine for some reason.
I did jump around from kde to xfce4. I still have xfce4 installed and will uninstall it AFTER I am done configuring sway. I did try to play with i3 and it is not needed as sway is superior. The end game is I want Wayland and just sway with the xfce4-panels.

These are the current packages I have installed:
http://ix.io/3LWe

I don't know if I have any packages left over from kde? Never installed kde before and tried it out to which I hated it.
I don't know what is going on. Any leads would be appreciated.

Last edited by AFatNut21 (2022-01-16 01:33:16)

Offline

#2 2022-01-12 07:33:28

seth
Member
Registered: 2012-09-03
Posts: 30,822

Re: Gnome display flickering at random intervals[Solved]

Here is the logs

Please post "sudo loginctl -b", the GDM filter doesn't help at all.
If you're running on the intel chip see https://wiki.archlinux.org/title/Intel_ … flickering

Edit: since you've the module in the initramfs, you'll have to use a kernel commandline parameter or rebuild the initramfs if you add a modprobe configlet

Last edited by seth (2022-01-12 07:34:18)

Offline

#3 2022-01-12 21:13:43

AFatNut21
Member
Registered: 2021-09-06
Posts: 25

Re: Gnome display flickering at random intervals[Solved]

loginctl -b is invalid. But I do notice that whenever pass my passhphrase through luks I have different sessions for some reason, and a different tty
Instead of it being tty1 it is tty2.

Do I need to set loginctl up? I ran systemctl enable systemd.logind and it is not up

Offline

#4 2022-01-12 21:17:19

seth
Member
Registered: 2012-09-03
Posts: 30,822

Re: Gnome display flickering at random intervals[Solved]

Sorry, I brainfarted.

sudo journalctl -b | curl -F 'f:1=<-' ix.io

Offline

#5 2022-01-12 23:30:00

AFatNut21
Member
Registered: 2021-09-06
Posts: 25

Re: Gnome display flickering at random intervals[Solved]

Here it is: http://ix.io/3M1I

Some stuff with openssh. I can get rid of that crap that's in there and see if that makes a different. If it doesn't at least it clears the error

Offline

#6 2022-01-13 07:50:58

seth
Member
Registered: 2012-09-03
Posts: 30,822

Re: Gnome display flickering at random intervals[Solved]

That's not the complete system journal (and esp. there're no kernel messages in there) but doesn't look like a session journal either - do you filter or limit the journal?

Offline

#7 2022-01-13 14:03:56

AFatNut21
Member
Registered: 2021-09-06
Posts: 25

Re: Gnome display flickering at random intervals[Solved]

Strange.... I thought I ran exactly what you asked...

Here is the data you wanted:
http://ix.io/3M4j

Here is the Xorg logs just in case:
http://ix.io/3M4k

Here's what the system service file looks like:
http://ix.io/3M4l

I only added the lines I said at the top. I didn't really mess with as it wasn't broken. gdm-plymouth is not good and shouldn't be used as their are users reports stating just stick with gdm.service.
It came like that when I ran pacman -S gdm
Also, correct me if I am wrong but I feel like -906 is a port and whatever it is, is executing very quickly and leaving the function.. This makes sense to me as in order to get lightdm to work I have to uncomment login-graphical=false and initialize it with true.
It would explain why I keep getting different ttys. Again, this is a guess.
I also did some more digging around and I am using a custom EDID binary. And I found it helpful to have it built into the init as well as adding it to the kernel parameter; it gets rid of that look if someone punched the monitor. I did not know that I was suppose to say that I am using a custom EDID.
Both Type=Idle and sleep 1 makes the session stable after it flickers a couple times, AFTER I log in. That's if I am lucky..  I am even more confidient that I either missed some configuration that I am not aware of? OR I have some other configs that I am not aware of that is causing this nightmare.
I did also run this:
systemctl set-default graphical.target
By doing this, it allowed me to boot SDDM when I had kde. Like I said before, I did install i3,kde,xfce4, and sway. I removed i3 and kde, but I don't know if there is any left over configs or packages from these environments. It is why I posted my packages.
It could also be another reason why it is doing this to me...

Here is my grub config:
http://ix.io/3M4p
I removed some of the stuff as I can't remember where I got it exactly so to say. I know for a fact my bios supports ASPM or whatever it is called, and even when all those variables were inside my parameter, it still didn't cause any kind of problem. I am talking about when I was using lightdm. I am going to heavily talk about lightdm fyi.

Here is my mkinitcpio.conf:
http://ix.io/3M4r
Everything in there had no issues what so ever when running lightdm, and I am wanting to use my GPU and IGPU if possible.

I hope this information I provide is even more useful as again, this was a broad/tough discussion to begin anyways

Last edited by AFatNut21 (2022-01-13 14:06:56)

Offline

#8 2022-01-13 16:41:58

seth
Member
Registered: 2012-09-03
Posts: 30,822

Re: Gnome display flickering at random intervals[Solved]

http://ix.io/3M4j wrote:

Jan 13 13:38:02 ArchLinux kernel: Linux version 5.15.13 (root@archiso) (gcc (GCC) 11.1.0, GNU ld (GNU Binutils) 2.36.1) #1 SMP PREEMPT Wed Jan 5 19:28:17 PST 2022

???

Jan 13 13:38:12 ArchLinux gnome-shell[954]: Added device '/dev/dri/card0' (amdgpu) using atomic mode setting.
Jan 13 13:38:12 ArchLinux gnome-shell[954]: Added device '/dev/dri/card1' (amdgpu) using atomic mode setting.

You've two AMD chips, no intel one (so no use for i915)

Jan 13 13:38:13 ArchLinux /usr/lib/gdm-x-session[968]: (--) PCI:*(1@0:0:0) 1002:67df:1462:341b rev 239, Mem @ 0xe0000000/268435456, 0xf0000000/2097152, 0xf7e00000/262144, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072

X11 runs on that one
=> What's the output of "lspci"?

Jan 13 13:38:13 ArchLinux /usr/lib/gdm-x-session[968]: (II) LoadModule: "ati"
Jan 13 13:38:13 ArchLinux /usr/lib/gdm-x-session[968]: (II) LoadModule: "radeon"

Get rid of xf86-video-ati, those interfere w/ the modesetting driver. If anything you want xf86-video-amdgpu

Here's a problem…

Jan 13 13:38:16 ArchLinux kernel: amdgpu 0000:03:00.0: cannot be used for peer-to-peer DMA as the client and provider (0000:01:00.0) do not share an upstream bridge or whitelisted host bridge

How many outputs (monitors) do you actually have, what GPU are they attached to and why's there a custom edid?
What if you omit that edid and rely on the autodetection? (Xorg log?)
Can you configure (eg. in the BIOS) which GPU you use (if this is a notebook)

I am wanting to use my GPU and IGPU if possible.

xrandr --listproviders

Offline

#9 2022-01-13 17:36:25

AFatNut21
Member
Registered: 2021-09-06
Posts: 25

Re: Gnome display flickering at random intervals[Solved]

I'll remove i915. I thought adding the i915 and packages is how you would get IGPU. I have one monitor and this right here:
https://www.amazon.com/Zuya-Splitter-Ad … B08R9P5QP1
It is a external plugin. And I have both my cards hooked up to it.

I am planning to use openbox to combine both of the outputs. Some crap like that. I have two of them because I want SLI/Vulkan. HOWEVER, that is long dead... But I have been digging nonstop and I might of found a way to create something similar using SDK/Vulkan. I can edit the layers instances by exporting variables described here: https://vulkan.lunarg.com/doc/view/late … arted.html
https://github.com/KhronosGroup/Vulkan- … ile-format
So whenever I log in, my edited layers will be used. Crossfire is now known as mGPU,(Multi-GPU) btw. I was saving this info for another post I made about this in the hopes of finding something.

I have a custom EDID because if I don't, the EDID is null or something like that. I tried the default layout in archlinux article, I can't remember where, but there is a part where it talks about creating your own EDIDs. The layout didn't work and when I tried the custom EDID which is1920x1080, it works perfectly with no issues.

I don't have any other way to upgrade as right now; it is attempting to do that. But I want to at least try to combine those two graphics cards for the sake of learning new things.
I'll clean up all that crap, and I will get back to you as soon as possible.

Last edited by AFatNut21 (2022-01-13 21:29:57)

Offline

#10 2022-01-13 21:52:02

seth
Member
Registered: 2012-09-03
Posts: 30,822

Re: Gnome display flickering at random intervals[Solved]

Hinweis: Es kann nicht 2 Displays unterstützen, die gleichzeitig aktiv sind, bitte schließen Sie ein Display, wenn Sie ein anderes verwenden möchten.

The german description explicitly states that you can't use both outputs at the same time, let alone have them show different outputs.
Is that thing currently attached?

Offline

#11 2022-01-14 17:47:48

AFatNut21
Member
Registered: 2021-09-06
Posts: 25

Re: Gnome display flickering at random intervals[Solved]

Ah, I don't speak German. I wouldn't know this and would kept on fighting with my setup until the day I go bald. I unplugged on of the HDMIs from my graphics card, and I went over the multi-thread archlinux post and developed this configuration:
http://ix.io/3Mb5
The idea of unplugging one of the HDMI cables came from that error you found fyi.

This is my Xorg.0.log output:
http://ix.io/3Mb6

Seems the configuration I made works, if not, I am happy with it as it is doing what I want; loading of gdm without losing signal.
Overall, everything is working perfectly.

Instead of opening more posts to solve other peculiar errors I have now, I am going to describe them below this line:

I can't log into xfce4, and I know why; it doesn't support wayland. I don't care honestly as I am moving over to sway. I did uninstalled openbox, because it has no support for wayland; waybox does but I don't trust it one bit. I have to remove redshift, remove some other stuff as it states in archlinux wiki, I believe I have some packets that will mess with gdm. 

I am having problems with sway as my xfce4-panels are not loading up, and my xterm terminal is not working as well. I am going to install the default sway terminal and see if I can get it to pop up, if not, I really need to find out how to chroot archlinux from kali IF POSSIBLE.

I do have support for iGPU, something with modesetting. I will go into further detail soon after troubleshooting sway. If chrooting from kali is not an option, I will have to log into GNOME environment. I don't want to do that, as it's not working. Such as right clicking on any kind of settings doesn't display anything, it could be something with me not having gnome-settings. I RATHER NOT not install more packages only to remove them after.

So basically what I want now, is to know what I said before if I can chroot from kali to archlinux, to trouble shoot sway. I have it setup, but it is complaining about /etc/mtab. Probably something to do with kali perhaps? IF I CAN'T DO that AND OR you don't know, then my only option is to use GNOME to trouble shoot sway. And I want to use this post, if I can that is.

Offline

#12 2022-01-15 09:53:28

seth
Member
Registered: 2012-09-03
Posts: 30,822

Re: Gnome display flickering at random intervals[Solved]

Instead of opening more posts to solve other peculiar errors I have now, I am going to describe them below this line:

Don't derail the topic of your own thread. It makes it less valuable for future readers interested in either topic.

but it is complaining about /etc/mtab

Also don't paraphrase. What command is "complaining" what error about mtab?

But again: make that a different thread.

Offline

#13 2022-01-16 01:32:56

AFatNut21
Member
Registered: 2021-09-06
Posts: 25

Re: Gnome display flickering at random intervals[Solved]

Okay. Will do. Didn't know, now I know. I'll mark it solved

Offline

Board footer

Powered by FluxBB