You are not logged in.

#1 2022-01-12 13:35:30

ruther
Member
Registered: 2021-02-24
Posts: 6

Wine stopped working

After an update (still trying to catch which one specifically), wine stopped working. All I get using a fresh winepfx is this output:

wine: created the configuration directory '/home/user/.wine'
002c:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
wine: Unhandled page fault on execute access to 0000000061DEC930 at address 0000000061DEC930 (thread 002c), starting debugger...
002c:err:seh:start_debugger Couldn't start debugger L"winedbg --auto 40 124" (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
wine: could not load kernel32.dll, status c0000135
 0048:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
0048:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x80004002
0048:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x80004002
0048:err:ole:apartment_get_local_server_stream Failed: 0x80004002
0048:err:ole:start_rpcss Failed to open RpcSs service

Since it's a bit faster to try, I'm trying the proton-ge builds to find in which version it stops working. For now this error happens between proton-ge build 6.3 and 6.20.
Will update if I can find the exact version where it stops working.

I've seen similar errors on system that have two graphics cards but it's not my case, it happens on both my Lenovo T420 and my desktop with a Ryzen 5 5600 and a Nvidia GTX 960.

Offline

#2 2022-01-12 17:38:43

Maniaxx
Member
From: .de
Registered: 2014-05-14
Posts: 502

Re: Wine stopped working

Looks like the prefix hasn't been properly initiated/updated. Check the output carefully on initialization.

rm -rf ~/.wine
wineboot -i

Last edited by Maniaxx (2022-01-12 17:39:49)


sys2064

Offline

#3 2022-01-13 01:35:23

ruther
Member
Registered: 2021-02-24
Posts: 6

Re: Wine stopped working

I've already tried making a new pfx. And still get the same result, for now I went with Wine-6.16 that seems to be working. But I don't wanna keep stuck with that.

wine: created the configuration directory '/home/user/.wine'
002c:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
wine: Unhandled page fault on execute access to 0000000061AB924D at address 0000000061AB924D (thread 002c), starting debugger...
002c:err:seh:start_debugger Couldn't start debugger L"winedbg --auto 40 92" (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
wine: could not load kernel32.dll, status c0000135
0048:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
0048:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x80004002
0048:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x80004002
0048:err:ole:apartment_get_local_server_stream Failed: 0x80004002
0048:err:ole:start_rpcss Failed to open RpcSs service

Offline

#4 2022-01-13 10:31:47

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,999

Re: Wine stopped working

IIRC the last time I've seen this there was some integration bug with lib32-gstreamer. Can you try removing that if installed?

Offline

#5 2022-01-14 01:46:10

ruther
Member
Registered: 2021-02-24
Posts: 6

Re: Wine stopped working

I've just tried removing it, even tried removing all gstreamer related packages, didn't help sad.
For now I'm using wine 6.4 that seems to work ok, but I don't wanna get stuck on this version forever

Offline

#6 2022-01-14 15:19:01

Kaot1223
Member
Registered: 2022-01-14
Posts: 1

Re: Wine stopped working

My wine stop working recently also and none of the wine versions I had cached worked even though they were all working completely fine before. This leads me to believe that something else updated and broke wine somehow as it was working before, im just not sure what it is.
My output when trying any wine command (in this case winecfg):

 wine: created the configuration directory '/home/user/.wine'
002c:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
002c:fixme:winediag:LdrInitializeThunk wine-staging 7.0-rc5 is a testing version containing experimental patches.
002c:fixme:winediag:LdrInitializeThunk Please mention your exact version when filing bug reports on winehq.org.
wine: Unhandled page fault on execute access to 0000000061E15672 at address 0000000061E15672 (thread 002c), starting debugger...
002c:err:seh:start_debugger Couldn't start debugger L"winedbg --auto 40 128" (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
wine: could not load kernel32.dll, status c0000135
0048:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)                                                                                                                     
0048:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x80004002                                                                                                                               
0048:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x80004002
0048:err:ole:apartment_get_local_server_stream Failed: 0x80004002
006c:err:winedevice:ServiceMain Failed to load L"C:\\windows\\system32\\win32k.sys"
006c:err:winedevice:ServiceMain Failed to load L"C:\\windows\\system32\\drivers\\dxgkrnl.sys"
006c:err:winedevice:ServiceMain Failed to load L"C:\\windows\\system32\\drivers\\dxgmms1.sys" 

Tested on linux-lts 5.15.14-1 and linux 5.16.arch1-1 with wine-7.0-rc5 (Staging).
Works completely fine on wine-6.4-1.

Offline

Board footer

Powered by FluxBB