You are not logged in.

#1 2022-01-14 03:26:32

Registered: 2022-01-14
Posts: 1

Xorg "Device(s) detected, but none match those in the config file"

After I updated my system yesterday, each time I turn on my computer LightDM fails to start, and when I try to start my computer with "startx" it gives me an error.
The error says "(EE) no screens found(EE)" and when I open the error log file it gives me the additional details of "Device(s) detected, but none match those in the config file".

I did check the Arch wiki and try to recreate a new config file, it didn't help.
My config file lists my GPU twice, the second time under what I think is the incorrect BusID, so I tried removing the second entry. I still ended up getting the same error but the full error log was a little different.

In my internet searching, I've only found the same "no screens found" error but with a different cause (not the device(s) detected error message). Or the solution didn't have to do with my issue, like having to do with Nvida drivers. I have an AMD R9 280 graphics card.
The BusID PCI in the config file is correct.

My Arch install is on my SSD, but I have another distro installed on my harddrive in the same computer that I can boot into fine. So I don't believe it could be a hardware issue.
The error log is from me running the zen kernel, but I have the same errors with the normal linux kernel.

If anyone has an idea of what might be causing this, or can point me in the right direction, that would be greatly appreciated.

Error Log:
Config File:

After I removed the second listing of my GPU:
Error Log:
Config File:


#2 2022-01-14 04:05:29

Forum Moderator
Registered: 2012-10-16
Posts: 15,083

Re: Xorg "Device(s) detected, but none match those in the config file"

Not directly related, but not a single thing in that config file is necessary to be configured that way, I'd just remove the thing.

Last edited by V1del (2022-01-14 04:10:21)


Board footer

Powered by FluxBB