You are not logged in.

#1 2022-01-14 04:04:19

Registered: 2008-01-06
Posts: 9

A10-7800/MSI A88xi AC AMDGPU KMS doesn't work initially

Don't have much of an environment yet on this machine, to easily pull logs off.  I'll try to get/attach logs tomorrow, but I'm hoping somebody might recognize this issue.   Supposedly the A10-7800 is at least a GCN 1.2 so it should fully be supported by amdgpu.

'radeon' KMS works fine.  'amdgpu' does not, at least not right away.  When the amdgpu module is loaded and KMS kicks in, the screen goes dead (no signal).  It is a TV (have not tried a 'proper' monitor yet), so that may be some issue, but it appears to pick out the EDID fine.  Whether 'early' or 'late' KMS, when it goes to KMS, that's when it dies.  The only error in 'dmesg' is something about missing _SB.ALIB ACPI functions (which I gather are a much much newer thing and it being missing is expected on this vintage) -- and the same error appears w/'radeon' kms anyway.  Everything else in the logs appears normal (switching the fb over to amdgpu, etc etc).   Only the HDMI output shows as enabled in /sys/class/drm/ so it's picking the right output just fine.  There's no crash or problems otherwise -- blind typing 'root' '<pw>' 'systemctl start sshd' got me in when I thought I was stuck after switching to amdgpu.

Here's the kicker.  X starts fine, and once it's been started, KMS is golden.  Can ctrl-alt-f2 to a console, can _exit_ X and still have a console.  Can hibernate or suspend after that and come back to a working console.  No interesting or odd errors/messages in the X logs.  Just no signal on a _fresh_ boot.   No modules are loaded by X, 'lsmod' reports the same before and after. 

There are some similar errors reported on much newer APUs that apparently started a couple months ago (though also reported fixed in the latest kernels -- and those folks couldn't get X up either), so I may try a rollback to 5.14 or 5.13 to see if it's a regression (this is a brand new install and a 'new' machine to me).   My use case for this particular machine does require a functional console but it's a perfectly fine workaround if X needs to be started once first.  Just don't like stuff not working right.


#2 2022-01-14 07:38:27

Registered: 2012-09-03
Posts: 26,521

Re: A10-7800/MSI A88xi AC AMDGPU KMS doesn't work initially

If you don't start X11 but instead simply re-plug the output after the boot, does it then turn on?
If so, it's probably the HDMI handshake and you might want to test that "proper monitor" ( your words tongue )


Board footer

Powered by FluxBB