You are not logged in.

#1 2022-01-14 17:25:19

idbentley
Member
Registered: 2020-09-02
Posts: 4

[SOLVED] Cannot start GNOME Shell on X11

GNOME shell works well for me under Wayland, but because I need to have reliable screen sharing through Zoom, it's necessary for me to sometimes use XOrg.

In the past months, when I attempt to load GNOME in X11, it fails to start.

In journalctl I find the following:

Jan 14 11:15:31 idb-lenovo systemd[397847]: Started GNOME Session Manager (session: gnome).
Jan 14 11:15:31 idb-lenovo systemd[397847]: Reached target GNOME Session Manager is ready.
Jan 14 11:15:31 idb-lenovo systemd[397847]: Starting GNOME Shell on Wayland...
Jan 14 11:15:31 idb-lenovo systemd[397847]: Starting GNOME Shell on X11...
Jan 14 11:15:31 idb-lenovo systemd[397847]: org.gnome.Shell@x11.service: Skipped due to 'exec-condition'.
Jan 14 11:15:31 idb-lenovo systemd[397847]: Condition check resulted in GNOME Shell on X11 being skipped.
Jan 14 11:15:31 idb-lenovo systemd[397847]: org.gnome.Shell@x11.service: Scheduled restart job, restart counter is at 1.
Jan 14 11:15:31 idb-lenovo systemd[397847]: Stopped GNOME Shell on X11.
Jan 14 11:15:31 idb-lenovo systemd[397847]: Starting GNOME Shell on X11...
Jan 14 11:15:31 idb-lenovo systemd[397847]: org.gnome.Shell@x11.service: Skipped due to 'exec-condition'.
Jan 14 11:15:31 idb-lenovo systemd[397847]: Condition check resulted in GNOME Shell on X11 being skipped.
Jan 14 11:15:31 idb-lenovo systemd[397847]: org.gnome.Shell@x11.service: Scheduled restart job, restart counter is at 2.
Jan 14 11:15:31 idb-lenovo systemd[397847]: Stopped GNOME Shell on X11.
Jan 14 11:15:31 idb-lenovo systemd[397847]: Starting GNOME Shell on X11...
Jan 14 11:15:31 idb-lenovo systemd[397847]: org.gnome.Shell@x11.service: Skipped due to 'exec-condition'.
Jan 14 11:15:31 idb-lenovo systemd[397847]: Condition check resulted in GNOME Shell on X11 being skipped.
Jan 14 11:15:31 idb-lenovo systemd[397847]: org.gnome.Shell@x11.service: Scheduled restart job, restart counter is at 3.
Jan 14 11:15:31 idb-lenovo systemd[397847]: Stopped GNOME Shell on X11.
Jan 14 11:15:31 idb-lenovo systemd[397847]: org.gnome.Shell@x11.service: Start request repeated too quickly.
Jan 14 11:15:31 idb-lenovo systemd[397847]: org.gnome.Shell@x11.service: Skipped due to 'exec-condition'.
Jan 14 11:15:31 idb-lenovo systemd[397847]: Started GNOME Shell on X11.

But I can't determine which condition is causing X11.service to be skipped.

My gdm.rules file looks normal to me:

# cat /usr/lib/udev/rules.d/61-gdm.rules
# disable Wayland on Hi1710 chipsets
ATTR{vendor}=="0x19e5", ATTR{device}=="0x1711", GOTO="gdm_disable_wayland"

# disable Wayland if modesetting is disabled
IMPORT{cmdline}="nomodeset", SUBSYSTEM=="drm", KERNEL=="card[0-9]*", GOTO="gdm_disable_wayland"

# Disable wayland when nvidia modeset is disabled or when drivers are a lower
# version than 470, in any case always prefer Xorg
KERNEL!="nvidia_drm", GOTO="gdm_nvidia_drm_end"
SUBSYSTEM!="module", GOTO="gdm_nvidia_drm_end"
ACTION!="add", GOTO="gdm_nvidia_drm_end"
# disable wayland if nvidia-drm modeset is not enabled
ATTR{parameters/modeset}!="Y", GOTO="gdm_disable_wayland"
# disable wayland for nvidia drivers versions lower than 470
ATTR{version}=="4[0-6][0-9].*|[0-3][0-9][0-9].*|[0-9][0-9].*|[0-9].*", GOTO="gdm_disable_wayland"
GOTO="gdm_prefer_xorg"
LABEL="gdm_nvidia_drm_end"

GOTO="gdm_end"

LABEL="gdm_prefer_xorg"
RUN+="/usr/lib/gdm-runtime-config set daemon PreferredDisplayServer xorg"
GOTO="gdm_end"

LABEL="gdm_disable_wayland"
RUN+="/usr/lib/gdm-runtime-config set daemon WaylandEnable false"
GOTO="gdm_end"

LABEL="gdm_end"

I uncommented the debug Enable line in /etc/gdm/custom.conf, but did not receive any additional output in my journal.

I'm not sure how to debug this issue, so any help is appreciated.

Last edited by idbentley (2022-01-16 20:08:15)

Offline

#2 2022-01-14 20:32:46

seth
Member
Registered: 2012-09-03
Posts: 26,570

Re: [SOLVED] Cannot start GNOME Shell on X11

Please post a complete system journal,

sudo journalctl -b | curl -F 'f:1=<-' ix.io

after attempting to start gnome on X11

Offline

#3 2022-01-15 02:58:47

idbentley
Member
Registered: 2020-09-02
Posts: 4

Re: [SOLVED] Cannot start GNOME Shell on X11

Here is the complete journal: https://paste.c-net.org/BaseballAccident

Offline

#4 2022-01-15 08:34:54

seth
Member
Registered: 2012-09-03
Posts: 26,570

Re: [SOLVED] Cannot start GNOME Shell on X11

So I fished this out of 170422 lines of journal (onehundredseventythousandfourhundredandtwentytwo lines) covering the last ten days …

Jan 14 11:38:22 idb-lenovo /usr/lib/gdm-x-session[408111]:         Using the first device section listed.
Jan 14 11:38:22 idb-lenovo /usr/lib/gdm-x-session[408111]: (**) |   |-->Device "Intel Graphics"
…
Jan 14 11:38:22 idb-lenovo /usr/lib/gdm-x-session[408111]: (EE) Failed to load module "intel" (module does not exist, 0)

Some config is referencing the xf86-video-intel driver which is not installed.

grep -ri intel /{etc,usr/share}/X11/xorg.conf*

Offline

#5 2022-01-16 20:07:40

idbentley
Member
Registered: 2020-09-02
Posts: 4

Re: [SOLVED] Cannot start GNOME Shell on X11

Sorry about the huge log - I guess I took your instruction to post the 'complete system journal' a bit too literally.

Anyways, in /etc/X11/xorg.conf.d/20-intel.conf there was a configuration

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option "TearFree" "true"
EndSection

Which I seemingly got from https://wiki.archlinux.org/title/Intel_graphics#Tearing.

Removing that file has solved my issue

Thanks Seth.

Offline

Board footer

Powered by FluxBB