You are not logged in.

#1 2022-01-20 20:02:32

MORdjking
Member
Registered: 2022-01-20
Posts: 4

downgrade to make-4.2.1

I need to revert to make 4.2.1 (instead of the core repository make 4.3) to compile a series of numerical solvers (dealii-toolchain). However, I'm having a hard time figuring out how to first create make 4.2.1 from the GNU site's make-4.2.1.tar.gz in order to follow the instructions found here: https://wiki.archlinux.org/title/Downgrading_packages.

running makepkg gives the following errors:

gcc  -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -Wl,--export-dynamic -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -o make ar.o arscan.o commands.o default.o dir.o expand.o file.o function.o getopt.o getopt1.o guile.o implicit.o job.o load.o loadapi.o main.o misc.o posixos.o output.o read.o remake.o rule.o signame.o strcache.o variable.o version.o vpath.o hash.o remote-stub.o glob/libglob.a   -ldl 
/usr/bin/ld: glob/libglob.a(glob.o): in function `glob_in_dir':
glob.c:(.text+0x2df): undefined reference to `__alloca'
/usr/bin/ld: glob.c:(.text+0x43b): undefined reference to `__alloca'
/usr/bin/ld: glob.c:(.text+0x609): undefined reference to `__alloca'
/usr/bin/ld: glob.c:(.text+0x667): undefined reference to `__alloca'
/usr/bin/ld: glob.c:(.text+0x76c): undefined reference to `__stat'
/usr/bin/ld: glob/libglob.a(glob.o): in function `glob':
glob.c:(.text+0xaec): undefined reference to `__alloca'
/usr/bin/ld: glob.c:(.text+0xe8a): undefined reference to `__stat'
/usr/bin/ld: glob.c:(.text+0x1271): undefined reference to `__alloca'
/usr/bin/ld: glob.c:(.text+0x1315): undefined reference to `__alloca'
/usr/bin/ld: glob.c:(.text+0x142b): undefined reference to `__stat'
/usr/bin/ld: glob.c:(.text+0x1799): undefined reference to `__stat'
/usr/bin/ld: glob.c:(.text+0x1858): undefined reference to `__alloca'
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:656: make] Error 1
make[2]: Leaving directory '/home/djking/Documents/src/make-4.2.1'
make[1]: *** [Makefile:798: all-recursive] Error 1
make[1]: Leaving directory '/home/djking/Documents/src/make-4.2.1'
make: *** [Makefile:534: all] Error 2
==> ERROR: A failure occurred in build()

I am very new to arch, so any help would be greatly appreciated!

Last edited by MORdjking (2022-01-21 18:59:46)

Offline

#2 2022-01-20 20:24:34

MORdjking
Member
Registered: 2022-01-20
Posts: 4

Re: downgrade to make-4.2.1

I'm running makepkg with --skipinteg

and here is my PKGBUILD code:

pkgname=make
pkgver=4.2.1
pkgrel=3
pkgdesc="GNU make utility to maintain groups of programs"
arch=('x86_64')
url="https://www.gnu.org/software/make"
license=('GPL3')
groups=('base-devel')
depends=('glibc' 'guile')
source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig})

# md5sums=()
# validpgpkeys=()


build() {
        cd "${pkgname}-${pkgver}"
        ./configure --prefix=/usr
        make
}

check() {
        cd "${pkgname}-${pkgver}"
        make -k check
}

package() {
        cd "${pkgname}-${pkgver}"
        make DESTDIR="${pkgdir}" install
}

Last edited by MORdjking (2022-01-21 19:00:22)

Offline

#3 2022-01-20 20:40:18

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 26,696
Website

Re: downgrade to make-4.2.1

Are you sure you need to downgrade make?  I really can't imagine why that would be.  Make's functionality is pretty generic - most projects don't require specific versions - and in fact will often strive to build with various implementation of make (other than GNUs).  Further, even if there was anything specific to GNU make required, was it removed as a backward incompatible change in 4.3?  If so, I'm really curious what that change would be.

As for the actual error, I'm currently able to replicate it at least when building outside of a clean chroot.  I suspect you need a patch that was used for building that version in the repos:
https://github.com/archlinux/svntogit-p … ore-x86_64

Also, would a prebuilt package from the ALA not work?

Side note: please edit your posts to add [ code ] tags around file contents and command output - see the BBCode link under the post textbox to learn more about forum formating.

Last edited by Trilby (2022-01-20 20:43:02)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#4 2022-01-21 19:14:22

MORdjking
Member
Registered: 2022-01-20
Posts: 4

Re: downgrade to make-4.2.1

Thanks for the quick reply and pointing me to ALA! I will try the prebuilt package there and let you know how it goes.

I'm not exactly sure why Trilinos 12.18 won't build with make 4.3, however it seems that others have had this issue as well (https://github.com/GEOSX/thirdPartyLibs/issues/136 , https://bugs.debian.org/cgi-bin/bugrepo … ug=961708). I was successful building version 13 using make 4.3, but later ran into problems with PETSc. Now I'm systematically rolling back packages to find a combo that works for all tools in deallii-toolchain configured using candi (https://github.com/dealii/candi).

Last edited by MORdjking (2022-01-21 19:18:20)

Offline

#5 2022-01-21 21:44:07

loqs
Member
Registered: 2014-03-06
Posts: 14,701

Re: downgrade to make-4.2.1

Did you try https://aur.archlinux.org/packages/trilinos/ and https://aur.archlinux.org/packages/petsc/ ?  Both built for me in a clean chroot which contained the dependent AUR packages.

Offline

#6 2022-02-16 23:01:12

MORdjking
Member
Registered: 2022-01-20
Posts: 4

Re: downgrade to make-4.2.1

loqs wrote:

Did you try https://aur.archlinux.org/packages/trilinos/ and https://aur.archlinux.org/packages/petsc/ ?  Both built for me in a clean chroot which contained the dependent AUR packages.

I was hoping to use the setup and config tool "Candi" to install deal-ii (with dependencies for the software I would like to run), but it seems like your suggestion to build each package individually will be much easier in this case. Thanks both for your help. -Cheers

Last edited by MORdjking (2022-02-16 23:03:39)

Offline

Board footer

Powered by FluxBB