You are not logged in.

#1 2022-01-23 19:23:35

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

gpg error(invalid or corrupted package (pgp signature)

high guys intros first this is my second post on the forums. first one was in regard to a chromebook that i flashed arch onto. so i know i can follow instructions tongue. what the issue is im not sure ive updated the keyring, populated linux and checked the sig. everything shows all good but when i run pacstrap to my my /mnt it goes boom. just wont  write it to memory i was unable to delete the gnupg.d file mentioned in a few explanations it said the resource was busy. im wondering is there any way to kill that process so i can start with a fresh slate. oh and the title is the cliff notes version of the error. for every package i was trying to strap it gives out



error: "package" : signature from "insert different names and address's" are invalid
file /package/to/install.pkg.tar.zst is corrupted (invalid or corrupted package(pgp signature)).

my pc crashed running lubuntu 20.04 after a security update the other day. so i decide to make my way to one of the more rolling release titles. and game support once you start the aur is amazing, and that ladys and germs is why i'm here

Offline

#2 2022-01-23 20:00:06

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,324

Re: gpg error(invalid or corrupted package (pgp signature)

Update the archlinux-keyring package. This is one of the VERY FEW cases where you should use -Sy, in this case, pacman -Sy archlinux-keyring.

In the future, when reporting errors, don't paraphrase, post exact errors.

Last edited by Scimmia (2022-01-23 20:04:06)

Offline

#3 2022-01-23 20:28:25

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

Re: gpg error(invalid or corrupted package (pgp signature)

still no luck. i paraphrased because it happens to every package. just ran pacman -Sy and it gave me new keys but still failed. i was wondering if the crash could have "burned" into memory?

Offline

#4 2022-01-23 20:35:13

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,324

Re: gpg error(invalid or corrupted package (pgp signature)

We'll need exact errors, then.

Offline

#5 2022-01-23 20:48:20

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

Re: gpg error(invalid or corrupted package (pgp signature)

im trying a different hard drive ill get back to you.... still kind of new to troubleshooting im usually really careful about how i set things up.....what method of error checking should i use?

Offline

#6 2022-01-23 21:09:35

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

Re: gpg error(invalid or corrupted package (pgp signature)

error: nss: signature from "Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>" is invalid
:: File ?mnt/var/cache/pacman/pkg/nss-3.74-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

its of course different package signers for each package but it says about the same for each package  try and pacstrap i can update  but it wont pacstrap.....sigh....anyway

error: failed to commit transaction (invalid or corrupted package)
errors occurred, no packages upgraded.
==>ERROR: failed to install packages to new root
pacstrap /mnt base linux linux-firmware vim lvm2 xfce4 xfce4-goodies  man-db 20.70s user 12.47s system 41% cpu 1:19.75 total

Offline

#7 2022-01-23 21:16:43

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,324

Re: gpg error(invalid or corrupted package (pgp signature)

It doesn't say anything before that?

What does `file /mnt/var/cache/pacman/pkg/nss-3.74-1-x86_64.pkg.tar.zst` give you? How about `pacman-key --list-keys heftig`?

Offline

#8 2022-01-23 21:27:15

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

Re: gpg error(invalid or corrupted package (pgp signature)

that's the last legible error. everything before that is a reiteration of the same gpg error. I'm guessing for the the packages listed in pacstrap.

Offline

#9 2022-01-23 21:47:01

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

Re: gpg error(invalid or corrupted package (pgp signature)

pacman-key --list-keys heftig brings up........


pub       rsa2048  2011-08-25[sc]
             8218f88849AAC522E94CF470A5E9288C4FA41FA
uid                        [full]  Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
sub       rsa2048  2011-08-25 [E]
sub       ed25519 2019-05-08 [A]

Offline

#10 2022-01-23 21:57:58

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

Re: gpg error(invalid or corrupted package (pgp signature)

sub    rsa4096 2019-05-08 [A]

pub    ed25519 2020-05-11 [SC]
          A2FF3A36AAA56654109064AB19802F8B0D70FC30
uid            [   undef   ]  Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
uid            [   undef   ]  Jan Alexander Steffens (heftig) <jan.steffens@itnglobal.com>
uid            [   full        ]  Jan Alexander Steffens (heftig) <heftig@archlinux.com>
sub    cv25519 2020-05-11 [E]
sub    cv25519 2020-05-11
sub    cv25519 2020-05-11 [A]

irrelavent but iguess my code copying is on point

Offline

#11 2022-01-23 21:59:22

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

Re: gpg error(invalid or corrupted package (pgp signature)

"[     s] on the third sub in the list and [/s        ] scratches things out" sorry for the bump

Last edited by 5m0k3l3ss (2022-01-23 22:03:50)

Offline

#12 2022-01-23 23:08:42

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

Re: gpg error(invalid or corrupted package (pgp signature)

so i reconfigured /etc/pacman.d/gnupg/pgp.conf to go specifically to the ubuntu keyserver repopulated the keyring after updating with -Sy and now i have the base pacstrap. hopefully everything goes okay with the full install. let me know if i should put solved or leave open.

Offline

#13 2022-03-17 22:46:25

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

Re: gpg error(invalid or corrupted package (pgp signature)

still have gpg errors on updates

Offline

#14 2022-03-17 22:50:10

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,324

Re: gpg error(invalid or corrupted package (pgp signature)

Scimmia wrote:

It doesn't say anything before that?

What does `file /mnt/var/cache/pacman/pkg/nss-3.74-1-x86_64.pkg.tar.zst` give you? How about `pacman-key --list-keys heftig`?

And you never answered the most important question here.

Offline

#15 2022-03-17 23:16:36

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

Re: gpg error(invalid or corrupted package (pgp signature)

for the file command there is no such file or directory

Offline

#16 2022-03-18 02:26:41

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,324

Re: gpg error(invalid or corrupted package (pgp signature)

Of course not, that's what it was 2 months ago. Check the files you're having problems with now.

Offline

#17 2022-03-18 03:47:26

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

Re: gpg error(invalid or corrupted package (pgp signature)

lol

Offline

#18 2022-03-18 03:52:34

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

Re: gpg error(invalid or corrupted package (pgp signature)

$ file /var/cache/pacman/pkg/ttc-iosevka=ss04=15.0.2-1-any.pkg.zst
/var/cache/pacman/pkg/ttc-iosevka=ss04=15.0.2-1-any.pkg.zst: cannot open `/var/cache/pacman/pkg/ttc-iosevka=ss04=15.0.2-1-any.pkg.zst' (No such file or directory)

Offline

#19 2022-03-18 04:08:04

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,324

Re: gpg error(invalid or corrupted package (pgp signature)

So I really need to state the obvious?

Don't delete it.

Edit: Or actually read the pkgname. That's not it.

Last edited by Scimmia (2022-03-18 04:08:32)

Offline

#20 2022-03-18 15:03:12

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

Re: gpg error(invalid or corrupted package (pgp signature)

no didnt need to state that......what im wondering is what is the cause that points to a solution

Offline

#21 2022-03-18 15:43:35

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

Re: gpg error(invalid or corrupted package (pgp signature)

im really confused i just ran pacman and its going through......? why?

Offline

#22 2022-03-21 13:50:23

daren_k
Member
Registered: 2020-02-13
Posts: 26

Re: gpg error(invalid or corrupted package (pgp signature)

I'm getting the same errors with archiso that I boot to RAM on a 2nd PC for some backup work.

Happened to me late into the 2022.02 image as well a couple days before 2022.03.
archlinux-keyring seems to be latest as it's stating to be reinstalling:

root@archiso ~ # pacman -Sy archlinux-keyring
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
warning: archlinux-keyring-20220224-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) archlinux-keyring-20220224-1

Total Download Size:   1.02 MiB
Total Installed Size:  1.44 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 archlinux-keyring-20220224-1-any                                                                  1040.1 KiB  8.00 MiB/s 00:00 [#############################################################################] 100%
(1/1) checking keys in keyring                                                                                                  [#############################################################################] 100%
downloading required keys...
:: Import PGP key 6D42BDD116E0068F, "Christian Hesse <eworm@archlinux.org>"? [Y/n] Y
error: key "Christian Hesse <eworm@archlinux.org>" could not be imported
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

Can work it around with editing /etc/pacman.conf variables

SigLevel = TrustAll
LocalFileSigLevel = TrustAll

and moving the packages away from /var/cache/pacman/pkg

mv /var/cache/pacman/pkg/*.zst /tmp
pacman -U /tmp/*.zst
rm /tmp/*.zst

Please fix this somehow though, it's very annoying.

Offline

#23 2022-03-21 13:57:18

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,324

Re: gpg error(invalid or corrupted package (pgp signature)

That's a different error. Please don't hijack threads.

Offline

#24 2022-03-21 14:36:52

daren_k
Member
Registered: 2020-02-13
Posts: 26

Re: gpg error(invalid or corrupted package (pgp signature)

No, I had the same ordeal like OP last month, pacman telling packages are corrupted, trying to refresh the keys - not functional, trying to remove that gnupg.d directory with the resource being busy, then finding the unsafe workaround until 2022.03 was released.

And here it is again ~10 days before the end of the month.

Last edited by daren_k (2022-03-21 14:38:04)

Offline

#25 2022-03-23 15:58:34

5m0k3l3ss
Member
Registered: 2022-01-23
Posts: 37

Re: gpg error(invalid or corrupted package (pgp signature)

not completely different but the man has it right not the same my arch works just the occasional gpg error

Offline

Board footer

Powered by FluxBB