You are not logged in.

#1 2022-02-08 16:17:39

Valentin_11
Member
Registered: 2022-02-08
Posts: 2

[SOLVED] Vulkan: driver only supports loader interface version 4

Hi,

I'm currently learning Vulkan through a tutorial. It worked well until the swapchain recreation step. Now the executable crashes because of this error when executing:

ERROR: [Loader Message] Code 0 : loader_scanned_icd_add: Driver /usr/lib/libvulkan_radeon.so supports Vulkan 1.2, but only supports loader interface version 4. Interface version 5 or newer required to support this version of Vulkan (Policy #LDP_DRIVER_7)

This happens whenever I try to execute my program or `vulkaninfo`. `vkcube` works.

I am using vulkan-radeon as a driver. I tried to use another driver but I get this error with amdvlk:

ERROR: [Loader Message] Code 0 : loader_scanned_icd_add: Driver /usr/lib/amdvlk64.so says it supports interface version 6 but still exports core entrypoints (Policy #LDP_DRIVER_6)

My system is up-to-date:

$pacman -Q | grep vulkan
lib32-vulkan-icd-loader 1.2.203-1
lib32-vulkan-intel 21.3.5-1
lib32-vulkan-radeon 21.3.5-1
vulkan-extra-layers 1.2.189.0-1
vulkan-extra-tools 1.2.189.0-1
vulkan-headers 1:1.3.204-1
vulkan-html-docs 1:1.3.204-1
vulkan-icd-loader 1.2.203-1
vulkan-radeon 21.3.5-1
vulkan-tools 1.2.203-1
vulkan-validation-layers 1.2.203-1

Last edited by Valentin_11 (2022-02-08 20:33:04)

Offline

#2 2022-02-08 17:10:12

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,029

Re: [SOLVED] Vulkan: driver only supports loader interface version 4

Afaik this shouldn't be fatal or lead to a crash, this error is generally normal with the current versions, and will likely "properly" fix itself with new mesa/driver updates.

You could try to downgrade vulkan-icd-loader to vulkan-icd-loader 1.2.199-2 to check whether it's really related to this message, it has afaik only been introduced in the 2.20xx series

Last edited by V1del (2022-02-08 17:12:33)

Offline

#3 2022-02-08 20:32:17

Valentin_11
Member
Registered: 2022-02-08
Posts: 2

Re: [SOLVED] Vulkan: driver only supports loader interface version 4

It worked with version 1.2.199-2, thank you!

The crash come from my code I guess as there is no error anymore but the program still crashes.

Last edited by Valentin_11 (2022-02-08 20:36:53)

Offline

Board footer

Powered by FluxBB