You are not logged in.

#1 2006-11-30 15:12:37

Bernie
Member
From: Oldebroek, Gelderland, The Ned
Registered: 2006-11-09
Posts: 40

Kernel panic - Attempted to kill init!

I've installed Arch Linux base on one of my PC's (a Pentium 3 450MHZ) via FTP installation. When I reboot the pc I get a bootscreen with 2 Arch Linux versions (Arch Linux and Arch Linux Fallback).

When I take Arch Linux Fallback everything works fine..... but when I try to boot Arch Linux I get an error:

Kinit: Cannot open root device hda3(3.3)
Kinit: init not found!
Kernel panic - not syncing. Attempted to kill init!

When have I done wrong!!!!? I've tried to reinstall Arch Linux but that doesn't change anything.....

please help me...

yours,

bernhard


Life is what you make of it.....

Offline

#2 2006-11-30 15:17:41

slubman
Member
From: Grenoble (France)
Registered: 2004-08-04
Posts: 86
Website

Re: Kernel panic - Attempted to kill init!

boot with archlinux fallback

log as root, then try to make :

mkinitcpio -g /boot/kernel26.img

then try to boot with the standard boot entry

Offline

#3 2006-11-30 15:25:01

Bernie
Member
From: Oldebroek, Gelderland, The Ned
Registered: 2006-11-09
Posts: 40

Re: Kernel panic - Attempted to kill init!

thanks. now it works. btw. does Arch Linux have desktop enviorment similar to windows? if so, how do I load it?


Life is what you make of it.....

Offline

#4 2006-11-30 15:29:06

slubman
Member
From: Grenoble (France)
Registered: 2004-08-04
Posts: 86
Website

Re: Kernel panic - Attempted to kill init!

Bernie wrote:

thanks. now it works. btw. does Arch Linux have desktop enviorment similar to windows? if so, how do I load it?

You can try one of the following:
· kde ( http://www.kde.org/ )
· gnome ( http://www.gnome.org/ )
· xfce ( http://www.xfce.org/ )

to install them with, arch, first install the X server

pacman -S xorg

then install the desktop

pacman -S kde

or

pacman -S gnome

or

pacman -S xfce

Offline

#5 2006-11-30 16:05:05

Bernie
Member
From: Oldebroek, Gelderland, The Ned
Registered: 2006-11-09
Posts: 40

Re: Kernel panic - Attempted to kill init!

when I do any of them I get the following error:

error: could not open sync database: extra
have you used --refresh yet?

when I try #pacman -S --refresh xorg I get a lot of errors:
error: cannot connect to {mirror}
gethostbyname: Resource temporarily unavaileble

After al the "cannot connect" errors the error:
failed to synchronise extra
error: could not open sync database: extra
have you used --refresh yet?


Life is what you make of it.....

Offline

#6 2006-11-30 16:14:24

Sigi
Member
From: Thurgau, Switzerland
Registered: 2005-09-22
Posts: 1,121

Re: Kernel panic - Attempted to kill init!

Do a pacman -Sy or better a pacman -Syu first


Dammit, haven't been here in a while. Still rocking Arch. smile

Offline

#7 2006-11-30 16:31:26

Bernie
Member
From: Oldebroek, Gelderland, The Ned
Registered: 2006-11-09
Posts: 40

Re: Kernel panic - Attempted to kill init!

Sigi wrote:

Do a pacman -Sy or better a pacman -Syu first

I get accactly the same error when I use that command... Could it be that there is something wrong in my hostfile? (the one where I configurate the ip addresse etc)


Life is what you make of it.....

Offline

#8 2006-11-30 17:19:49

stingray
Member
From: Lima, Peru SA
Registered: 2006-03-24
Posts: 188

Re: Kernel panic - Attempted to kill init!

Try pinging google to see if your internet connection is good.

#ping www.google.com

Offline

#9 2006-11-30 17:59:36

Bernie
Member
From: Oldebroek, Gelderland, The Ned
Registered: 2006-11-09
Posts: 40

Re: Kernel panic - Attempted to kill init!

I get this in result:

ping: Unknown host www.google.com


Life is what you make of it.....

Offline

#10 2006-11-30 18:01:52

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,770

Re: Kernel panic - Attempted to kill init!

well then your network is not set up correctly ....

put your rc.conf in arch pastebin please post link


Mr Green

Offline

#11 2006-11-30 18:14:40

Bernie
Member
From: Oldebroek, Gelderland, The Ned
Registered: 2006-11-09
Posts: 40

Re: Kernel panic - Attempted to kill init!

Mr Green wrote:

well then your network is not set up correctly ....

put your rc.conf in arch pastebin please post link

what do you meen?  :oops:  I'm completely new to Linux....


Life is what you make of it.....

Offline

#12 2006-11-30 18:21:41

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,770

Re: Kernel panic - Attempted to kill init!

sorry your file rc.conf is in /etc directory you need to set it up to get network running at boot

might to time to look at Arch Docs ;-)


Mr Green

Offline

#13 2006-11-30 18:44:09

Bernie
Member
From: Oldebroek, Gelderland, The Ned
Registered: 2006-11-09
Posts: 40

Re: Kernel panic - Attempted to kill init!

Mr Green wrote:

sorry your file rc.conf is in /etc directory you need to set it up to get network running at boot

might to time to look at Arch Docs ;-)

I'm logged in as root but I get an "access denied" message...


Life is what you make of it.....

Offline

#14 2006-11-30 19:19:30

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,770

Re: Kernel panic - Attempted to kill init!

I think you should read manual and see where you went wrong

Do not know what Linux knowledge you have but as a first distro Arch is not always a good idea

Of course there is Larch or Archie the live versions you could try [to get hang of it!]

Search forum for them

can you ....

cd /etc
more rc.conf

Mr Green

Offline

#15 2006-11-30 19:54:38

Bernie
Member
From: Oldebroek, Gelderland, The Ned
Registered: 2006-11-09
Posts: 40

Re: Kernel panic - Attempted to kill init!

@mr green: Arch Linux was suggested to me by someone who uses it allready. According to him it's a good OS to start with. My linux knowledge is 0.0 al best.....

cd /etc
more rc.conf

I can do that.... A screen is loaded with the rc.conf settings. When I scroll down to "networking" I see the following:

HOSTNAME: server

lo="192.168.2.4"
eth0="eth0 192.168.2.1 netmask 255.255.255.0 broadcast 192.168.0.255"
INTERFASES=(lo eth0)

gateway="default gw 192.168.2.1"
ROUTES=(!gateway)


I know that my modem/router uses a dhcp and that the address for the dhcp is 192.168.2.1 and that the ip address of the pc is 192.168.2.4.

What does the broadcast thing mean?
Is there anything I should change in the rc.conf? And if so, how?[/code]


Life is what you make of it.....

Offline

#16 2006-11-30 20:14:05

slubman
Member
From: Grenoble (France)
Registered: 2004-08-04
Posts: 86
Website

Re: Kernel panic - Attempted to kill init!

Your rc.conf is not good

In your case, the networking section should look like that (if you use DHCP):

#
# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
HOSTNAME="server"
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
eth0="dhcp"
INTERFACES=(lo eth0)
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
# gateway="default gw 192.168.2.1"
ROUTES=(!gateway)
#
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network-profiles
#
#NET_PROFILES=(main)

Offline

#17 2006-11-30 20:24:54

marxav
Member
From: Gatineau, PQ, Canada
Registered: 2006-09-24
Posts: 386

Re: Kernel panic - Attempted to kill init!

gateway="default gw 192.168.2.1"
ROUTES=(gateway)

as opposed to :

# gateway="default gw 192.168.2.1"
ROUTES=(!gateway)

Offline

#18 2006-11-30 20:33:22

slubman
Member
From: Grenoble (France)
Registered: 2004-08-04
Posts: 86
Website

Re: Kernel panic - Attempted to kill init!

marxav wrote:

gateway="default gw 192.168.2.1"
ROUTES=(gateway)

as opposed to :

# gateway="default gw 192.168.2.1"
ROUTES=(!gateway)

That will not solve the problem,because in his rc.conf, the loopback interface (lo) is misconfigured, theeth1 has the sameIP as the gateway (another problem)and also has you show it, the gateway is not activated. But his router is also a dhcp server, so if there is no server running, he can use dhcp wink

Offline

#19 2006-11-30 20:46:49

Bernie
Member
From: Oldebroek, Gelderland, The Ned
Registered: 2006-11-09
Posts: 40

Re: Kernel panic - Attempted to kill init!

okay. that's what my rc.conf should look like. Now, how can I change it as I get an error when I try to open /etc/rc.conf

-bash: /etc/rc.conf: Access denied


Life is what you make of it.....

Offline

#20 2006-11-30 20:49:30

chrismortimore
Member
From: Edinburgh, UK
Registered: 2006-07-15
Posts: 655

Re: Kernel panic - Attempted to kill init!

Bernie wrote:

okay. that's what my rc.conf should look like. Now, how can I change it as I get an error when I try to open /etc/rc.conf

-bash: /etc/rc.conf: Access denied

Make sure you are root. Check the output of "ls -l /etc/ | grep rc.conf" to make sure the file has read/write permissions for root.


Desktop: AMD Athlon64 3800+ Venice Core, 2GB PC3200, 2x160GB Maxtor DiamondMax 10, 2x320GB WD Caviar RE, Nvidia 6600GT 256MB
Laptop: Intel Pentium M, 512MB PC2700, 60GB IBM TravelStar, Nvidia 5200Go 64MB

Offline

#21 2006-11-30 20:56:47

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,770

Re: Kernel panic - Attempted to kill init!

-rw-r--r--  1 root  root    1734 2006-11-16 14:10 rc.conf

should look like that ....


Mr Green

Offline

#22 2006-11-30 21:16:24

Bernie
Member
From: Oldebroek, Gelderland, The Ned
Registered: 2006-11-09
Posts: 40

Re: Kernel panic - Attempted to kill init!

chrismortimore wrote:

Make sure you are root. Check the output of "ls -l /etc/ | grep rc.conf" to make sure the file has read/write permissions for root.

output:
-rw-r--r-- 1 root root 2772 nov 30 03:30 /etc/rc.conf


Life is what you make of it.....

Offline

#23 2006-11-30 21:17:17

chrismortimore
Member
From: Edinburgh, UK
Registered: 2006-07-15
Posts: 655

Re: Kernel panic - Attempted to kill init!

Bernie wrote:

output:
-rw-r--r-- 1 root root 2772 nov 30 03:30 /etc/rc.conf

And you are definitely root?


Desktop: AMD Athlon64 3800+ Venice Core, 2GB PC3200, 2x160GB Maxtor DiamondMax 10, 2x320GB WD Caviar RE, Nvidia 6600GT 256MB
Laptop: Intel Pentium M, 512MB PC2700, 60GB IBM TravelStar, Nvidia 5200Go 64MB

Offline

#24 2006-11-30 21:18:01

Bernie
Member
From: Oldebroek, Gelderland, The Ned
Registered: 2006-11-09
Posts: 40

Re: Kernel panic - Attempted to kill init!

well. if root@server meens that I'm logged as root then I am wink


Life is what you make of it.....

Offline

#25 2006-11-30 21:30:13

chrismortimore
Member
From: Edinburgh, UK
Registered: 2006-07-15
Posts: 655

Re: Kernel panic - Attempted to kill init!

Bernie wrote:

well. if root@server meens that I'm logged as root then I am wink

A simple "yes" would suffice.

Does "cat /etc/rc.conf" still yield access denied?  What editor are you using to try and open the file?


Desktop: AMD Athlon64 3800+ Venice Core, 2GB PC3200, 2x160GB Maxtor DiamondMax 10, 2x320GB WD Caviar RE, Nvidia 6600GT 256MB
Laptop: Intel Pentium M, 512MB PC2700, 60GB IBM TravelStar, Nvidia 5200Go 64MB

Offline

Board footer

Powered by FluxBB