You are not logged in.

#1 2022-02-24 12:09:05

climb4life
Member
Registered: 2022-02-24
Posts: 2

[SOLVED] Cannot upgrade system because of expat and lib32-expat

I cannot update my system with "pacman -Syu".
The output is the following:

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing expat (2.4.6-1) breaks dependency 'expat=2.4.5' required by lib32-expat

Apparently both packages were updated to version 2.4.6-1 about an hour ago. However, according to the package description of lib32-expat it's actually dependent on expat=2.4.6 and not 2.4.5.
Is there something I'm missing here?

Last edited by climb4life (2022-02-24 15:21:05)

Offline

#2 2022-02-24 12:28:20

mpan
Member
Registered: 2012-08-01
Posts: 851
Website

Re: [SOLVED] Cannot upgrade system because of expat and lib32-expat

Are you using the same mirror for both the core and multilib repositories? If no: use the same mirror for all official repos.
If yes: are both repos updated on your mirror? See what versions this command reports:

pacman -Si expat expat-lib32

Do they differ? If yes, wait a bit. The packages are very fresh. Perhaps the mirror didn’t synchronize both repositories at the same time.

In either case, please tell which mirror you are using. The exact line from your config. I believe that with the rsync invocation recommended for mirror administrators this should have never happen, so the situation may require reporting.

Last edited by mpan (2022-02-24 12:36:11)


Sometimes I seem a bit harsh — don’t get offended too easily! PGP: 7C848198AE93D3BB

Offline

#3 2022-02-24 13:32:54

climb4life
Member
Registered: 2022-02-24
Posts: 2

Re: [SOLVED] Cannot upgrade system because of expat and lib32-expat

If you are referring to the settings in /etc/pacman.conf then the include line is set to my mirrorlist for all repositories (namely "Include = /etc/pacman.d/mirrorlist").
The first entry in the mirrorlist would be https://mirrors.neusoft.edu.cn/archlinux/$repo/os/$arch.

The full output of pacman -Si is the following:

Repository      : core
Name            : expat
Version         : 2.4.6-1
Description     : An XML parser library
Architecture    : x86_64
URL             : https://libexpat.github.io/
Licenses        : MIT
Groups          : None
Provides        : libexpat.so=1-64
Depends On      : glibc
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 117.32 KiB
Installed Size  : 407.94 KiB
Packager        : David Runge <dvzrv@archlinux.org>
Build Date      : Sun Feb 20 20:42:51 2022
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Repository      : multilib
Name            : lib32-expat
Version         : 2.4.5-1
Description     : An XML Parser library
Architecture    : x86_64
URL             : https://libexpat.github.io/
Licenses        : MIT
Groups          : None
Provides        : None
Depends On      : expat=2.4.5  lib32-glibc
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 72.99 KiB
Installed Size  : 197.10 KiB
Packager        : David Runge <dvzrv@archlinux.org>
Build Date      : Sat Feb 19 10:21:43 2022
Validated By    : MD5 Sum  SHA-256 Sum  Signature

...seems like multilib isn't updated yet on the mirror (the problem is still there).
I switched to https://mirror.pkgbuild.com/$repo/os/$arch and it works with that one.
Thanks for your help so far.

Offline

#4 2022-02-24 13:56:04

mpan
Member
Registered: 2012-08-01
Posts: 851
Website

Re: [SOLVED] Cannot upgrade system because of expat and lib32-expat

It may be worth notifying that mirror’s administrators about the problem or opening a mirror bug report (Project: Arch Linux, Category: Mirrors) if you have the bug tracker account. I myself can’t even connect to the mirror and neusoft.edu.cn status log looks pretty unappealing.

While reporting/contacting, please remember those are volunteers that run it for the community without receiving financial compensation from us. The message tone should be chosen appropriately, without assuming malice or — unless proven otherwise — blatant lack of due diligence.

Last edited by mpan (2022-02-24 13:56:39)


Sometimes I seem a bit harsh — don’t get offended too easily! PGP: 7C848198AE93D3BB

Offline

Board footer

Powered by FluxBB