You are not logged in.

#1 2006-12-04 20:32:38

Shagbag
Member
Registered: 2006-10-25
Posts: 259

WPA-PSK configuration [RESOLVED]

I'm doing something really stupid but as I don't know much about linux - let along wireless linux - I just know I'm doing something INSANELY stupid.

I finally got my wireless working thanks to chrismortimore and tardo smile  But it's working with its front door wide open. I want to secure it with WPA-PSK.

I've got a Netgear DG834GT ADSL Modem Router.  I'm manually configuring it and it gives me the following four security options:

1. Disable
2. WEP (Wired Equivalent Privacy)
3. WPA-PSK (Wi-Fi Protected Access Pre-Shared Key)
4.  WPA-802.1x

I've been using it on 1. for a couple of days now without any problems.  However, I switched it to 3. (WPA-PSK) and it asked me for a 8-63 digit Network Key.  I set it with 4rchL1nuxR0ck5.

I then altered my /etc/conf.d/wireless from:

wlan_eth2="eth2 essid ShagNet"

which I know works to:

wlan_eth2="eth2 essid ShagNet key s:4chL1nuxR0ck5"

I rebooted but it didn't work.  I couldn't get any web pages to load in Konqueror.

Can someone please tell me what I'm doing wrong?

Offline

#2 2006-12-04 23:26:24

iggy
Member
From: Germany, L.E. - Leipzig
Registered: 2004-10-17
Posts: 367

Re: WPA-PSK configuration [RESOLVED]

for wpa you need the wpa_supplicant. install it and then edit and USE your network-profile (/etc/network-profiles/...) like this:

# Wireless Settings (optional)
ESSID=ShagNet
#KEY=
IWOPTS="mode managed essid $ESSID channel ?"
...
USEWPA="yes"           # start wpa_supplicant with the profile
...
AUTOWPA="yes"          # automatically configure WPA
PASSKEY="4rchL1nuxR0ck5"             # wpa passkey/phrase. for use with AUTOWPA
...

for this your rc.conf must look like this:

...
INTERFACES=(lo !eth0 !foo)
...
NET_PROFILES=(menu)
...

hope that this will help you...

mfg iggy


sorry for my bad english smile

Offline

#3 2006-12-04 23:39:45

codemac
Member
From: North Carolina
Registered: 2005-05-13
Posts: 776
Website

Re: WPA-PSK configuration [RESOLVED]

wow, I didn't know about AUTOWPA.

That should be advertised a little more smile

Offline

#4 2006-12-05 13:15:59

Shagbag
Member
Registered: 2006-10-25
Posts: 259

Re: WPA-PSK configuration [RESOLVED]

Thanks iggy.  I've got it working now.  big_smile

Offline

#5 2006-12-05 13:39:02

Snarkout
Member
Registered: 2005-11-13
Posts: 542

Re: WPA-PSK configuration [RESOLVED]

If you want something a little more point and click, take a look at knetworkmanager.


Unthinking respect for authority is the greatest enemy of truth.
-Albert Einstein

Offline

#6 2006-12-05 23:38:52

iggy
Member
From: Germany, L.E. - Leipzig
Registered: 2004-10-17
Posts: 367

Re: WPA-PSK configuration [RESOLVED]

codemac wrote:

wow, I didn't know about AUTOWPA.

That should be advertised a little more smile

yeah, i saw it a week ago while making a new profile! sometimes it is good to check the initscript-updates. smile


sorry for my bad english smile

Offline

Board footer

Powered by FluxBB